Voici quelques tâches de base de données que vous pouvez effectuer pour vous aider à apprendre à utiliser Microsoft Access 2010.

 

Contenu de cet article

Qu’est-ce qu’Access ?

Access 2010 est un outil de conception et de déploiement d’application de base de données que vous pouvez utiliser pour assurer le suivi des informations importantes. Vous pouvez conserver vos données sur votre ordinateur ou les publier sur le web pour que d’autres utilisateurs utilisent votre base de données avec un navigateur web.

De nombreuses personnes commencent à utiliser Access lorsque le programme qu’elles utilisent pour suivre quelque chose devient progressivement moins adapté à la tâche. Par exemple, supposons que vous êtes un planificateur d’événements et que vous voulez effectuer le suivi de tous les détails que vous devez gérer pour réussir vos événements. À cet effet, si vous utilisez un traitement de texte ou un tableur, vous pouvez facilement créer des problèmes avec des données en double et incohérentes. Vous pouvez utiliser un logiciel de calendrier, mais le suivi des informations financières dans un calendrier n’est pas adapté.

Bases de données relationnelles dans Access

Vous avez parfois besoin d’une base de données relationnelle pour suivre de telles informations, c’est-à-dire, une base de données qui a été séparée en collections de données plus petites (appelées tables) afin d’éliminer la redondance, puis liées sur la base de bits d’informations courants (appelés champs). Par exemple, une base de données relationnelle de planification d’événements peut contenir une table avec des informations client, une table avec des informations sur le fournisseur et une table avec des informations sur les événements. La table avec des informations sur les événements peut avoir un champ pour le relier à la table Client, ainsi qu’un champ pour le l’établir avec la table du fournisseur. Ainsi, si le numéro de téléphone d’un fournisseur a changé, les informations peuvent être modifiées une fois dans la table Fournisseur, plutôt que dans tous les événements qui ont impliqué le fournisseur.

Access est un outil qui vous permet de développer rapidement et facilement des applications de base de données relationnelles qui vous aident à gérer les informations. Vous pouvez créer une base de données pour assurer le suivi d’à peu près toutes sortes d’informations, telles que le stock, les contacts professionnels ou les processus d’entreprise. En fait, Access est livré avec des modèles que vous pouvez utiliser immédiatement pour effectuer le suivi d’une variété d’informations, ce qui permet même aux débutants de se faciliter la tâche.

Lorsque vous ouvrez Access

Lorsque vous démarrez Access 2010, vous voyez le Microsoft Office Backstage dans lequel vous pouvez obtenir des informations sur la base de données actuelle, créer une base de données, ouvrir une base de données existante et afficher le contenu en vedette de Office.com.

Mode Backstage dans Access 2010

Le vue Backstage contient également de nombreuses autres commandes que vous pouvez utiliser pour ajuster, gérer ou partager vos bases de données. En général, les commandes du vue Backstage s’appliquent à des bases de données entières, et non à des objets à l’intérieur d’une base de données.

Remarque : Vous pouvez passer en affichage Backstage à tout moment en cliquant sur l’onglet Fichier.

Haut de page

Rechercher et appliquer un modèle

Access vous offre un large éventail de modèles que vous pouvez utiliser pour accélérer le processus de création de votre base de données. Un modèle est une base de données prête à l’emploi qui contient l’ensemble des tables, requêtes, formulaires et états nécessaires pour effectuer une tâche spécifique. Par exemple, certains modèles peuvent être utilisés pour suivre des problèmes, gérer des contacts ou conserver un dossier de dépenses. Certains modèles contiennent quelques exemples d’enregistrements pour en faire une démonstration. Vous pouvez utiliser les bases de données de modèle telles qu’elles sont, ou les personnaliser pour répondre à vos besoins.

Pour rechercher et appliquer un modèle à votre base de données, voici comment faire :

  1. Sous l’onglet Fichier, cliquez sur Nouveau.

  2. Sous Modèles disponibles,faites l’une des choses suivantes :

    • Pour réutiliser un modèle que vous avez utilisé récemment, cliquez sur Modèles récents,puis sélectionnez le modèle de votre choix.

    • Pour utiliser un modèle que vous avez déjà installé, cliquez sur Mes modèles,puis sélectionnez le modèle de votre choix.

    • Pour trouver un modèle sur Office.com, sous Modèles Office.com,cliquez sur une catégorie de modèles, sélectionnez le modèle de votre choix, puis cliquez sur Télécharger pour télécharger le modèle à partir d’Office .com sur votre ordinateur.

      Vous pouvez également rechercher des modèles sur un Office.com à partir d’Access. Dans la zone Rechercher Office.com des modèles, tapez un ou plusieurs termes de recherche, puis cliquez sur la flèche pour effectuer une recherche.

  3. Vous pouvez également cliquer sur l’icône de dossier en côté de la zone Nom de fichier pour rechercher un emplacement dans lequel vous voulez créer la base de données. Si vous n’indiquez pas un emplacement spécifique, Access crée la base de données à l’emplacement par défaut qui s’affiche sous la zone Nom de fichier.

  4. Cliquez sur Créer.

Access crée la base de données et l’ouvre pour l’utiliser.

Haut de page

Créer une base de données entièrement nouvelle

Si vous souhaitez une présentation plus complète des concepts derrière l’utilisation d’Access pour créer une base de données, consultez l’article Concepts de base sur la conception d’une base de données.

Si aucun des modèles ne répond à vos besoins, ou si vous avez des données dans un autre programme que vous voulez utiliser dans Access, vous pouvez décider de créer une base de données de toutes pièces. Dans Access 2010, vous avez le choix entre une base de données de bureau standard ou une base de données web.

Pour plus d’informations sur les bases de données web, voir l’article Créer une base de données à partager sur le web.

Pour créer une base de données, vous pouvez :

  1. Démarrez Access.

  2. Sous l’onglet Nouveau en backstage, cliquez sur Base de données vide ou Base de données web vide.

    Important : Le choix que vous faites ici détermine les fonctionnalités disponibles dans la base de données. Les bases de données de bureau ne peuvent pas être publiées sur le web, et les bases de données web ne peuvent pas prendre en charge certaines fonctionnalités de bureau, telles que les requêtes Totaux.

  3. À droite, tapez un nom pour votre base de données dans la zone Nom de fichier.

    Pour modifier l’emplacement dans lequel vous créez le fichier, cliquez sur Parcourir les texte de remplacementen face de la zone Nom de fichier, accédez au nouvel emplacement et sélectionnez-le, puis cliquez sur OK.

  4. Cliquez sur Créer.

    Access crée la base de données, puis ouvre une table vide (nommée Table1) dans mode Feuille de données.

  5. Access place le curseur dans la première cellule vide de la colonne Cliquer pour ajouter de la nouvelle table.

    Pour ajouter des données, commencez à taper, ou vous pouvez coller des données d’une autre source, comme décrit dans la section Coller les données d’une autre source dans une table Access,plus loin dans cet article.

    Remarques : 

    • La saisie de données en vue Feuille de données est semblable à la saisie de données dans une feuille de calcul Excel. La principale restriction est que les données doivent être entrées dans des lignes et colonnes contiguës, en commençant par le coin supérieur gauche de la feuille de données. Vous ne devez pas essayer de mettre en forme vos données en incluant des lignes ou des colonnes vides comme vous pouvez le faire dans une feuille de calcul Excel, car cette opération perd de l’espace dans votre tableau. La table ne contient que vos données. Toutes les présentations visuelles de ces données seront faites dans les formulaires et rapports que vous concevez ultérieurement.

    • La structure du tableau est créée lorsque vous entrez des données. Chaque fois que vous ajoutez une nouvelle colonne à la feuille de données, un nouveau champ est défini dans la table. Access définit la type de données du champ en fonction du type de données que vous entrez. Par exemple, si vous avez une colonne dans laquelle vous avez entré uniquement des valeurs de date, Access définira le type de données de ce champ sur Date/Heure. Si vous tentez par la suite d’entrer une valeur autre qu’une date (par exemple, un nom ou un numéro de téléphone) dans ce champ, Access affiche un message vous informant que la valeur ne correspond pas au type de données de la colonne. Si possible, planifiez votre tableau de sorte que chaque colonne contienne le même type de données (texte, dates, nombres, etc.). Cela facilite la build de requêtes, de formulaires et d’états qui sélectionnent uniquement les données que vous souhaitez.

Si vous ne voulez pas encore entrer de données, cliquez sur Fermer Image du bouton.

Remarque : Access supprime Table1 si vous le fermez sans l’enregistrer.

Haut de page

Ouvrir une base de données Access existante

Conseil : Pour ouvrir rapidement l’une des dernières bases de données ouvertes, sous l’onglet Fichier, cliquez sur Récents,puis sur le nom du fichier.

  1. Sous l’onglet Fichier, cliquez sur Ouvrir.

  2. Cliquez sur un raccourci dans la boîte de dialogue Ouvrir ou, dans la zone Regarder dans, cliquez sur le lecteur ou le dossier contenant la base de données de votre choix.

  3. Dans la liste des dossiers, double-cliquez sur les dossiers jusqu’à ce que vous ouvrez le dossier qui contient la base de données.

  4. Lorsque vous trouvez la base de données, faites l’une des choses suivantes :

    • Pour ouvrir la base de données en mode d’ouverture par défaut, double-cliquez dessus.

    • Pour ouvrir la base de données pour un accès partagé dans un environnement multi-utilisateur, afin que les autres utilisateurs et vous-même pouvez lire et écrire dans la base de données en même temps, cliquez sur Ouvrir.

    • Pour ouvrir la base de données en lecture seule afin de pouvoir l’afficher mais ne pas la modifier, cliquez sur la flèche en regard du bouton Ouvrir, puis sur Ouvrir en lecture seule.

    • Pour ouvrir la base de données pour y accéder en exclusif afin que personne d’autre ne puisse l’ouvrir une fois celle-ci ouverte, cliquez sur la flèche en haut à côté du bouton Ouvrir, puis cliquez sur Ouvrir en exclusif.

    • Pour ouvrir la base de données en lecture seule, cliquez sur la flèche en bas du bouton Ouvrir, puis cliquez sur Ouvrir en lecture seule Les autres utilisateurs peuvent toujours ouvrir la base de données, mais ils n’ont accès qu’en lecture seule.

Si vous ne trouvez pas la base de données que vous souhaitez ouvrir    

  1. Dans la boîte de dialogue Ouvrir, cliquez sur le raccourci Mon ordinateur ou, dans la zone Regarder dans, cliquez sur Mon ordinateur.

  2. Dans la liste des lecteurs, cliquez avec le bouton droit sur le lecteur que vous pensez contenir la base de données, puis cliquez sur Rechercher.

  3. Entrez vos critères de recherche, puis appuyez sur Entrée pour rechercher la base de données.

  4. Si la base de données est trouvée, ouvrez-la en double-cliquant dessus dans la boîte de dialogue Résultats de la recherche.

    Étant donné que la recherche a été lancée à partir de la boîte de dialogue Ouvrir, vous devez cliquer sur Annuler dans cette boîte de dialogue pour que la base de données s’ouvre.

Vous pouvez ouvrir directement un fichier de données dans un format de fichier externe (par exemple, dBASE, Paradox, Microsoft Exchange ou Excel). Vous pouvez également ouvrir directement tout source de données ODBC, comme Microsoft SQL Server ou Microsoft FoxPro. Access crée automatiquement une nouvelle base de données Access dans le même dossier que le fichier de données, et ajoute des liens vers chaque table de la base de données externe.

Haut de page

Commencer à utiliser votre nouvelle base de données

Selon le modèle que vous avez utilisé, vous devrez peut-être faire une ou plusieurs des choses suivantes pour commencer à utiliser la nouvelle base de données :

  • Si Access affiche une boîte de dialogue Connexion avec une liste vide d’utilisateurs, utilisez la procédure suivante pour commencer :

    1. Cliquez sur Nouvel utilisateur.

    2. Remplissez le formulaire Détails de l’utilisateur.

    3. Cliquez sur Enregistrer et fermer.

    4. Sélectionnez le nom d’utilisateur que vous ouvrez, puis cliquez sur Connexion.

  • Si Access affiche une feuille de données vide, vous pouvez commencer à taper des données directement dans cette feuille de données, ou cliquer sur d’autres boutons et onglets pour explorer la base de données.

  • Si Access affiche une page de mise en page De mise en page, vous pouvez cliquer sur les liens de cette page pour en savoir plus sur la base de données, ou cliquer sur d’autres boutons et onglets pour explorer la base de données.

  • Si Access affiche un message d’avertissement de sécurité dans la barre des messages et que vous faites confiance à la source du modèle, cliquez sur Activer le contenu. Si la base de données nécessite une connexion, vous devrez vous connecter à nouveau.

Pour les bases de données de bureau et web, vous souhaitez également commencer par l’une des étapes suivantes :

Haut de page

Ajouter un tableau

Vous pouvez ajouter une nouvelle table à une base de données existante à l’aide des outils du groupe Tables sous l’onglet Créer.

Groupe Tables de l’onglet Créer

Remarque : Dans une base de données web, seule la commande Table est disponible dans le groupe Tables.

Quel que soit le mode d’affichage dans lequel vous commencez, vous pouvez toujours basculer vers l’autre affichage à l’aide des boutons d’affichage dans la barre d’état de la fenêtre Access.

Créer une table vide en vue Feuille de données    En affichage Feuille de données, vous pouvez entrer des données immédiatement et laisser Access créer la structure de la table en arrière-plan. Les noms de champs sont attribués numériquement (Champ1, Champ2, etc.) et Access définit le type de données de champ, en fonction du type de données que vous entrez.

  1. Sous l’onglet Créer, dans le groupe Tables, cliquez sur Tableau Image du bouton.

  2. Access crée la table, puis place le curseur dans la première cellule vide de la colonne Cliquer pour ajouter.

  3. Pour ajouter des données, commencez à taper dans la première cellule vide, ou collez les données d’une autre source, comme décrit plus loin dans cet article.

    • Pour renommer une colonne (champ), double-cliquez sur son en-tête, puis tapez le nouveau nom.

      Conseil : Donnez un nom significatif à chaque champ afin de savoir ce qu’il contient sans avoir à examiner les données.

    • Pour déplacer une colonne, sélectionnez-la en cliquant sur son en-tête de colonne, puis en la faisant glisser vers l’endroit voulu. Vous pouvez également sélectionner plusieurs colonnes contiguës et les faire glisser toutes ensemble vers un nouvel emplacement.

      Pour ajouter des champs à votre table, vous pouvez commencer à taper dans le groupe Cliquer pour ajouter une colonne en affichage Feuille de données ou ajouter de nouveaux champs à l’aide des commandes du groupe Ajouter & Supprimer sous l’onglet Champs.

Créer une table en mode Création    En mode Création, vous devez d’abord créer la structure de la nouvelle table. Vous passez ensuite en mode Feuille de données pour entrer des données, ou vous entrez vos données à l’aide d’une autre méthode, comme avec un formulaire.

Le mode Création n’est pas disponible pour les tables d’une base de données web.

  1. Sous l’onglet Créer, dans le groupe Tables, cliquez sur Création de table. Image du bouton

  2. Pour chaque champ de votre table, tapez un nom dans la colonne Nom du champ, puis sélectionnez un type de données dans la liste Type de données.

  3. Vous pouvez entrer des informations supplémentaires pour chaque champ dans la colonne Description. La description que vous entrez s’affiche dans la barre d’état lorsque le point d’insertion se trouve dans ce champ, et est utilisée comme texte de barre d’état pour les contrôles que vous créez en faisant glisser le champ du volet Liste de champs vers un formulaire ou état, et pour tous les contrôles créés pour ce champ par l’Assistant Formulaire ou l’Assistant État.

  4. Après avoir ajouté tous vos champs, enregistrez la table :

    • Sous l’onglet Fichier, cliquez sur Enregistrer.

  5. Vous pouvez commencer à entrer des données dans la table à tout moment en passant en mode Feuille de données, en cliquant dans la première cellule vide, puis en tapant. Vous pouvez également coller des données provenant d’une autre source, comme décrit dans la section suivante.

Créer une table basée sur une liste SharePoint    Avec une liste SharePoint, vos données peuvent être utilisées par des personnes qui n’ont pas Access. En outre, les données de liste sont stockées sur un serveur, ce qui offre généralement une meilleure protection contre la perte de données que les fichiers stockés sur un ordinateur de bureau. Vous pouvez commencer avec une nouvelle liste ou créer un lien vers une liste existante. Vous devez avoir les autorisations suffisantes sur le site SharePoint sur lequel vous voulez créer la liste. cette option peut varier selon le site. Contactez donc votre administrateur SharePoint pour plus d’informations sur les options qui s’offrent à vous.

Cette fonctionnalité n’est pas disponible dans une base de données web.

  1. Sous l’onglet Création, dans le groupe Tables, cliquez sur Listes SharePoint.

  2. Vous pouvez utiliser l’un des modèles de liste pour créer une liste SharePoint standard, telle que Contacts ou Événements.

    Vous pouvez également choisir de créer une liste personnalisée, ou de lier ou d’importer une liste existante. Cliquez sur l’option souhaitée.

  3. Si vous choisissez l’un des modèles de liste ou pour créer une liste personnalisée, la boîte de dialogue Créer une liste s’ouvre pour vous guider tout au long du processus. Si vous choisissez d’utiliser une liste existante, la boîte de dialogue Données externes s’ouvre pour vous aider.

Pour plus d’informations sur les tables, voir l’article Présentation des tables.

Haut de page

Coller des données d’une autre source dans une table Access

Si vos données sont actuellement stockées dans un autre programme, tel qu’Excel, vous pouvez les copier et les coller dans une table Access. En règle générale, cela fonctionne mieux si vos données sont déjà séparées en colonnes, comme dans une feuille de calcul Excel. Si vos données sont dans un programme de traitement de texte, vous devez d’abord séparer les colonnes de données à l’aide d’onglets, ou convertir les données en tableau dans le programme de traitement de texte, puis copier les données. Si vos données ont besoin d’être modifiées ou modifiées (par exemple, séparant les noms complets en prénoms et noms), vous pouvez le faire avant de copier les données, particulièrement si vous n’êtes pas familiarisé avec Access.

Lorsque vous collez des données dans une table vide, Access définit le type de données de chaque champ en fonction du type de données qu’il y trouve. Par exemple, si un champ ne contient que des valeurs de date, Access applique le type de données Date/heure à ce champ. Si le champ ne contient que les mots « oui » et « non », Access applique le type de données Oui/Non au champ.

Access nomme les champs en fonction de ce qu’il trouve dans la première ligne de données passées. Si le type de la première ligne de données est semblable à celui des lignes qui suivent, Access détermine que la première ligne fait partie des données et affecte les noms génériques aux champs (Champ1, Champ2, et ainsi de suite). Si la première ligne de données ne ressemble pas aux lignes qui suivent, Access utilise la première ligne comme noms de champs et exclut la première ligne dans les données réelles.

Si Access affecte des noms de champs génériques, vous devez renommer les champs dès que possible afin d’éviter toute confusion. Procédez comme suit :

  1. Sous l’onglet Fichier, cliquez sur Enregistrer pour enregistrer la table.

  2. En mode Feuille de données, double-cliquez sur chaque en-tête de colonne, puis tapez un nom pour la colonne.

  3. Enregistrez de nouveau la table.

Haut de page

Étapes suivantes

Le reste du processus de conception varie en fonction de vos objectifs, mais vous pouvez envisager de créer des requêtes, des formulaires, des états et des macros. Cet article ne fournit aucune information sur la création d’objets de base de données supplémentaires.

Pour plus d’informations, voir les articles suivants :

Haut de page

Importer des données à partir d’une feuille de calcul ou d’un autre programme

Si vous avez l’habitude d’utiliser d’autres programmes de base de données ou de feuille de calcul, vous connaissez probablement les principes de base de fonctionnement de ces applications et les bases de données utilisées. Access diffère de beaucoup d’autres applications de base de données en vous permettant de créer des bases de données relationnelles, et diffère davantage de la plupart des tableurs en offrant des outils pour développer des requêtes, formulaires et états sophistiqués. Access propose également de nombreuses options pour travailler avec d’autres programmes de base de données, tels que SQL Server.

Importer une feuille de calcul Excel dans Access

De nombreuses personnes commencent à explorer Access après avoir commencé à créer une liste dans Excel. Excel est l’endroit idéal pour commencer une liste, mais à mesure qu’elle s’agrandit, il devient plus difficile de s’organiser et de rester à jour. Le déplacement de la liste vers Access constitue généralement l’étape logique suivante.

Une table de base de données est similaire en structure à une feuille de calcul, dans la même façon que les données sont stockées dans des lignes et des colonnes. Par conséquent, il est généralement facile d’importer une feuille de calcul dans une table de base de données. La principale différence entre le stockage de vos données dans une feuille de calcul et dans une base de données est l’organisation des données. L’importation de la feuille de calcul entière en tant que nouvelle table dans une base de données ne résout pas les problèmes associés à l’organisation et la mise à jour de vos données, en particulier si votre feuille de calcul contient des données redondantes. Pour résoudre ces problèmes, vous devez fractionner les données de la feuille de calcul en tables distinctes contenant chacune des données connexes. Pour plus d’informations sur la façon d’organiser les données dans vos tables, consultez l’article « Principes de base de la conception d’une base de données».

Access propose l’Assistant Analyse de table, qui peut vous aider à effectuer ce processus. Après avoir importé vos données dans une table, l’Assistant vous aide à le fractionner au cours de tables distinctes, chacune contenant des données qui ne sont pas dupliquées dans les autres tables. L’Assistant crée également les relations nécessaires entre les tables.

Haut de page

Importer une feuille de calcul Excel en tant que tableau dans une nouvelle base de données

  1. Sous l’onglet Fichier, cliquez surNouveau, puis sur Base de données vide.

  2. Tapez un nom pour la nouvelle base de données dans la zone Nom de fichier, puis cliquez sur Créer.

    La nouvelle base de données s’ouvre et Access crée une table vide, Table1.

  3. Fermer Table1.

    Lorsque vous êtes invité à enregistrer les modifications apportées à la conception de Table1, cliquez sur Non.

  4. Sous l’onglet Données externes, dans le groupe Importer & liaison, cliquez sur Excel. Image du bouton

  5. Dans la boîte de dialogue Données externes, cliquez sur Parcourir.

  6. Utilisez la boîte de dialogue Ouvrir un fichier pour localiser votre fichier.

  7. Sélectionnez le fichier, puis cliquez sur Ouvrir.

  8. Dans la boîte de dialogue Données externes, assurez-vous que l’option Importer les données sources dans une nouvelle table est sélectionnée dans la base de données actuelle.

  9. Cliquez sur OK.

    L’Assistant Importation de feuille de calcul démarre et vous pose quelques questions sur vos données.

  10. Suivez les instructions, en cliquant sur Suivantou Retour pour parcourir les pages. Sur la dernière page de l’Assistant, cliquez sur Terminer.

    Remarque : Access vous demande si vous voulez enregistrer les détails de l’opération d’importation que vous voulez terminer. Si vous pensez recommencer la même opération d’importation, cliquez sur Oui,puis entrez les détails. Vous pouvez alors reproduire facilement l’opération à l’avenir en cliquant sur Importations enregistrées dans le groupe Importer sous l’onglet Données externes. Si vous ne voulez pas enregistrer les détails de l’opération, cliquez sur Fermer.

Access importe les données dans une nouvelle table, puis les affiche sous Toutes les tables dans le volet de navigation.

Haut de page

Utiliser l’Assistant Analyse de table pour organiser vos données

Une fois vos données importées dans une table Access, vous pouvez utiliser l’Assistant Analyse de table pour identifier rapidement les données redondantes. L’Assistant offre ensuite un moyen simple d’organiser les données au moyen de tables distinctes, de sorte qu’elles soient stockées de la manière la plus efficace. Access conserve la table d’origine en tant que sauvegarde, puis crée des tables que vous pouvez utiliser comme base pour votre application de base de données.

  1. Ouvrez la base de données Access qui contient la table que vous voulez analyser.

  2. Sous l’onglet Outils de base de données, dans le groupe Analyser, cliquez sur Analyser la table.

    L’Assistant Analyse de table démarre.

    Les deux premières pages de l’Assistant contiennent un bref didacticiel contenant des boutons sur la base des exemples sur la page. Si vous ne voyez pas les pages d’introduction, mais qu’une case à cocher libellée Afficher les pagesd’introduction s’affiche ? Cochez la case, puis cliquez deux fois sur Retour pour afficher l’introduction. Si vous ne voulez plus afficher les pages d’introduction après avoir lu l’introduction, vous pouvez effacer la case à cocher Afficher les pages d’introduction?

  3. Dans la page Quelle table contient des champs dont les valeurs sont répétées dans de nombreux enregistrements ? Sélectionnez la table que vous voulez analyser, puis cliquez sur Suivant.

  4. Vous pouvez laisser l’Assistant décider des champs dans quelles tables, ou vous pouvez prendre cette décision vous-même. Si vous suivez les suggestions de l’Assistant, vous pouvez toujours modifier la disposition du tableau sur la page suivante de l’Assistant.

    Remarque : Si vous laissez l’Assistant décider des champs à placer dans quelles tables, ses choix risquent de ne pas toujours être appropriés pour vos données, en particulier s’il y a peu de données à travailler. Vérifiez soigneusement les résultats de l’Assistant. En revanche, l’Assistant peut suggérer une organisation plus efficace que celle à quoi vous pensez, il peut s’il s’agit au moins de tenter les décisions de l’Assistant une seule fois. Si vous n’aimez pas les suggestions, vous pouvez toujours réorganiser les champs manuellement, et vous pouvez toujours cliquer sur Retour et réorganiser vous-même tous les champs.

  5. Cliquez sur Suivant.  Dans cette page, vous spécifiez les tables qui contiennent quels champs. Si vous choisissez de laisser l’Assistant décider, vous devez voir plusieurs tables connectées par des lignes de relation. Sinon, Access ne crée qu’une seule table contenant tous les champs. Dans les deux cas, vous pouvez apporter des modifications sur cette page.

    • Vous pouvez faire glisser des champs d’une table vers une zone vierge de la page pour créer une table contenant ces champs. Access vous demande un nom de table.

    • Vous pouvez faire glisser des champs d’une table vers une autre table si vous pensez qu’ils seront stockés plus efficacement à partir de celle-ci.

    • Un ID ou un champ D’ID unique généré sera attribué à la plupart des tables. Pour en savoir plus sur les champs ID, cliquez sur Conseils dans le coin supérieur droit de l’Assistant.

    • Pour annuler une modification, cliquez sur le bouton Annuler.

    • Pour renommer un tableau, double-cliquez sur sa barre de titre, tapez le nouveau nom, puis cliquez sur OK.

  6. Après avoir organisé les champs comme vous le souhaitez, cliquez sur Suivant.

  7. Si l’Assistant trouve des enregistrements présentant des valeurs très similaires, il identifie ces valeurs comme étant des erreurs typographiques possibles et présente un écran dans lequel vous pouvez confirmer la procédure à prendre. Faites défiler la liste pour trouver les valeurs de la colonne Correction, puis cliquez sur l’élément approprié dans la liste de liste bas. Sélectionnez (Conserver en l’tant que) pour empêcher l’Assistant d’apporter des modifications à la valeur. Lorsque vous avez terminé, cliquez sur Suivant.

  8. L’Assistant vous demande si vous voulez créer une requête qui ressemble à votre table d’origine. Si vous avez déjà créé des formulaires et états basés sur la table d’origine, il est bon de créer une telle requête. Si vous choisissez Oui,créez la requête, l’Assistant renomme la table d’origine en ajoutez « _OLD » au nom de la table, puis nomme la nouvelle requête en utilisant le nom de la table d’origine. Les formulaires et états basés sur la table utilisent désormais la requête pour leurs données et continuent de fonctionner comme avant.

  9. Cliquez sur Terminer.

    L’Assistant crée les nouvelles tables comme spécifié, puis les ouvre. Fermez-les lorsque vous avez terminé d’inspecter les résultats.

Haut de page

Travailler avec des données d’autres programmes

Access 2010 fournit des fonctionnalités d’analyse des données stockées dans d’autres programmes.

Créer une base de données Access qui lie des données dans un autre format de fichier    Vous pouvez utiliser Access pour ouvrir un fichier dans un autre format de fichier tel que texte, dBASE ou une feuille de calcul. Access crée automatiquement une base de données Access et lie le fichier pour vous.

  1. Démarrez Access.

  2. Sous l’onglet Fichier, cliquez sur Ouvrir.

  3. Dans la boîte de dialogue Ouvrir, cliquez sur le type de fichier que vous voulez ouvrir dans la liste. Si vous n’êtes pas sûr du type de fichier, cliquez sur Tous les fichiers (*.*).

  4. Si nécessaire, accédez au dossier contenant le fichier que vous voulez ouvrir. Une fois le fichier trouvé, double-cliquez dessus pour l’ouvrir.

  5. Suivez les instructions de l’Assistant. Sur la dernière page de l’Assistant, cliquez sur Terminer.

Importer ou lier des données à une base de données Access existante    Vous pouvez importer des données à partir d’autres sources et programmes dans des tables Access de sorte que les données y sont contenues, ou vous pouvez lier les données d’Access de façon à ce que les données restent dans le fichier d’origine (en dehors du fichier Access).

  1. Sous l’onglet Données externes, dans le groupe Importer & liaison, cliquez sur le format dans lequel les données sont stockées.

    Vous pouvez importer ou lier des données à partir des sources suivantes :

    • Excel    Vous pouvez y faire appel à partir d’une feuille de calcul ou d’une plage nommée. Chaque feuille de calcul ou plage nommée doit être importée ou liée séparément.

    • Access    Cela est très pratique pour séparer votre processus de vos données et créer une base de données fractionnement. Autrement dit, vous pouvez utiliser une base de données pour contenir l’ensemble de vos formulaires, états et macros, et conserver vos données dans une autre base de données. Vous pouvez ensuite développer des améliorations sans interrompre le travail de n’importe qui. Vous pouvez également combiner les données de nombreuses bases de données Access dans une seule, ce qui facilite la synthèse des données entre départements ou entre partenaires commerciaux.

    • base de données ODBC    De nombreux programmes offrent ce format, y compris de nombreux produits serveurs de base de données. Cela vous permet de créer des bases de données « landing pad » dans le cas où vous combinez les données de différents systèmes.

    • Fichier texte    Vous pouvez vous connecter à un fichier texte simple, et même utiliser Access pour modifier son contenu. Cela peut faciliter la consommation des données Access par un large éventail de programmes.

    • Fichier XML    Ce format offre également une compatibilité avec d’autres programmes, notamment certains serveurs web.

    • Liste SharePoint    Cela permet d’utiliser vos données avec un navigateur web, la façon standard d’utiliser une liste SharePoint.

    • Services de données    Vous pouvez vous connecter à des services de données web au sein de votre entreprise.

    • Document HTML    

    • Dossier Outlook    Vous pouvez vous connecter à des dossiers Outlook afin d’intégrer plus facilement vos informations de contact au reste de vos données.

    • fichier dBase    dBase est un système de base de données alternative populaire pris en charge par Access

      La boîte de dialogue Données externes s’affiche.

  2. Suivez les instructions de la boîte de dialogue.

    Access importe ou liera les données à votre base de données. Pour la plupart des formats, vous devez spécifier l’emplacement des données, puis choisir la manière dont vous souhaitez stocker les données dans votre base de données.

Haut de page

Utiliser une base de données de version antérieure dans plusieurs versions d’Access

Si votre base de données ou projet Access a été créé dans Access 2000 ou version ultérieure, vous pouvez utiliser la base de données ou le projet dans la version d’Access dans laquelle elle a été créée ou dans une version ultérieure, même si la sécurité du fichier est activée. Par exemple, les fichiers Access 2000 peuvent être utilisés dans Access 2000, Access 2002, Access 2003, Access 2007 et Access 2010.

Il se peut que vous vouliez conserver vos données dans une version antérieure d’Access, mais que certains de vos utilisateurs disposent d’une version ultérieure d’Access souhaitent lier ces données, tout en profitant de certaines fonctionnalités de la version ultérieure. La solution consiste à créer une base de données « frontale » dans la version ultérieure (contenant des formulaires, des états, des requêtes, des macros, mais aucune table), puis à la lier aux tables du fichier de version antérieure. Utilisez l’une des procédures suivantes, selon que votre base de données est contenue dans un fichier ou déjà fractionée en un application frontale/principale.

Utiliser un fichier de base de données Access dans plusieurs versions d’Access

Si l’ensemble des tables, formulaires et autres objets de votre base de données Access de version antérieure sont contenus dans un seul fichier et que vous souhaitez utiliser la base de données dans plusieurs versions d’Access, vous pouvez créer une base de données frontale dans une version ultérieure et la lier au fichier d’origine. Les utilisateurs qui ont la version antérieure d’Access peuvent toujours utiliser la base de données d’origine. Les utilisateurs qui ont la version ultérieure peuvent utiliser la nouvelle base de données frontale pour établir une liaison avec les mêmes données. Vous pouvez créer plusieurs versions frontales si vous avez besoin d’utiliser plusieurs versions d’Access.

Haut de page

Étape 1 : effectuer une copie de la base de données existante et l’enregistrer dans un nouveau format

Utilisez la procédure suivante pour convertir la base de données dans l’un des trois formats les plus récents : Access 2000, Access 2002-2003 ou Access 2007. Cette commande conserve le format d’origine de la base de données d’origine et crée une copie au format spécifié.

  1. Fermez le fichier Access. Si le fichier est une base de données Access multi-utilisateur située sur un serveur ou dans un dossier partagé, assurez-vous que personne d’autre ne l’a ouvert.

  2. Démarrez Access 2010.

  3. Sous l’onglet Fichier, cliquez sur Ouvrir.

  4. Accédez à l’emplacement du fichier à convertir, puis double-cliquez dessus pour l’ouvrir.

    Si la boîte de dialogue Amélioration de la base de données s’affiche, vous demandant si vous souhaitez améliorer la base de données, cliquez sur Non.

  5. Si un formulaire s’ouvre au démarrage de la base de données, fermez le formulaire.

  6. Sous l’onglet Fichier, cliquez sur Enregistrer la base de données sous.

  7. Dans la boîte de dialogue Enregistrer sous, tapez un nom pour la nouvelle base de données.

    Remarque : À moins que vous n’enregistrez la nouvelle base de données dans un autre emplacement, son nom doit être différent de celui de la base de données d’origine. Dans les deux cas, il est généralement préférable d’utiliser un autre nom, afin de faire facilement la distinction entre la base de données frontale et la base de données principale. Toutefois, si vous convertissez au format Access 2007, l’extension de nom de fichier change de .mdb à .accdb, de sorte que vous pouvez utiliser le même nom de fichier.

  8. Cliquez sur Enregistrer.

Haut de la page

Étape 2 : fractionner la base de données de copie et utiliser le fichier d’origine comme base de données principale

Fractionner la base de données convertie à l’aide de la procédure suivante :

  • Sous l’onglet Outils de base de données, dans le groupe Déplacer les données, cliquez sur Base de données Access. Image du bouton

  • Dans la boîte de dialogue Fractionnement de base de données, cliquez sur Fractionner la base de données.

    Vous pouvez effectuer une sauvegarde si vous le souhaitez, mais vous pouvez aussi simplement créer à nouveau la copie à l’aide de la base de données d’origine.

  • Tapez un nom pour la base de données principale, puis cliquez sur Fractionner.

Haut de page

Étape 3 : connecter le nouveau frontal à la base de données d’origine

  1. Supprimez la base de données principale créée par l’outil Fractionnement de base de données, en vous soin de ne pas supprimer votre base de données d’origine.

  2. Lier la nouvelle base de données frontale aux tables de la base de données d’origine : Sous l’onglet Données externes, dans le groupe Importer & Lier, cliquez sur Gestionnaire de tables liées. Image du bouton

  3. Cliquez sur Sélectionner tout,puis cochez la case Toujours choisir un nouvel emplacement.

  4. Cliquez sur OK,accédez à la base de données de la version antérieure, puis double-cliquez dessus.

    Si tout se passe bien, Access affiche un message indiquant que toutes les tables liées sélectionnées ont été correctement actualisées.

Vous pouvez désormais améliorer la nouvelle base de données frontale pour prendre en charge de nouvelles fonctionnalités pour les utilisateurs ayant des versions plus récentes d’Access. Les utilisateurs qui utilisent des versions antérieures peuvent continuer à utiliser la base de données de version antérieure.

Haut de page

Utiliser une application frontale/frontale dans plusieurs versions d’Access

Si votre base de données Access est déjà application frontale/principale, vous pouvez convertir le frontal au nouveau format de fichier. Aucune modification n’est nécessaire pour la base de données principale.

La procédure suivante vous montre comment utiliser la commande Enregistrer la base de données sous pour convertir la base de données frontale dans l’un des trois formats les plus récents : Access 2000, Access 2002-2003 ou Access 2007. Cette commande conserve le format d’origine de la base de données d’origine et crée une copie au format spécifié.

  1. Fermez la base de données frontale. Si le fichier est une base de données Access multi-utilisateur située sur un serveur ou dans un dossier partagé, assurez-vous que personne d’autre ne l’a ouvert.

  2. Démarrez Access 2010.

  3. Sous l’onglet Fichier, cliquez sur Ouvrir.

  4. Accédez à l’emplacement de la base de données frontale, puis double-cliquez dessus pour l’ouvrir.

    Si la boîte de dialogue Amélioration de la base de données s’affiche, vous demandant si vous souhaitez améliorer la base de données, cliquez sur Non.

  5. Si un formulaire apparaît lorsque vous ouvrez la base de données, fermez le formulaire.

  6. Sous l’onglet Fichier, cliquez sur Enregistrer la base de données sous.

  7. Dans la boîte de dialogue Enregistrer sous, tapez un nom pour la nouvelle base de données.

  8. Cliquez sur Enregistrer.

Vous pouvez désormais améliorer la nouvelle base de données frontale pour prendre en charge de nouvelles fonctionnalités.

Haut de page

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions pour vos commentaires.

×