Cet article décrit la syntaxe de formule et l’utilisation de la fonction TYPE.ERREUR dans Microsoft Excel.

Description

Renvoie un nombre correspondant à l’une des valeurs d’erreur de Microsoft Excel ou la valeur #N/A s’il n’y a pas d’erreur. Vous pouvez utiliser la fonction TYPE.ERREUR dans une fonction SI pour tester une valeur d’erreur et renvoyer une chaîne de caractères telle qu’un message à la place de la valeur d’erreur.

Syntaxe

TYPE.ERREUR(valeur)

La syntaxe de la fonction TYPE.ERREUR contient les arguments suivants :

  • valeur    Obligatoire. Il s’agit de la valeur d’erreur dont vous voulez trouver le numéro. Bien que l’argument valeur puisse être une valeur d’erreur proprement dite, il est généralement donné sous forme de référence à une cellule contenant une formule que vous souhaitez tester.

Si valeur est égal à

TYPE.ERREUR renvoie

#NUL!

1

#DIV/0!

2

#VALEUR!

3

#REF!

4

#NOM?

5

#NOMBRE!

6

#N/A

7

#CHARGEMENT_DONNEES

8

Une autre valeur

#N/A

Exemple

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, puis sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Données

#NUL!

#DIV/0!

Formule

Description

Résultat

=TYPE.ERREUR(A2)

Numéro de l’erreur #NUL! (1).

1

=SI(TYPE.ERREUR(A3)<3;CHOISIR(TYPE.ERREUR(A3),"Les plages ne se recoupent pas","Le diviseur est zéro"))

Vérifie la cellule A3 pour voir si la cellule contient l’un des #NULL! ou la valeur #DIV/0! valeur d’erreur. Si c’est le cas, le nombre de la valeur d’erreur est utilisé dans la fonction de feuille de calcul CHOISIR pour afficher un des deux messages . sinon, la #N/A d’erreur est renvoyée.

Le diviseur est zéro

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions pour vos commentaires.

×