Lorsque vous entrez une formule detableau, vous utilisez le plus souvent une plage de cellules dans votre feuille de calcul, mais vous n’avez pas besoin de le faire. Vous pouvez également utiliser des constantes de matrice,c’est-à-dire des valeurs que vous entrez simplement dans la barre de formule à l’intérieur d’accolades : {}. Vous pouvez ensuite nommer votre constante afin de la rendre plus facile à utiliser.

Vous pouvez utiliser des constantes dans vos formules de tableau ou de vous-même.

  1. Dans votre formule de tableau, tapez une accolade ouvrante, les valeurs de votre choix et une accolade fermant. Voici un exemple : =SOMME(A1:E1*{1,2,3,4,5})

    La constante est à l’intérieur des accolades ({)}, et oui, vous tapez vraiment ces accolades manuellement.

  2. Entrez le reste de votre formule, puis appuyez sur Ctrl+Shift+Entrée.

    La formule ressemblera à {=SOMME(A1:E1*{1,2,3,4,5})}et les résultats ressembleront à ceci :


    Constante de matrice imbriquée dans une formule SOMME

    La formule a multiplié A1 par 1 et B1 par 2, etc., ce qui vous permet d’économiser 1,2,3,4,5 dans les cellules de la feuille de calcul.

Utiliser une constante pour entrer des valeurs dans une colonne

Pour entrer des valeurs dans une seule colonne, par exemple, 3 cellules dans la colonne C, vous :

  1. Sélectionnez les cellules que vous souhaitez utiliser.

  2. Entrez un signe égal et votre constante. Séparez les valeurs de la constante par des points-virgules, et non par des virgules, et si vous entrez du texte, vous pouvez l’entourer de guillemets doubles. Par exemple : ={"Trimestre 1 »; » Trimestre2 »; » Trimestre 3"}

  3. Appuyez sur Ctrl+Maj+Entrée. La constante ressemble à ceci :

    Constante de matrice verticale utilisant du texte

    En termes de pratique, il s’agit d’une constante verticale à une dimension.

Utiliser une constante pour entrer des valeurs dans une ligne

Pour entrer rapidement des valeurs dans une seule ligne, par exemple, les cellules F1, G1 et H1, vous :

  1. Sélectionnez les cellules que vous souhaitez utiliser.

  2. Entrez un signe égal et votre constante, mais cette fois,vous séparez les valeurs par des virgules, et non par des points-virgules. Par exemple : ={1,2,3,4,5}

  3. Appuyez sur Ctrl+Shift+Entrée pour que la constante ressemble à ceci :

    Constante de matrice horizontale à une dimension

    En termes de pratique, il s’agit d’une constante horizontale à une dimension.

Utiliser une constante pour entrer des valeurs dans plusieurs colonnes et lignes

  1. Sélectionnez les cellules de votre choix.

    Assurez-vous que le nombre de lignes et de colonnes que vous sélectionnez correspond au nombre de valeurs dans votre constante. Par exemple, si votre constante écrit des données sur quatre colonnes et trois lignes, sélectionnez ce nombre de colonnes et de lignes.

  2. Entrez un signe égal et votre constante. Dans ce cas, séparez les valeurs de chaque ligne par des virgules et utilisez un point-virgule à la fin de chaque ligne. Par exemple :

    ={1.2.3.4;5.6.7.8;9.10.11.12}

  3. Appuyez sur Ctrl+Shift+Entrée, puis :

    Constante de matrice à deux dimensions

    En termes de pratique, il s’agit d’une constante à deux dimensions, car elle remplit des colonnes et des lignes. Si vous vous demandez, vous ne pouvez pas créer une constante tridimensionnelle, ce qui signifie que vous ne pouvez pas imbribrier une constante dans une autre.

Utiliser une constante dans une formule

Maintenant que vous êtes familiarisé avec les constantes de matrice, voici un exemple de travail.

  • Dans une cellule vide, entrez (ou copiez-collez) cette formule, puis appuyez sur Ctrl+Shift+Entrée :

    =SOMME(A1:E1*{1.2.3.4.5})

    La valeur 85 apparaît dans la cellule A3.

    Que s’est-il passé ? Vous avez multiplié la valeur dans A1 par 1, la valeur dans la cellule B2 par 2, et ainsi de suite, la fonction SOMME a ajouté ces résultats. Vous pouvez également entrer la formule sous la formule =SOMME(A1*1;B1*2;C1*3;D1*4;E1*5)

Si vous le souhaitez, vous pouvez entrer les deux ensembles de valeurs en tant que constantes de matrice :

=SOMME({3.4.5.6.7}*{1.2.3.4.5})

Pour essayer cela, copiez la formule, sélectionnez une cellule vide, collez la formule dans la barre de formule, puis appuyez sur Ctrl+Shift+Entrée. Vous voyez le même résultat.

Remarques : Recherchez ces problèmes si vos constantes ne fonctionnent pas :

  • Assurez-vous de séparer vos valeurs avec le caractère approprié. Si vous omettez une virgule ou un point-virgule, ou si vous mettez un point-virgule au mauvais endroit, la constante de matrice risque de ne pas paraître juste ou de voir un message d’avertissement.

  • Vous avez peut-être sélectionné une plage de cellules qui ne correspond pas au nombre d’éléments dans votre constante. Par exemple, si vous sélectionnez une colonne de six cellules à utiliser avec une constante de cinq cellules, le message d’erreur #N/A apparaît dans la cellule vide. Si vous ne sélectionnez pas assez de cellules, Excel omettez les valeurs qui ne sont pas correspondantes.

  • Pour plus d’informations sur les formules de tableau :

Haut de la page

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions pour vos commentaires.

×