Utiliser des constantes de matrice dans des formules matricielles

Lorsque vous Entrez une formule matricielle, vous utilisez le plus souvent une plage de cellules dans votre feuille de calcul, mais ce n’est pas le cas. Vous pouvez également utiliser des constantes de matrice, les valeurs que vous entrez simplement dans la barre de formule entre accolades : {}. Vous pouvez ensuite nommer votre constante pour pouvoir l’utiliser plus facilement.

Vous pouvez utiliser des constantes dans vos formules matricielles ou en tant que telles.

  1. Dans votre formule matricielle, tapez une accolade ouvrante, les valeurs souhaitées et une accolade fermante. Voici un exemple : = somme (a1 : E1 * {1, 2, 3, 4, 5})

    La constante se trouve à l’intérieur des accolades ({)}, et oui, vous devez réellement entrer ces accolades manuellement.

  2. Entrez le reste de votre formule et appuyez sur Ctrl + Maj + Entrée.

    La formule se présentera comme suit {= somme (a1 : E1 * {1, 2, 3, 4, 5})}et les résultats comme suit :


    Constante de matrice imbriquée dans une formule SOMME

    La formule a multiplié a1 par 1 et B1 par 2, etc., ce qui vous évite d’avoir à insérer 1, 2, 3, 4, 5 dans les cellules de la feuille de calcul.

Utiliser une constante pour entrer des valeurs dans une colonne

Pour entrer des valeurs dans une seule colonne, telles que 3 cellules dans la colonne C, procédez comme suit :

  1. Sélectionnez les cellules que vous souhaitez utiliser.

  2. Entrez un signe égal et votre constante. Séparez les valeurs de la constante par des points-virgules, et non par des virgules, et si vous entrez du texte, entourez-le avec des guillemets doubles. Par exemple : = {"trimestre 1"; " Quarter2";" Trimestre 3 "}

  3. Appuyez sur Ctrl+Maj+Entrée. La constante ressemble à ceci :

    Constante de matrice verticale utilisant du texte

    Dans le cadre des conditions d’utilisation, il s’agit d’une constante verticale à une dimension .

Utiliser une constante pour entrer des valeurs dans une ligne

Pour entrer rapidement des valeurs dans une seule ligne, telles que les cellules F1, G1 et H1, procédez comme suit :

  1. Sélectionnez les cellules que vous souhaitez utiliser.

  2. Entrez un signe égal et votre constante, mais cette fois-ci, vous séparez les valeurs par des virgules et non les points-virgules. Par exemple : = {1, 2, 3, 4, 5}

  3. Appuyez sur Ctrl + Maj + Entrée pour que la constante ressemble à ceci :

    Constante de matrice horizontale à une dimension

    Dans le cadre des conditions d’utilisation, il s’agit d’une constante horizontale à une dimension .

Utiliser une constante pour entrer des valeurs dans plusieurs colonnes et lignes

  1. Sélectionnez les cellules souhaitées.

    Vérifiez que le nombre de lignes et de colonnes que vous sélectionnez correspond au nombre de valeurs dans votre constante. Par exemple, si votre constante va écrire des données sur quatre colonnes et trois lignes, sélectionnez le nombre de colonnes et de lignes souhaité.

  2. Entrez un signe égal et votre constante. Dans ce cas, séparez les valeurs de chaque ligne par des virgules, puis utilisez un point-virgule à la fin de chaque ligne. Par exemple :

    ={1,2,3,4;5,6,7,8;9,10,11,12}

  3. Appuyez sur Ctrl + Maj + entrée, et :

    Constante de matrice à deux dimensions

    Il s’agit d’une constante à deux dimensions , car elle remplit des colonnes et des lignes. Si vous vous demandez, vous ne pouvez pas créer de constante tridimensionnelle, ce qui signifie que vous ne pouvez pas imbriquer une constante dans une autre.

Utiliser une constante dans une formule

Maintenant que vous êtes familiarisé avec les constantes de matrice, voici un exemple pratique.

  • Dans n’importe quelle cellule vide, entrez (ou copiez et collez) cette formule, puis appuyez sur Ctrl + Maj + Entrée :

    =SOMME(A1:E1*{1,2,3,4,5})

    La valeur 85 apparaît dans la cellule A3.

    Que s’est-il passé ? Vous avez multiplié la valeur dans a1 par 1, la valeur de la cellule B2 par 2, et ainsi de suite, la fonction somme a ajouté ces résultats. Vous pouvez également entrer la formule comme = somme (a1 * 1, B1 * 2, C1 * 3, D1 * 4, E1 * 5)

Si vous le souhaitez, vous pouvez entrer les deux jeux de valeurs sous forme de constantes de matrice :

=SOMME({3,4,5,6,7}*{1,2,3,4,5})

Pour cela, copiez la formule, sélectionnez une cellule vide et collez la formule dans la barre de formule, puis appuyez sur Ctrl + Maj + Entrée. Le même résultat s’affiche.

Remarques : Recherchez ces problèmes si vos constantes ne fonctionnent pas :

  • Veillez à séparer les valeurs par le caractère approprié. Si vous omettez une virgule ou un point-virgule, ou si vous en avez une au mauvais endroit, il est possible que la constante matricielle ne soit pas correcte ou qu’un message d’avertissement s’affiche.

  • Il est possible que vous ayez sélectionné une plage de cellules qui ne correspond pas au nombre d’éléments de votre constante. Par exemple, si vous sélectionnez une colonne de six cellules à utiliser avec une constante de cinq cellules, l’erreur #N/A s’affiche dans la cellule vide. Si vous ne sélectionnez pas suffisamment de cellules, Excel omet les valeurs qui n’ont pas de cellule correspondante.

  • Pour en savoir plus sur les formules matricielles :

Haut de la page

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×