PROBLÈME
Lorsque vous ajoutez un compte Outlook pour Microsoft 365 avec un domaine personnalisé ou un compte Outlook.com avec une adresse e-mail personnalisée, vous recevez l’erreur suivante :
CAUSE
Ce problème se produit parce que le processus de découverte automatique utilisé par Outlook reçoit un résultat inattendu d’un serveur web tiers lorsqu’il effectue la recherche de domaine racine. Par exemple, Outlook peut recevoir un résultat tel que https://< RootDomain>/AutoDiscover/AutoDiscover.xml.
En règle générale, la recherche de domaine racine échoue dans ce cas, et Outlook effectue une recherche de découverte automatique sur https://AutoDiscover.<RootDomain>/AutoDiscover/AutoDiscover.xml. Toutefois, étant donné qu’Outlook reçoit une réponse de découverte automatique réussie de la recherche de domaine racine, Outlook tente de s’authentifier auprès des protocoles publiés tels que POP et IMAP, et l’opération échoue.
SOLUTION
Contactez votre fournisseur de services web ou le fournisseur d’hébergement web de votre site web de domaine et assurez-vous que le serveur web ne répond pas aux demandes de découverte automatique.
CONTOURNEMENT
Pour contourner ce problème si le fournisseur de services web ou le fournisseur d’hébergement web ne parvient pas à le résoudre, procédez comme suit :
Créez des clés de Registre Outlook pour exclure les derniers paramètres corrects connus, le domaine racine HTTPS et l’enregistrement SRV, comme indiqué ci-dessous. Une fois les entrées de Registre en place, redémarrez Outlook et essayez d’ajouter le compte ou de créer à nouveau un profil.
Utiliser ExcludeLastKnownGoodUrl pour empêcher Outlook d’utiliser la dernière URL de découverte automatique correcte connue
HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD : ExcludeLastKnownGoodUrl
Valeur : 1OU
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD : ExcludeLastKnownGoodUrl
Valeur : 1Utiliser ExcludeHttpsRootDomain pour empêcher Outlook d’utiliser le domaine racine HTTPS
HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD : ExcludeHttpsRootDomain
Valeur : 1OU
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD : ExcludeHttpsRootDomain
Valeur : 1Utiliser ExcludeSrvRecord pour empêcher Outlook d’utiliser le domaine racine HTTPS
HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD : ExcludeSrvRecord
Valeur : 1OU
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD : ExcludeSrvRecord
Valeur : 1
Remarque
- L’espace réservé x.0 représente votre version d’Office (16.0 = Office 2016, Office 365 et Office 2019, 15.0 = Office 2013).
- Lorsque la valeur ExcludeLastKnownGoodUrl est définie sur 1, Outlook n’utilise pas la dernière URL de découverte automatique opérationnelle connue.
Important
L’exclusion du domaine racine HTTPS n’est pas une solution à long terme pour ce problème, et nous ne le recommandons pas. Cette solution de contournement est fournie pour résoudre immédiatement le problème. Dès que le fournisseur de services web ou le fournisseur d’hébergement web résout le problème, la clé de Registre Outlook doit être supprimée.
Pour plus d’informations sur la découverte automatique et les paramètres du Registre, consultez Comportement de découverte automatique inattendu lorsque vous avez des paramètres de Registre sous la clé \Découverte automatique.