KB2713827 - CORRECTIF : erreur « Dataflow - <SSISPackageName> » lorsque vous essayez d’ouvrir un package SSIS dans SSIS 2012

S’applique à
SQL Server 2012 Business Intelligence SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard

Microsoft distribue les correctifs Microsoft SQL Server 2012 sous la forme d’un fichier téléchargeable. Étant donné que les correctifs sont cumulatifs, chaque nouvelle version contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2012.

Symptômes

Prenons le scénario suivant :

  • Vous avez une version de SQL Server Integration Services (SSIS) antérieure à SSIS 2012 installée sur votre ordinateur.
  • Vous disposez d’un package SSIS qui utilise le connecteur Microsoft pour Oracle par Attunity ou le connecteur Microsoft pour Teradata par Attunity.
  • Vous effectuez une mise à niveau vers SSIS 2012.
  • Vous essayez d’ouvrir le colis.

Dans ce cas, un message d’erreur semblable au suivant s’affiche :

Remarque

Erreur 0xc004706c : Dataflow - SSISPackageName : Composant « Oracle Source Oracle Source Source, clsid {4CAC6073-BCA7-430E-BD29-68A9F0012C6D} » n’a pas pu être créé et renvoyé code d’erreur 0x80070005 « L’accès est refusé. ». Assurez-vous que le composant est enregistré correctement.

Erreur 0xc0048021 : Dataflow - SSISPackageName : Le composant est manquant, non enregistré, non évolutif ou des interfaces requises manquantes. Les informations de contact de ce composant sont « Source Oracle ; Microsoft Connector for Oracle par Attunity ; Attunity Ltd. ; Tous droits réservés ; http://www.attunity.com ; 2".

Erreur 0xc004801f : Dataflow - SSISPackageName : Les métadonnées du composant pour « Oracle Source < Oracle Source Source Source Name> » n’ont pas pu être mises à niveau vers la nouvelle version du composant. La méthode PerformUpgrade a échoué.

Cause

Ce problème se produit parce qu’un ancien GUID est utilisé dans le package SSIS.

Résolution

Informations sur les mises à jour cumulatives

Package de mise à jour cumulative 1 pour SQL Server 2012 Service Pack 1

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 1. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2012 Service Pack 1, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2765331 Package de mise à jour cumulative 1 pour SQL Server 2012 Service Pack 1Remarque Comme les versions sont cumulatives, chaque nouvelle version contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2772858 Builds de SQL Server 2012 publiées après SQL Server 2012 Service Pack 1

Package de mise à jour cumulative 3 pour SQL Server 2012

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 3. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2012, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2723749 Mise à jour cumulative 3 pour SQL Server 2012Note Comme les versions sont cumulatives, chaque nouvelle publication contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2692828 Les builds SQL Server 2012 publiées après la sortie de SQL Server 2012

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Solution de contournement

Pour contourner ce problème, recherchez puis remplacez l’ancien GUID par le nouveau dans le fichier de package .dtsx avec le mappage suivant. Ces modifications peuvent être effectuées avant ou après la mise à niveau des packages SSIS vers SQL Server 2012.

Oracle Source

OLD : {4CAC6073-BCA7-430E-BD29-68A9F0012C6D}

NOUVEAU : {CB67CD40-126C-4280-912D-2A625DFAFB66}

Oracle Destination

OLD : {3C2D9CC0-74EE-4f64-98E0-4DD374B92068}

NEW : {96F6C478-E5BE-45A4-B39A-055F9787CCD4}

Oracle Gestionnaire des connexions

OLD : {58BD57A5-2572-4e04-8D64-A646AFD434F3}

NEW : {577C27D9-1E41-4116-B8AC-1A11E1E4B66D}

Teradata Source

OLD : {58664F3B-262F-4E4B-8AD1-E3FA1B504C1E}

NOUVEAU : {FE2F6C7B-2535-434A-8E03-894F4C01D8B7}

Teradata Destination

ANCIEN : {3703B1C2-3155-4905-9D5B-9DDAB8EB8773}

NEW : {664D5009-786B-4C11-A507-2BF056EF5F61}

Teradata Gestionnaire des connexions

ANCIEN : {EA88DC41-494C-41FE-9BB2-0B728B46B7B2}

NOUVEAU : {84B09D80-8309-4CA8-9CEC-E19ACB76F257}

Informations supplémentaires

Les produits tiers mentionnés dans le présent article sont fabriqués par des sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.