KB2765331 - Package de mise à jour cumulative 1 pour SQL Server 2012 Service Pack 1

S’applique à
SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Developer SQL Server 2012 Enterprise

INTRODUCTION

Cet article décrit le package de mise à jour cumulative 1 pour Microsoft SQL Server 2012. Cette mise à jour contient des correctifs logiciels pour des problèmes résolus après la publication de SQL Server 2012 Service Pack 1 (SP1).

Remarque Le numéro de build de ce package de mise à jour cumulative est 11.0.3321.0.

Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2012 SP1. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif.

  Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2772858 Builds de SQL Server 2012 publiées après SQL Server 2012 Service Pack 1

Remarques importantes sur le package de mise à jour cumulative

  • Les correctifs logiciels de SQL Server 2012 SP1 sont désormais multilingues. Il n’existe donc qu’un seul correctif logiciel cumulatif pour toutes les langues.
  • Un correctif logiciel cumulatif inclut tous les packages des composants. Le package de mise à jour cumulative met à jour uniquement les composants installés sur le système.

Informations supplémentaires

Procédure pour obtenir la mise à jour cumulative 1 pour SQL Server 2012 SP1

Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par ces problèmes, il est recommandé d’attendre la prochaine version du Service Pack SQL Server 2012 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.

Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :

/contactus/ ?ws=support

Correctifs logiciels inclus dans ce package de mise à jour cumulative

  Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.

  Pour plus d’informations sur les bogues de SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

Numéro de bogue VSTS Numéro d’article de la Base de connaissances Description
1086784 2406666 CORRECTION : erreur « [Base de données Teradata] [3737] » lorsque vous cliquez sur « Nombre » dans l’Assistant Conception d’agrégation dans SSAS 2008, SSAS 2012 ou SSAS 2008 R2
1078523 2445812 CORRECTIF : une colonne qui utilise le type de données DATETIME ne se réplique pas sur un abonné Oracle à l’aide d’une réplication transactionnelle dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
1078647 2644794 CORRECTIF : erreur d’assertion fFalse lorsque vous essayez de convertir la valeur d’une colonne XML en une variable XML dans SQL Server 2008, dans SQL Server 2008 R2 ou dans SQL Server 2012
1078655 2645648 CORRECTIF : échec de la procédure d’exportation lors de l’exportation d’un rapport SSRS 2008 R2, SSRS 2012 ou d’un rapport SSRS 2008 64 bits qui contient plusieurs niveaux d’une correspondance de document au format PDF
1078512 2651629 CORRECTIF : message d’erreur lors de l’utilisation de DTA pour accorder une ou plusieurs requêtes à une base de données qui contient de nombreux objets dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
1086762 2661644 CORRECTIF : Violation d’accès dans le sqlservr ! Fonction ReplicaToPrimaryPageCopier ::ReadIoCompletionRoutine dans SQL Server 2008 R2 ou dans SQL Server 2012
1078579 2667037 CORRECTIF : Erreur « Le format chaîne de connexion n’est pas valide » lorsque vous essayez de créer un plan de maintenance pour un serveur SQL Server 2008 R2 ou SQL Server 2012
1078631 2667742 CORRECTIF : erreur « mémoire insuffisante » lorsque vous utilisez ODBC avec SQL Server 2012, SQL Server 2008 R2 ou SQL Server 2008
1078541 2671078 CORRECTIF : Message d’erreur « Tentative de définition de la valeur d’une colonne non NULL » lors de l’utilisation d’une instruction MERGE dans SQL Server 2008, dans SQL Server 2008 R2 ou dans SQL Server 2012
1086761 2671318 CORRECTIF : la première exécution de la procédure stockée xp_cmdshell ne se termine pas avant la fin de la dernière exécution en SQL Server 2012
1078538 2680799 CORRECTIF : Message d’erreur lors de l’exécution d’un remplissage complet d’un index de recherche en texte intégral à l’aide d’analyseurs lexicaux pour la langue chinoise dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
1078582 2697983 CORRECTIF : une valeur incorrecte est stockée dans la colonne TIME_ZONE de la table BACKUPSET dans SQL Server 2008 R2 ou dans SQL Server 2012
1078535 2698639 CORRECTIF : les performances d’une instruction SELECT contenant un opérateur LIKE et une clause ESCAPE sont faibles dans SQL Server 2008 R2 ou SQL Server 2012
1078588 2699013 CORRECTIF : SQL Server 2012, SQL Server 2008 R2 ou SQL Server 2008 cesse de répondre et une erreur « Planificateur non productif » est consignée
1078516 2703193 CORRECTIF : résultats incorrects lors de l’exécution d’une requête parallèle qui utilise un index columnstore dans SQL Server 2012
1078593 2706601 CORRECTIF : les groupes de séries d’un rapport sont manquants lorsque vous rendez le rapport dans SQL Server 2008 Reporting Services ou dans les versions ultérieures de Reporting Services
1078597 2708027 CORRECTIF : Message d’erreur « Une erreur s’est produite lors du traitement du rapport » lorsque vous essayez d’afficher un aperçu d’un rapport SSRS 2008 R2 ou SSRS 2012 après avoir défini le classement du jeu de données sur le grec ou le Greek_100
1078527 2708786 CORRECTIF : violation d’accès lorsque vous essayez de créer un index columnstore pour une table dans SQL Server 2012
1078530 2709075 Erreur « Une erreur grave s’est produite sur la commande actuelle » lorsque vous exécutez une requête en texte intégral avec le prédicat CONTAINS dans SQL Server 2012
1078649 2713151 CORRECTIF : violation d’accès lors de l’utilisation de Assistant Paramétrage du moteur de base de données pour ajuster un tableau dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012 si vous activez la case case activée « Inclure les index filtrés »
1078547 2713827 CORRECTIF : erreur « Dataflow - » lorsque vous essayez d’ouvrir un package SSIS dans SSIS 2012
1078603, 1086774 2714634 CORRECTIF : SQL Server 2008 R2 ou SQL Server 2012 prend beaucoup de temps pour générer des scripts pour une table partitionnée qui utilise la fonctionnalité de compression de données
1078544 2714937 CORRECTIF : Message d’erreur « Aucun objet n’existe avec un ID de traçabilité » lors de l’exécution d’un package SSIS 2012
1078573 2720171 CORRECTIF : Message d’erreur lors de l’exécution d’un package SSIS si la procédure stockée sys.xp_regread est révoquée dans SQL Server 2012 : « L’autorisation EXECUTE a été refusée sur l’objet 'xp_regread' »
1086770 2723979 CORRECTIF : violation d’accès dans le moniteur de blocage interne de SQL SQL Server lorsque vous exécutez plusieurs applications avec plusieurs jeux de résultats actifs activés dans SQL Server 2008 R2 ou dans SQL Server 2012
1078613, 1078616 2725950 CORRECTIF : Performances ralenties ou blocage lorsque vous restaurez une base de données et exécutez des instructions en même temps dans SQL Server 2012
1078658 2727322 CORRECTIF : Des résultats incorrects sont renvoyés lorsque vous exécutez une requête qui utilise le parallélisme dans le plan d’exécution de la requête dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
1086769 2728419 CORRECTIF : message d’erreur « Le processus de réglage s’est arrêté de manière inattendue » lorsque vous exécutez Assistant Paramétrage du moteur de base de données sous le rôle db_owner dans SQL Server 2008 R2 ou dans SQL Server 2012
1086771 2728534 CORRECTIF : erreur « une assertion système case activée a échoué » lorsque vous recréez un index non-cluster sur une colonne dans SQL Server 2008 R2 ou dans SQL Server 2012
1086773 2731068 CORRECTIF : « Une erreur inattendue s’est produite » lorsque vous interrogez des données de calcul d’un modèle tabulaire SSAS à l’aide de SQL Server 2008 R2 PowerPivot pour Excel 2010 ou de SQL Server 2008 R2 PowerPivot pour SharePoint 2010
1086772 2737499 CORRECTIF : La propriété KeepTogether ne fonctionne pas lorsque vous générez un rapport contenant un tableau matriciel dans SSRS 2008 R2 ou SSRS 2012
1078575 2737580 CORRECTIF : erreur interne lors de l’exécution de requêtes sur un modèle d’extraction non rectangulaire à l’aide de DMX ou MDX dans SQL Server 2012 Analysis Services
1086766 2738197 CORRECTIF : les threads de travail ne se réveillent pas immédiatement lorsque plusieurs tâches gourmandes en E/S s’exécutent en même temps dans SQL Server 2012
1086767 2739940 CORRECTIF : la base de données est hors connexion et en état de récupération lorsque vous reconstruisez un index dans SQL Server 2012 si le journal des transactions est saturé
1086780 2752511 CORRECTIF : Message « Erreur de dépassement de capacité arithmétique » lors de l’exécution de la procédure stockée système sys.sp_tables_info_90_rowset_64 sur un serveur lié dans SQL Server 2012
1086781 2754444 CORRECTION : Message d’erreur « L’index et la longueur doivent faire référence à un emplacement dans la chaîne » lorsque vous extrayez un grand volume de données de SAP BW dans un package SSIS 2012
1086782 2754939 CORRECTIF : Une violation d’accès se produit lorsque vous exécutez une requête en texte intégral dans SQL Server 2012
1086785 2755079 CORRECTIF : les modifications ne sont pas synchronisées pour les abonnés après la modification d’un filtre d’article dans une publication de réplication transactionnelle dans SQL Server 2008, SQL Server 2012 ou SQL Server 2008 R2
1086763 2756097 CORRECTIF : « Aperçu de la technologie de la communauté (CTP d’août) » s’affiche dans l’Assistant Installation ou désinstallation d’une mise à jour de SQL Server 2012
1086765 2762557 CORRECTIF : Message d’erreur « Le processus semble ne pas céder sur le Planificateur » lorsque vous exécutez une requête dans SQL Server 2012
1086783 2762559 CORRECTIF : les échecs de SQL Server 2012 sont affichés dans la boîte de dialogue Notifications d’état de tâche dans System Center Operations Manager 2012
1086786 2762593 CORRECTIF : L’utilitaire tablediff signale des résultats incorrects lorsqu’un tableau contient une clé primaire dans une colonne identificateur unique dans SQL Server 2012
1115973 2780716 CORRECTIF : perte de données lors de l’exportation de Microsoft Azure SQL Database vers une application de la couche Données package .bacpac
1116032 2780719 CORRECTIF : perte de données lors de l’importation d’une application de la couche Données à partir d’un fichier de package .bacpac dans Microsoft Azure SQL Database

Informations sur le package de mise à jour cumulative

Informations sur le redémarrage

  Vous devrez peut-être redémarrer l’ordinateur après avoir appliqué cette mise à jour cumulative.

Informations sur le Registre

  Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.

Comment désinstaller ce package de mise à jour cumulative

Pour désinstaller ce package de mise à jour cumulative, procédez comme suit :

  1. Dans le Panneau de configuration, ouvrez Ajout/Suppression de programmes
      l’objet.

    Remarque Si vous utilisez Windows 7, ouvrez l’élément Programmes et fonctionnalités du Panneau de configuration.

  2. Recherchez l’entrée installée par ce package de mise à jour cumulative.

  3. Cliquez avec le bouton droit sur l’entrée, puis sélectionnez Désinstaller pour supprimer le package de mise à jour cumulative.

Références

  Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

935897
  Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés

  Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

822499
  Schéma d’appellation des packages de mise à jour logicielle de Microsoft SQL Server
   Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684
  Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft