KB2714937 - CORRECTIF : Message d’erreur « Aucun objet n’existe avec un ID de traçabilité » lors de l’exécution d’un package SSIS 2012

S’applique à
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Enterprise Core SQL Server 2012 Business Intelligence

Microsoft distribue les correctifs Microsoft SQL Server 2012 sous la forme d’un fichier téléchargeable. Étant donné que les correctifs sont cumulatifs, chaque nouvelle version contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2012.

Symptômes

Prenons le scénario suivant :

  • Vous exécutez un package Microsoft SQL Server Integration Services (SSIS) dans SQL Server 2012 Integration Services. Le package contient un composant personnalisé ou un composant tiers.

  • Le composant personnalisé ou tiers contient une propriété qui est un tableau d’ID de traçabilité.

    Remarque La propriété ContainsID et la propriété IsArray sont définies sur True pour le composant.

Dans ce cas, un message d’erreur semblable au suivant s’affiche :

Remarque

[SSIS. Pipeline] Erreur : Aucun objet n’existe avec un ID de traçabilité numérique.
[Différence de table] Erreur : Impossible de récupérer les informations des champs, veuillez configurer le composant.
[SSIS. Pipeline] Erreur : « ComponentName » a échoué la validation et a renvoyé la validation status « VS_ISBROKEN ».

Remarque Si vous utilisez le composant de différence de table COZYROC tiers, vous rencontrez ce problème.

Cause

Ce problème se produit car la combinaison du tableau des ID de traçabilité est renvoyée de manière incorrecte. Cela provoque l’échec lors de l’analyse du tableau.

Résolution

Informations sur les mises à jour cumulatives

Package de mise à jour cumulative 1 pour SQL Server 2012 Service Pack 1

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 1. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2012 Service Pack 1, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2765331 Package de mise à jour cumulative 1 pour SQL Server 2012 Service Pack 1Remarque Comme les versions sont cumulatives, chaque nouvelle version contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2772858 Builds de SQL Server 2012 publiées après SQL Server 2012 Service Pack 1

Package de mise à jour cumulative 3 pour SQL Server 2012

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 3. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2012, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2723749 Mise à jour cumulative 3 pour SQL Server 2012Remarque Comme les builds sont cumulatives, chaque nouvelle publication contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2692828 Les builds SQL Server 2012 publiées après la sortie de SQL Server 2012

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».