KB2715512 - CORRECTIF : Messages d’erreur lors de l’utilisation de dtexec pour exécuter des packages dans SSIS 2008, SSIS 2012 ou SSIS 2008 R2

S’applique à
SQL Server 2008 Developer SQL Server 2008 Enterprise SQL Server 2008 Express SQL Server 2008 R2 Datacenter SQL Server 2008 R2 Developer SQL Server 2008 R2 Enterprise SQL Server 2008 R2 Express SQL Server 2008 R2 Web SQL Server 2008 R2 Workgroup SQL Server 2008 Web SQL Server 2008 Workgroup SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Enterprise Core

Microsoft distribue les correctifs de Microsoft SQL Server 2008 Service Pack 3 sous la forme d’un fichier téléchargeable. Étant donné que les correctifs sont cumulatifs, chaque nouvelle version contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2008 Service Pack 3.

Symptômes

Quand vous utilisez l’utilitaire dtexec pour exécuter en parallèle Microsoft SQL Server 2012 Integration Services (SSIS 2012), Microsoft SQL Server 2008 Integration Services (SSIS 2008) ou Microsoft SQL Server 2008 R2 Integration Services (SSIS 2008 R2), un ou plusieurs des messages d’erreur ci-dessous peuvent s’afficher :

Message d’erreur 1

Remarque

Les objets de Data Flow ne peuvent pas être chargés. Vérifiez que Microsoft.SqlServer.PipelineXml.dll est correctement enregistré.

Message d’erreur 2

Remarque

Échec du chargement de la tâche « TaskName », tapez « SSIS. Pipeline.2". Les informations de contact pour cette tâche sont les suivantes : « Effectuer l’extraction, la transformation et le chargement de données hautes performances ; Microsoft Corporation ; Microsoft SQL Server v10 ; (c) 2007 Microsoft Corporation ; Tous droits réservés ; http://www.microsoft.com/sql/support/default.asp;1".

Message d’erreur 3

Remarque

Code d’erreur SSIS DTS_E_OLEDBERROR. Une erreur OLE DB s’est produite. Code d’erreur : 0x800736B1.
Un enregistrement OLE DB est disponible. Source : « Composants du service Microsoft OLE DB » Hresult : 0x800736B1 Description : « Cette application n’a pas pu démarrer car la configuration de l’application est incorrecte. La réinstallation de l’application peut résoudre ce problème. »

Remarque Ce problème est plus susceptible de se produire lorsque l’ordinateur subit une forte sollicitation de la mémoire.

Cause

Ce problème se produit car SSIS ne case activée pas si les composants SSIS sont correctement chargés. Si les composants SSIS ne sont pas chargés correctement, SSIS valide et exécute une tâche de Data Flow vide.

Remarque L’utilitaire dtexec renvoie un code de sortie dont la valeur est 0. Cette valeur signifie que les packages SSIS ont été exécutés correctement.

Résolution

Informations sur les mises à jour cumulatives

Mise à jour cumulative 2 pour SQL Server 2012 SP1

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 2. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2012 SP1, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2790947 Package de mise à jour cumulative 2 pour SQL Server 2012 Service Pack 1Remarque : les builds étant cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012 SP1. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2772858 Builds de SQL Server 2012 publiées après SQL Server 2012 Service Pack 1

Mise à jour cumulative 5 pour SQL Server 2012

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 5. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2012, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2777772 Package de mise à jour cumulative 5 pour SQL Server 2012Remarque Comme les builds sont cumulatives, chaque nouvelle publication contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2692828 Les builds SQL Server 2012 publiées après la sortie de SQL Server 2012

Mise à jour cumulative 4 pour SQL Server 2008 R2 SP2

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 4. Pour plus d’informations sur la façon d’obtenir ce package de mise à jour cumulative pour SQL Server 2008 R2 SP 2, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2777358 Package de mise à jour cumulative 4 pour SQL Server 2008 R2 Service Pack 2
 Remarque : les builds étant cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2008 R2 SP 2. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2730301 Les builds SQL Server 2008 R2 publiées après SQL Server 2008 R2 Service Pack 2

Package de mise à jour cumulative 10 pour SQL Server 2008 R2 Service Pack 1

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 10. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2008 R2 SP1, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2783135 Package de mise à jour cumulative 10 pour SQL Server 2008 R2 SP1
 Remarque : les builds étant cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2008 R2 SP1. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2567616 Builds de SQL Server 2008 R2 publiées après SQL Server 2008 R2 Service Pack 1

SQL Server 2008 Service Pack 3

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 7 pour SQL Server 2008 Service Pack 3. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2008 Service Pack 3, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2738350 Package de mise à jour cumulative 7 pour SQL Server 2008 Service Pack 3Remarque Comme les versions sont cumulatives, chaque nouvelle publication contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la précédente version du correctif SQL Server 2008 Service Pack 3. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2629969 Les builds SQL Server 2008 publiées après SQL Server Service Pack 3 2008

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Solution de contournement

Pour contourner ce problème, n’exécutez pas trop de packages SSIS en même temps. Par exemple, n’exécutez pas plusieurs centaines de packages SSIS en même temps.

Informations supplémentaires

Pour plus d’informations sur l’utilitaire dtexec, reportez-vous au site web MSDN à l’adresse suivante :

Informations générales sur l’utilitaire dtexec