KB2790947 - Package de mise à jour cumulative 2 pour SQL Server 2012 Service Pack 1

S’applique à
SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Developer SQL Server 2012 Enterprise

INTRODUCTION

Cet article décrit le package de mise à jour cumulative 2 pour Microsoft SQL Server 2012Service Pack 1 (SP1). Cette mise à jour contient des correctifs logiciels pour des problèmes résolus après la publication de SQL Server 2012 SP1.

Remarque Le numéro de build de ce package de mise à jour cumulative est 11.0.3339.0.

Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2012 SP1. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif.

  Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2772858 Builds de SQL Server 2012 publiées après SQL Server 2012 Service Pack 1

Remarques importantes sur le package de mise à jour cumulative

  • Les correctifs logiciels de SQL Server 2012 SP1 sont désormais multilingues. Il n’existe donc qu’un seul correctif logiciel cumulatif pour toutes les langues.
  • Un correctif logiciel cumulatif inclut tous les packages des composants. Le package de mise à jour cumulative met à jour uniquement les composants installés sur le système.

Informations supplémentaires

Procédure pour obtenir la mise à jour cumulative 2 pour SQL Server 2012 SP1

Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par ces problèmes, il est recommandé d’attendre la prochaine version du Service Pack SQL Server 2012 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.

Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :

/contactus/ ?ws=support

Correctifs logiciels inclus dans ce package de mise à jour cumulative

  Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.

  Pour plus d’informations sur les bogues de SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

Numéro de bogue VSTS Numéro d’article de la Base de connaissances Description
1155749 972936 CORRECTIF : Erreur « SqlDumpExceptionHandler : Le processus a généré une exception irrécupérable c0000005 EXCEPTION_ACCESS_VIOLATION. » lorsque vous exécutez une requête en SQL Server 2012, en SQL Server 2008, en SQL Server 2008 R2 ou en SQL Server 2005
1133945 2509302 Le journal des transactions d’une base de données continue de croître après la mise à niveau vers SQL Server 2012, SQL Server 2008 R2 SP1, SQL Server 2008 SP2 ou SQL Server 2008 SP3
1154924 2674636 CORRECTIF : la taille d’un fichier de base de données n’est pas réduite lorsque vous utilisez la commande DBCC SHRINKFILE dans SQL Server 2008 R2 ou dans SQL Server 2012
1029028 2688395 CORRECTIF : impossible de créer un instantané d’une base de données qui contient un catalogue de texte intégral en mode lecture seule ou veille dans SQL Server 2012
1133924 2696161 CORRECTIF : Message d’erreur lors de la tentative d’affichage d’un rapport dans SSRS 2012, SSRS 2008 R2 ou SSRS 2008 : « Différents paramètres de requête ont abouti à un même hachage »
1154926 2715512 CORRECTIF : Messages d’erreur lors de l’utilisation de dtexec pour exécuter des packages dans SSIS 2008, SSIS 2012 ou SSIS 2008 R2
1136154 2715841 CORRECTIF : Report Viewer 2010 n’affiche pas le paramètre DateTime lors de l’exécution d’un rapport dans SSRS 2012
1155739 2734191 CORRECTIF : Les rapports ne sont pas imprimés dans la taille de page définie lorsque vous utilisez le contrôle RSClientPrint pour imprimer des rapports dans SSRS 2008 R2
1080478 2739213 CORRECTIF : Message d’erreur lorsque vous affichez un rapport SSRS qui utilise le paramètre rc :Toolbar=false dans l’URL : « Une erreur s’est produite dans la base de données du serveur de rapports »
1154934 2742131 Exception « 0xe0434f4d » et message d’erreur « 0xC001000A » lors de la création d’un plan de maintenance sur un serveur MSX
1034257 2748780 CORRECTIF : les mesures calculées sont modifiées après avoir parcouru un cube dans SSAS 2012
1080464 2749913 CORRECTIF : exception non gérée lors de l’utilisation d’une transaction marquée qui s’étend sur plusieurs bases de données dans SQL Server 2008 R2 ou dans SQL Server 2012
1080488 2752432 CORRECTIF : utilisation élevée du processeur lors de l’interrogation d’une colonne d’objets binaires volumineux à l’aide de l’indicateur NOLOCK dans SQL Server 2008 R2 ou SQL Server 2012
1080467 2754301 CORRECTIF : les requêtes volumineuses qui modifient les données s’exécutent plus lentement que prévu lorsque de nombreux verrous s’accumulent dans SQL Server 2008 R2 ou dans SQL Server 2012
1080470 2754800 CORRECTIF : Erreur 17066 lors de la réplication d’un article de table qui contient une colonne de type de données NTEXT dans SQL Server 2008 R2 ou dans SQL Server 2012
1080490 2755767 CORRECTIF : Une opération de restauration du journal des transactions prend plus de temps que prévu et une erreur 3402 se produit si un fichier de base de données est supprimé dans SQL Server 2008 R2 ou dans SQL Server 2012
1133929 2756471 CORRECTIF : un résultat incorrect est renvoyé lorsque vous interrogez une vue indexée à l’aide de l’indicateur NOEXPAND dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
1080476 2757356 CORRECTION : Le message d’erreur « Le composant attend une notification » et le package SSIS 2012 ou SSIS 2008 R2 cesse de répondre lorsque vous utilisez Microsoft Connector 1.1 pour SAP BI afin d’extraire des données de SAP BW
1080458 2761600 CORRECTIF : le texte est tronqué dans un contrôle Tablix d’un rapport de SSRS 2008 R2 ou de SQL Server 2012 après l’exportation du rapport au format PDF ou image
1133941 2761934 La prise en charge des types de données varchar(max), nvarchar(max) et varbinary(max) est ajoutée dans la plupart des fournisseurs de OLE DB dans SQL Server 2012, SQL Server 2008 ou SQL Server 2008 R2
1080492 2762102 CORRECTIF : résultat incorrect lorsque vous exécutez une requête MDX avec une fonction d’agrégation dans SSAS 2008 R2 ou SSAS 2012
1158568 2765785 CORRECTIF : violation d’accès lors de l’exécution d’un package SSIS 2008 R2 ou SSIS 2012 qui contient une transformation de tri sur un ordinateur doté de plusieurs processeurs
1154928 2767183 CORRECTIF : échec de l’installation lorsque vous essayez d’installer SQL Server magasin d’objets blob distant 2012 pour une base de données supplémentaire sur le même instance de SQL Server à l’aide de la ligne de commande
1154929 2769594 SQL Server 2012 rencontre des erreurs de mémoire insuffisante
1154930 2769673 CORRECTIF : la longueur du type de données est doublée dans un script généré lorsque vous utilisez le service SQL Server 2012 Change Data Capture pour Oracle par Attunity
1158570 2770258 CORRECTIF : vous recevez un résultat incorrect lorsque vous exécutez une requête sur une table partitionnée dans SQL Server 2008 R2 ou dans SQL Server 2012
1158572 2776344 CORRECTIF : des blocages se produisent lorsque vous exécutez une procédure stockée pour modifier une table temporaire si le partitionnement de verrou est activé dans SQL Server 2008 R2 ou dans SQL Server 2012
1154933 2776947 CORRECTIF : résultat incorrect dans une colonne calculée lorsque la colonne contient une expression semblable à « ISBLANK(RELATED()) » dans SSAS 2012
1154936 2777097 CORRECTIF : les groupes de mesures définis pour une perspective sont manquants après l’enregistrement ou le déploiement de la perspective dans Visual Studio
1133954 2778088 CORRECTIF : fuite de mémoire si vous activez l’option AUTO_UPDATE_STATISTICS_ASYNC statistiques dans SQL Server 2008, SQL Server 2012 ou SQL Server 2008 R2
1154937 2778200 Un correctif logiciel est disponible pour améliorer les performances d’une requête MDX qui utilise l’opération « NON VIDE » avec des calculs qui se chevauchent dans SQL Server 2012 Analysis Services
1158574 2778479 CORRECTIF : erreurs 17066 et 3624 lors de l’exécution de la procédure stockée sp_refreshview dans un lot volumineux qui effectue des opérations liées aux objets volumineux binaires dans SQL Server 2008 R2 ou dans SQL Server 2012
1101725 2778494 CORRECTIF : résultat incorrect lorsque vous exécutez une requête qui utilise la fonction TRY_CONVERT avec le paramètre de style dans SQL Server 2012
1154931 2779898 CORRECTIF : messages d’erreur lorsque vous empruntez l’identité d’un autre utilisateur et exécutez une requête MDX dans SSAS 2012
1158580 2781008 CORRECTIF : message d’erreur « Utilisateur introuvable » dans SSRS 2008 R2 ou dans SSRS 2012 après la modification du nom d’ouverture de session dans Active Directory
1122125 2781126 CORRECTIF : W3wp.exe exceptions et la batterie de serveurs SharePoint devient indisponible après la désactivation d’une planification de l’actualisation des données pour un classeur PowerPivot dans SharePoint 2013 qui interagit avec SSAS 2012
1155752 2781486 CORRECTIF : messages d’erreur en cas de mise à jour de produit vers une instance gérée par UCP de SQL Server 2008 R2 ou de SQL Server 2012
1133338 2785014 CORRECTIF : violation d’accès lors du fractionnement d’une table partitionnée dans SQL Server 2012
1133455 2785054 CORRECTIF : résultats incorrects lorsqu’une requête fait référence à _90 classements Windows dans SQL Server 2012
1158588 2785079 CORRECTIF : Une erreur « non cédante » se produit sur un serveur pour le transfert de messages Service Broker dans SQL Server 2008 R2 ou dans SQL Server 2012
1154927 2785699 CORRECTIF : Message d’erreur lors de l’affichage des abonnements intégrés pilotés par les données SharePoint après la mise à niveau vers SSRS 2012
1155758 2786212 CORRECTIF : Une violation d’accès se produit lorsque vous exécutez une requête spatiale sur un serveur lié dans SQL Server 2008 R2 ou dans SQL Server 2012
1158592 2788362 CORRECTIF : Erreur 28921 et 18054 lorsque vous démarrez une instance de SQL Server 2008 R2 ou de SQL Server 2012 qui est mise à niveau à partir de SQL Server 7.0
1143654 2790878 CORRECTIF : erreur lors de la réexécution d’une règle de stratégie correspondante dans une application Data Quality Client dans SQL Server 2012
1138636 2792894 CORRECTIF : erreur lors de la publication de règles métier pour une entité dans SQL Server 2012
1161356 2793634 Windows Installer démarre à plusieurs reprises après l’installation de SQL Server 2012 SP1
1140319 2800050 CORRECTIF : le processus d’installation des composants échoue après l’installation de SQL Server 2012 SP1
1128676 2800293 CORRECTIF : le processus de mise en lots basé sur une entité MDS ne met pas à jour les valeurs d’attribut après l’application de SQL Server 2012 SP1
1155994 2800355 CORRECTIF : la valeur d’attribut n’est pas mise à jour pendant la validation lorsque deux règles métier mettent à jour le même attribut avec une certaine valeur dans SQL Server 2012 MDS
1141158 2801379 CORRECTIF : erreur 17883 lors de l’exécution d’une requête sur un serveur doté de nombreux processeurs et d’une grande quantité de mémoire dans SQL Server 2012
1147263;
1147411;
1149051
2792921 Description des nouvelles fonctionnalités de la mise à jour cumulative 2 pour SQL Server 2012 SP1

Informations sur le package de mise à jour cumulative

Informations sur le redémarrage

  Vous devrez peut-être redémarrer l’ordinateur après avoir appliqué cette mise à jour cumulative.

Informations sur le Registre

  Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.

Comment désinstaller ce package de mise à jour cumulative

Pour désinstaller ce package de mise à jour cumulative, procédez comme suit :

  1. Dans le Panneau de configuration, ouvrez l’élément Ajout/Suppression de programmes.

    Remarque Si vous utilisez Windows 7, ouvrez l’élément Programmes et fonctionnalités du Panneau de configuration.

  2. Recherchez l’entrée installée par ce package de mise à jour cumulative.

  3. Cliquez avec le bouton droit sur l’entrée, puis sélectionnez Désinstaller pour supprimer le package de mise à jour cumulative.

Références

  Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

935897
  Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés

  Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

822499
  Schéma d’appellation des packages de mise à jour logicielle de Microsoft SQL Server
   Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684
  Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft