Symptômes
Les exécutions sans assistance de votre flux de bureau échouent avec le code d’erreur AADMachineAlwaysPromptingForPassword , comme illustré dans la capture d’écran ci-dessous.
Cause
Power Automate pour le bureau n’a pas réussi à valider vos informations d’identification Azure Active Directory sur la machine. Cela est généralement dû à un paramètre de stratégie de groupe sur votre ordinateur.
Résolution
Pour voir si un paramètre de stratégie de groupe est à l’origine du problème, vous pouvez accéder à l’Éditeur de stratégie de groupe local (Démarrer > Exécuter > « gpedit.msc »). À partir de là, examinez Stratégie de l’ordinateur local > Configuration de l’ordinateur > Modèles d’administration > Composants Windows > services Bureau à distance > Hôte de session Bureau à distance > Sécurité, puis examinez la valeur « Toujours demander le mot de passe lors de la connexion ». Si cette valeur est définie sur true, vous devez collaborer avec votre service informatique pour désactiver la stratégie pour cet ordinateur. Notez que cette valeur est également reflétée dans le Registre dans le chemin d’accès suivant : Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services; si la clé Terminal Services a une valeur fPromptForPassword définie sur 1, cela signifie que le paramètre est activé et que vous devez travailler avec votre service informatique pour le désactiver (la simple modification de la valeur de Registre n’est généralement pas suffisante, car elle peut être annulée).
Si « Toujours demander le mot de passe lors de la connexion » n’est pas activé et que vous rencontrez toujours l’erreur, utilisez regedit pour ouvrir la clé de Registre suivante : Ordinateur\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp. Recherchez ensuite le DWORD fPromptForPassword et définissez-le sur 0 ; si ce DWORD n’existe pas, vous pouvez le créer.