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Symptômes

Envisagez le scénario suivant :

  • Vous avez une forêt de l’utilisateur et une forêt de ressources dans votre environnement Active Directory. Le Microsoft Exchange Server et Skype pour Business Server sont hébergées dans la forêt de ressources ; Les utilisateurs Active Directory sont hébergées dans la forêt de l’utilisateur.

  • Vous créez un compte d’utilisateur de la forêt d’utilisateur, par exemple, les u utilisateur. L’objectSID est objectSIDU.

  • Vous créez un compte désactivé dans la forêt de ressources, par exemple, l’utilisateur R et remplissez la msRTCSIP-OriginatorSID avec objectSIDU.

  • Vous permettez à l’utilisateur R dans Skype pour Business Server 2015 avec adresse Sip : sip:user@contoso.com.

  • Sur l’Exchange Server, vous créez une boîte aux lettres de l’utilisateur R avec l’adresse de messagerie : smtp:user@contoso.com et créer un groupe, group@contoso.com, puis ajoutez l’utilisateur R en tant que membre de ce groupe.  

  • Sur le Skype pour panneau de Business Server 2015, sélectionnez Les groupes de réponse, cliquez sur groupe, puis cliquez sur Nouveau pour créer un groupe RGS qui utilise le nom du groupe A et ajoutez l’utilisateur de l’agent R.

  • Vous créez un autre groupe RGS qui utilise le nom du groupe B, sélectionnez utiliser une liste de distribution de courrier électronique dans des Agents. Entrée du group@contoso.com adresse liste distribution créé avant.

Dans ce cas, vous pouvez recevoir un message d’erreur semblable au suivant :

205 2AE0.12F78 TL_ERROR(TF_COMPONENT) [6] :: [date].411.0b2bdc21 (Échec de la configuration mise à jour de RgsMatchMakingService,ContactCenterModel.ReportMMConfigurationFailureEvent:contactcentermodel.cs(1943)) (000000000141B8B3), action = [créer], Item = [groupe], identificateur = [IdentifierID], exception=[System.Data.SqlClient.SqlException (0x80131904) : Impossible d’insérer une ligne de clé en double dans l’objet ' dbo. Agents' avec un index unique 'IX_Agents_SipAddress'. La valeur de clé en double est (sip:user@contoso.com).

Cause

Ce problème est dû à une entrée existante dans la table de l’agent qui est utilisée par les groupes de réponse. La table dbo.agent sera remplie avec un SID différent de l’utilisateur R (le compte désactivé que vous avez créé dans la forêt de ressources). Par conséquent, il provoque la duplication.

Résolution

Pour résoudre ce problème, installez la mise à jour de juillet 2018 de cumulative 6.0.9319.534 pour Skype pour Business Server 2015, serveur frontal et serveur de transport Edge.

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