Symptômes
Dans un environnement Microsoft Exchange Server 2016, les utilisateurs connaissent le comportement suivant lorsqu’une opération FindItems est exécutée dans les appels de services Web Exchange (EWS) :
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L’appel EWS échoue avec l’erreur suivante :
Exception non gérée : Microsoft. Exchange. WebServices. Data. ServiceResponseException : une erreur de serveur interne s’est produite. L’opération a échoué... ne peut pas interroger les lignes d’une table.
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Les journaux EWS dans C:\Program Files\Microsoft\Exchange Server\V15\Logging\Ews sur le serveur de rôles de boîte aux lettres indiquent le message d’erreur suivant :
ExceptionHandler_Execute = Microsoft. Exchange. Data. Storage. StoragePermanentException : ne peut pas interroger les lignes d’une table. ---> Microsoft. MAPI. MapiExceptionMaxObjsExceeded : MapiExceptionMaxObjsExceeded : impossible d’interroger les lignes de la table.
Cause
Un changement du nombre de restrictions matérialisées qui peuvent exister dans une boîte aux lettres a été introduit dans Exchange Server 2016. Ce changement peut déclencher une situation dans laquelle un appel FindItems doit créer une nouvelle recherche matérialisée dans la boîte aux lettres mais ne peut pas le faire, car la boîte aux lettres est déjà à la limite.
Résolution
Pour résoudre le problème, installez Exchange Server 2016 cumulative Update 3 ou version ultérieure. Dans le scénario décrit dans la section « symptômes », la recherche matérialisée la plus ancienne sera obsolète après l’installation de cette mise à jour. Par conséquent, une nouvelle recherche peut être créée sans générer d’exception.