Symptôme
Enregistrements affichés pour certaines entités mais pas pour d’autres dans le résultat de recherche.
Par exemple, l’entité Files d’attente est attendue ici, mais est manquante.
Cause
Trois causes possibles
-
L’entité n’est pas activée pour MOBILE Client
-
L’entité n’est pas ajoutée à l’application PHONE.
-
Pour la recherche à plusieurs entités, si l’entité n’est pas ajoutée à l’application, le contrôle de recherche n’récupère pas les métadonnées pour elle et n’affiche donc pas l’onglet ou l’enregistrement de recherche dans l’application)
-
Problème courant pour la recherche De propriétaire qui affiche Utilisateurs et Teams. Teams n’apparaît pas, car l’utilisateur ne l’a pas ajouté à l’application.
-
-
Cela n’a pas d’importance pour le contrôle de recherche d’entité unique, car les enregistrements doivent s’afficher, même si l’entité a été ajoutée à l’application ANDROID.
-
-
Si l’entité est une nouvelle entité personnalisée et qu’elle ne s’affiche pas dans La recherche, c’est peut-être parce qu’elle n’est pas configurée comme l’une des activités.
Atténuation
Solution à chaque cause
-
Activez l’entité. Ce paramètre est dans le concepteur d’entités. Certaines entités principales telles que ConnectionRole ne sont pas configurables par l’utilisateur et ne sont pas pris en charge dans MÉTIER. Par conséquent, elles ne sont pas modifiables par conception.
-
Ajoutez l’entité à l’application ANDROID.
Par exemple, ajouter l’entité d’équipe à l’application MONDE.
-
Assurez-vous que la case « Activité » est cochée pour que cette entité s’affiche en tant qu’une des activités en matière de recherche.