Symptômes
Considérez le scénario suivant :
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Vous activez le partage de cookie entre les membres du groupe dans Microsoft Forefront Threat Management Gateway (TMG) 2010.
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Vous publiez des sites Web par le biais de Forefront TMG 2010.
Dans le scénario, les clients existants qui ont déjà un cookie d’authentification peuvent être impossible d’accéder aux ressources publiées et peuvent recevoir le message d’erreur suivant :
Index non valide de 1413.
Remarque Ce problème concerne principalement les utilisateurs Exchange ActiveSync en leur appareil mobile conserve le cookie ancien jusqu'à ce que le périphérique est redémarré ou supprimé par le serveur.
Cause
Partage de cookie entre les membres du groupe utilise un nouveau format de cookie et le cookie d’authentification qui est fourni par les clients existants n’est pas correctement désactivé après l’activation de la fonctionnalité Partage de cookie.
Résolution
Pour résoudre ce problème, installez le correctif cumulatif 5 pour Forefront Threat Management Gateway (TMG) 2010 Service Pack 2.
Solution de contournement
Pour contourner ce problème, modifiez le nom du cookie qui est défini sur le port d’écoute web. Pour ce faire, procédez comme suit :
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Ouvrez la console Forefront TMG, puis cliquez sur Stratégie de pare-feu.
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Sous l’onglet de la boîte à outils , dans le volet de droite, développez Objets de réseau.
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Développez Ports d’écoute Web, cliquez sur le port d’écoute a été utilisé pour publier les sites Web du problème et puis cliquez sur Propriétés.
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Sous l’onglet formulaires , cliquez sur Avancé.
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Dans le champ Nom du Cookie , tapez un nom de cookie différent, cadata2.
Remarque Par défaut, ce champ est vide, et le nom de cookie par défaut qui est utilisé est cadata. -
Cliquez sur OK, puis cliquez sur OK pour fermer les boîtes de dialogue.
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Cliquez sur Appliquer pour enregistrer les modifications.
Attendez que les modifications à synchroniser avec le Service de pare-feu de Forefront TMG. Pour ce faire, cliquez sur analyse, puis cliquez sur Configuration. Les clients doivent être en mesure d’accéder aux sites publiés lorsque tous les serveurs affichent l’état synchronisés.
Ou bien, demandez les clients à redémarrer leur périphérique mobile ou à fermer toutes les instances de leur navigateur. Cette opération efface le cookie ancien.
État
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».
Références
Obtenir des informations sur la terminologie que Microsoft utilise pour décrire les mises à jour logicielles.