Symptômes
Lorsque vous recevez une erreur 500 revenant WCF à partir d’un port d’envoi, le port d’envoi n’est pas interrompu, mais à la place se termine avec succès. Cela est incompatible avec le comportement de cette même carte lorsque erreur 400 revient et qu’il n’est également pas cohérent avec le comportement des autres cartes basé sur HTTP, qui suspend l’instance de port d’envoi lorsque l’erreur 500 est renvoyé. Ce comportement vous empêche également d’intercepter l’exception dans l’orchestration dans le cas d’une erreur 500.
Cause
Ce problème se produit parce que les adaptateurs WCF ne gèrent pas les erreurs HTTP de la même manière comme cartes HTTP.
Résolution
Ce problème a été corrigé dans les mises à jour cumulatives suivantes pour BizTalk Server :
État
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».
Références
Pour plus d’informations sur les service packs et la liste de mise à jour cumulative pour BizTalk Server, consultez 2555976 de la base de connaissances : le Service pack et liste de mise à jour cumulative pour BizTalk Server.
Pour plus d’informations sur les correctifs de BizTalk Server, consultez 2003907 de la base de connaissances : mettre à jour les informations sur les correctifs de BizTalk et cumulative prise en charge.