Se connecter avec Microsoft
S'identifier ou créer un compte.
Bonjour,
Sélectionnez un autre compte.
Vous avez plusieurs comptes
Choisissez le compte avec lequel vous voulez vous connecter.

Symptômes

Lorsque vous utilisez l’éditeur de profil de suivi (TPE) ou de l’outil BTTDeploy (Bttdeploy.exe) pour déployer un profil de suivi de grande taille (.btt) dans BizTalk Server 2010, le déploiement échoue. En outre, le message d’erreur suivant s’affiche :

La transaction a déjà été implicitement ou explicitement validée ou abandonnée (Exception à partir de HRESULT : 0x8004D00E).


Remarque : Ce package de mise à jour cumulative résout uniquement le problème qui se produit lorsque vous utilisez l’outil Bttdeploy.exe.

Cause

Ce problème se produit car la transaction expire après 3 minutes avant que le profil de grande taille peut être entièrement déployé.

Résolution

Pour résoudre ce problème, appliquez ce correctif. Après avoir appliqué le correctif, vous pouvez étendre la valeur de délai d’attente par défaut une valeur supérieure à 3 minutes.

Remarque  Ce correctif s’applique à l’outil de ligne de commande BTSDeploy.exe et pas aux autres outils Business Activity Monitoring (BAM).

Pour étendre la valeur de délai d’attente par défaut, ajoutez les lignes suivantes au fichier BTSDeploy.exe.config :

<configuration>
  <appSettings>
< Ajouter clé = « CommandTimeoutInMinutes » value = »nn"/ >
  </appSettings>
</ configuration>
Remarques

  • L’espace réservé nn représente le nombre de minutes que vous souhaitez définir comme la valeur de délai d’attente par défaut.

  • Si le délai d’expiration atteint 10 minutes ou plus, vous devez également tenir compte de la valeur de délai d’attente par défaut du.NET Framework dans le fichier Machine.config. Cette valeur doit être identique ou supérieure à la valeur de délai d’attente dans le fichier BTSDeploy.exe.config.

  • Sachez que l’augmentation de la valeur de délai d’attente peut résoudre pas entièrement le problème. Étant donné que ce comportement peuvent également déclencher des autres problèmes sous-jacents, il se peut que vous deviez suivi de profils, BizTalk configuration, Windows configuration, SQL Server de performances, les performances de stockage, et les performances du réseau pour résoudre le problème réel.


Informations de mise à jour cumulative

Le correctif qui résout ce problème est inclus dans les 6 mise à jour Cumulative pour BizTalk Server 2010.

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Solution de contournement

Pour contourner ce problème, utilisez une des méthodes suivantes :

  • Déploiement des profils de plus petite taille de suivi afin que la réponse de la transaction ne dépasse pas 3 minutes.

  • Optimiser SQL Server pour répondre à la transaction dans le délai de 3 minutes.

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.

Les communautés vous permettent de poser des questions et d'y répondre, de donner vos commentaires et de bénéficier de l'avis d'experts aux connaissances approfondies.

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?
En cliquant sur Envoyer, vos commentaires seront utilisés pour améliorer les produits et services de Microsoft. Votre administrateur informatique sera en mesure de collecter ces données. Déclaration de confidentialité.

Nous vous remercions de vos commentaires.

×