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Symptômes

Prenons l’exemple du scénario suivant :

  • Vous configurez Microsoft Forefront Threat Management Gateway 2010 pour utiliser le remplacement de l’utilisateur pour les catégories bloquées introduit dans Microsoft Forefront Threat Management Gateway 2010 Service Pack 1 (SP1).

  • Vous configurez Forefront Threat Management Gateway 2010 pour générer des rapports afin de surveiller les utilisateurs qui remplacementnt les règles de refus.


Dans ce scénario, vous pouvez trouver que les informations de synthèse de la table DES URL les plus hautes et de la table Top Rule Override Users affichent des informations incorrectes et que les valeurs semblent beaucoup plus grandes que prévu.

Cause

Ce problème se produit parce que la procédure stockée pour synthétiser ces informations n’a pas pour conséquence d’accumuler les valeurs du jour précédent dans les valeurs du jour suivant.

Résolution

Pour résoudre ce problème, installez le package de correctifs logiciels qui est décrit dans l’article suivant de la Base de connaissances Microsoft :

2649961 Correctif 1 pour Forefront Threat Management Gateway (TMG) 2010 Service Pack 2 Pour activer ce correctif, exécutez le script FixSoftBlockSummaries.js sur l’un des serveurs de Forefront Threat Management Gateway. Vous pouvez exécuter ce script sur n’importe quel serveur Forefront Threat Management Gateway, un nœud de matrice ou un serveur de gestion d’entreprise.

Notez que le script résumant tous les tableaux disponibles et corrige la procédure stockée afin que les informations de synthèse sont créées correctement. Vous deront peut-être exécuter à nouveau le script si de nouveaux tableaux sont ajoutés au stockage.


Pour nous permettre d’activer ce correctif pour vous, allez à la section«Résoudre le problème pour moi ». Si vous préférez activer ce correctif vous-même, allez à la section «Laissez-moi le résoudre vous-même».

Aidez-moi



Pour activer ce correctif automatiquement, cliquez sur le bouton ou le lien corriger. Cliquez ensuite sur Exécuter dans la boîte de dialogue Téléchargement de fichier, puis suivez les étapes de l’Assistant De réparation.




Notes

  • Installez un correctif décrit dans l’article 2649961 de la Base de connaissances Microsoft avant d’exécuter cette solution de réparation.

  • Il se peut que cet Assistant ne soit disponible qu’en anglais. Toutefois, la résolution automatique fonctionne aussi pour d’autres versions linguistiques de Windows.

  • Si vous n’utilisez pas l’ordinateur concerné, vous pouvez enregistrer la solution sur un lecteur flash ou sur un CD-ROM et ensuite l’exécuter sur l’ordinateur concerné par le problème.


Ensuite, allez à la section « Le problèmeest-ilcorrigé ? ».



Je résous le problème moi-même

  1. Démarrez le Bloc-notes. Pour démarrer le Bloc-notes, cliquez surDémarrer, puissur Exécuter, tapez notepad.exe dans la zone Ouvrir, puis cliquez sur OK.

  2. Collez le script suivant dans un nouveau fichier Bloc-notes.

    var guidGenerator = new ActiveXObject("Scriptlet.TypeLib");
    var fpcRoot = new ActiveXObject("FPC.Root");
    try
    {
    WScript.Echo("Enumerating arrays:");
    var arraysCollection = new Enumerator(fpcRoot.Arrays);
    for (; !arraysCollection.atEnd(); arraysCollection.moveNext())
    {
    try
    {
    var array = arraysCollection.item();
    var found = false;
    WScript.Echo(" " + array.Name);
    var sumDefsCollection = new Enumerator(array.Reports.ReportSummaryDefinitions);
    for(; !sumDefsCollection.atEnd(); sumDefsCollection.moveNext())
    {
    var sumDef = sumDefsCollection.item();
    if(sumDef.Name != "spTrimArraySoftBlockSummary")
    {
    continue;
    }

    if (sumDef.AggregationStatement.indexOf("@ToDate AS [Date]") < 0)
    {
    WScript.Echo("---- spTrimArraySoftBlockSummary.AggregationStatement already contains fix, skipping array");
    break;
    }

    found = true;
    WScript.Echo("Found summary definition " + sumDef.Name + ", will fix the AggregationStatement");
    WScript.Echo("---- Old version start");
    WScript.Echo(sumDef.AggregationStatement);
    WScript.Echo("---- Old version end");
    sumDef.AggregationStatement = sumDef.AggregationStatement.replace(/@ToDate AS \[Date\]/g, "@FromDate AS [Date]");
    WScript.Echo("---- New version start");
    WScript.Echo(sumDef.AggregationStatement);
    WScript.Echo("---- New version end");
    break;
    }
    if (found)
    {
    WScript.Echo("Updating configuration ID...");
    WScript.Echo("Old configuration ID:" + array.Reports.ReportingServicesProperties.ReportingServicesConfigurationId);
    array.Reports.ReportingServicesProperties.ReportingServicesConfigurationId = guidGenerator.Guid;
    WScript.Echo("New configuration ID:" + array.Reports.ReportingServicesProperties.ReportingServicesConfigurationId);

    WScript.Echo("Saving the current configuration...");
    array.Save();
    WScript.Echo("Waiting for configuration reload...");
    array.WaitForReload();
    }
    }
    catch (err)
    {
    WScript.Echo("An error occurred. Error Decscription: " + err.description);
    WScript.Echo("Try running the script as an administrator");
    }
    }
    }
    catch (err)
    {
    WScript.Echo("An error occurred. Error Decscription: " + err.description);
    WScript.Echo("Try running the script as an administrator");
    }
  3. Enregistrez le fichier au FixSoftBlockSummaries.js, puis quittez le Bloc-notes.

  4. Sur un serveur, ouvrez une invite de commandes d’administration.

  5. Exécutez le script à l’aide de la commande suivante :

    cscript.exe FixSoftBlockSummaries.js

Attendez la fin du script et la synchronisation de la configuration. Après cela, des informations sur les utilisateurs qui ont pris le pas sur les règles d’refus sont créées correctement. Le script ne peut pas résoudre ce problème pour les données de synthèse précédentes.

Le problème est-il résolu ?

  • Vérifiez que le problème est résolu. Si c'est le cas, vous n'avez plus besoin de cette section. Sinon, vous pouvez contacter le support technique.

  • Vos commentaires sont les bienvenus. Pour nous faire part de vos commentaires ou d’un problème concernant cette solution, écrivez-nous sur le blog « Fix it for me » ou envoyez-nous un courrier électronique.

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Références

Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft :

824684 Terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

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