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Symptômes

Considérez le scénario suivant :

  • Vous avez quelques partitions en ligne analytique traitement ROLAP (Relational) dans un cube Microsoft SQL Server 2008 R2 Analysis Services (SSAS 2008 R2).

  • Vous exécutez une requête d’Expressions multidimensionnelles (MDX) sur les partitions ROLAP. Par conséquent, certaines requêtes ROLAP sont envoyés à SQL Server.

  • Une erreur se produit lors de l’évaluation d’une requête MDX, et la tâche de traitement de la requête MDX se fige. Par exemple, SQL Server renvoie le message d’erreur suivant sur les requêtes ROLAP :

    La transaction active dans cette session a été validée ou arrêtée par une autre session


Dans ce scénario, aucune transaction ne peut être validée et vous ne pouvez pas vous connecter avec SSAS.

Cause

Le problème se produit car, lorsque les requêtes ROLAP sont envoyés à SQL Server et les requêtes échouent avec une erreur, un thread enfant de la requête MDX s’arrête dans SSAS. Toutefois, le thread de requête principale est toujours en attente pour le thread enfant. Par conséquent, le thread principal bloque commit de traitement et de cette évaluation de sécurité de blocs pour toutes les nouvelles sessions de l’utilisateur.

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et de sécurité inclus dans la mise à jour cumulative précédente. Découvrez les dernières mises à jour cumulatives pour SQL Server :


Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n’apparaît pas, soumettez une demande au Service Clients et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web Microsoft suivant :

http://support.microsoft.com/contactus/?ws=supportRemarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

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