Symptômes
Envisagez le scénario suivant. Vous travaillez avec un canal de Windows Communication Foundation (WCF) pour WebSphere MQ dans un environnement Microsoft Host Integration Server 2010. Le Gestionnaire de file d’attente est arrêté pour une raison quelconque, telle qu’une connexion réinitialisée dans le transport.
Dans ce scénario, le canal WCF ne peut pas se reconnecter. Ensuite, chaque requête de lecture successive échoue et vous recevez le code de motif 6124 comme suit :
Une méthode a échoué, car une connexion nécessaire à un gestionnaire de file d’attente n’était pas disponible, et établir une connexion ne peut pas être implicitement car l’indicateur IMQ_IMPL_CONN de l’attribut de la classe ImqQueueManagerbehavior a la valeur FALSE.
Cause
Ce problème se produit parce que l’erreur est gérée de manière incorrecte lorsque le Gestionnaire de file d’attente est arrêté.
Résolution
Informations de mise à jour cumulative
Le correctif qui résout ce problème est inclus dans le package de mise à jour cumulative 8 pour Host Integration Server 2010. Pour plus d’informations sur l’obtention de la liste cumulative mise à jour de package, reportez-vous à la section 8 pour Host Integration Server 2010 de package de mises à jour cumulatives.
État
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».