PROBLÈME
Lorsque vous essayez de déplacer ou d’intégrer une boîte aux lettres de votre environnement Exchange local vers Exchange Online dans Office 365 dans un déploiement exchange hybride, vous recevez un message d’erreur qui ressemble à l’un des suivants :
-
Erreur(s) : l’appel à https ://mail.<DomainName>.com/ews/mrsproxy.svc a échoué, car aucun service n’écoutait sur le point de terminaison spécifié Détails de l’erreur : Aucun point de terminaison à l’écoute à l’adresse https ://mail.<DomainName>.com/ews/mrsproxy.svc ne pouvait accepter le message. Cela est souvent dû à une adresse ou une action SOAP incorrecte. Le serveur distant a renvoyé une erreur 404 introuvable.
-
Erreur : MigrationTransientException : l’appel à « https ://mail.<DomainName>.com/EWS/mrsproxy.svc » a expiré.Détails de l’erreur : Le canal de requête a expiré en attendant une réponse après 00:00:00.0020000. Augmentez la valeur du délai d’attente passé à l’appel à Request ou augmentez la valeur SendTimeout sur la liaison. Le temps alloué à cette opération peut avoir été une partie d’un délai d’expiration plus long. --> La requête HTTP à « https ://mail.<DomainName>.com/EWS/mrsproxy.svc » a dépassé le délai d’expiration alloué de 00:00:00.0020000.
-
Erreur : MigrationTransientException : l’appel à « https://mail.contoso.com/EWS/mrsproxy.svc » a échoué, car aucun service n’écoutait sur le point de terminaison spécifié.Détails de l’erreur : aucun point de terminaison à l’écoute de https://mail.contoso.com/EWS/mrsproxy.svc ne pouvait accepter le message. Cela est souvent dû à une adresse ou une action SOAP incorrecte. Pour plus d’informations, consultez InnerException, le cas échéant.Le serveur distant a renvoyé une erreur : (404) Introuvable. --> L’appel à « https://mail.contoso.com/EWS/mrsproxy.svc » a échoué, car aucun service n’écoutait sur le point de terminaison spécifié.
Toutefois, vous pouvez toujours être en mesure de déplacer d’autres boîtes aux lettres avec succès.
23/10/2020 : 20:09 UTC : bluehawk prod test
CAUSE
Ce problème peut se produire si la propriété ExchangeGUID de l’objet MailUser Exchange Online ne correspond pas à la propriété ExchangeGUID de la boîte aux lettres locale. Pour déplacer correctement une boîte aux lettres, la valeur de la propriété ExchangeGUID dans la boîte aux lettres Exchange Online et dans la boîte aux lettres distante locale associée doit correspondre.
SOLUTION
Définissez la propriété ExchangeGUID de l’utilisateur à extension messagerie dans Exchange Online pour qu’elle corresponde à la propriété ExchangeGUID de la boîte aux lettres locale correspondante, puis réessayez le déplacement. Pour cela, procédez comme suit :
-
Récupérez la valeur de la propriété ExchangeGUID pour la boîte aux lettres locale que vous souhaitez déplacer. Pour ce faire, ouvrez Exchange Management Shell sur le serveur local, puis exécutez la commande suivante :
Get-Mailbox <MailboxName> | Format-List ExchangeGUID
Notez la valeur. Vous en aurez besoin plus tard à l’étape 2B.
-
Connectez-vous à Exchange Online à l’aide du PowerShell à distance. Pour plus d’informations, consultez Se connecter à Exchange Online à l’aide de PowerShell à distance. Ensuite, procédez comme suit :
-
Déterminez la valeur de la propriété ExchangeGUID de l’utilisateur à extension messagerie dans Exchange Online. Pour ce faire, exécutez la commande suivante :
Get-MailUser -Identity <UserName> | fl displayname,ExchangeGuid
-
Définissez la valeur de la propriété ExchangeGUID de l’utilisateur à extension messagerie dans Exchange Online pour qu’elle corresponde à la propriété ExchangeGUID de la boîte aux lettres locale. Pour ce faire, exécutez la commande suivante :
Set-MailUser -Identity <UserName> -ExchangeGUID <Value Retrieved From Step 1>
-
-
Réessayez le déplacement.
INFORMATIONS SUPPLÉMENTAIRES
Encore besoin d’aide ? Accédez à la Communauté Microsoft ou aux Forums TechNet Exchange.