Symptômes
Vous pouvez rencontrer un ou plusieurs des problèmes suivants dans Windows Small Business Server (SBS) 2011.
Lorsque vous installez Windows SBS 2011, vous recevez un ou plusieurs des messages d'erreur suivants :
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Après l'installation de Windows SBS 2011, les problèmes suivants se produisent :
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Lorsque vous ouvrez la console de gestion Exchange sur un ordinateur qui exécute Windows SBS 2011, vous recevez le message suivant : Les serveurs suivants de votre organisation exécutant Exchange Server 2010 sont actuellement sans licence. Remarque Ce message affiche également le nom de l'ordinateur qui exécute Windows SBS 2011 Standard. |
Cause
Ces problèmes peuvent se produire lorsque l'une des conditions suivantes est remplie :
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Condition 1 :
Pendant l'installation de Windows SBS 2011, Exchange Server 2010 n'a pas été installé. Exchange Server 2010 a été installé plus tard manuellement. -
Condition 2 :
Exchange Server 2010 a été désinstallé à partir de Windows SBS 2011, puis a été réinstallé. -
Condition 3 :
Une installation de réparation d'Exchange Server 2010 a été effectuée sur le serveur Windows SBS 2011.
Résolution
Pour résoudre ce problème si vous vous trouvez dans les conditions 1 ou 2, suivez la procédure indiquée dans la section « Script PowerShell pour résoudre les problèmes d'Exchange Server ». Ensuite, installez le correctif logiciel décrit dans la section « Informations sur le correctif logiciel ».
Pour résoudre ce problème si vous vous trouvez dans la condition 3, installez le correctif logiciel décrit dans la section « Informations sur le correctif logiciel ».
Script PowerShell pour résoudre les problèmes d'Exchange Server
Important Avant d'effectuer cette procédure, Exchange Server 2010 doit être installé correctement. N'effectuez pas la procédure décrite dans cet article si les rôles suivants d'Exchange Server 2010 ne sont pas installés correctement :
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Boîte aux lettres
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Transport/Hub
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CAS (serveur d'accès au client)
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Gestion
Les étapes suivantes définissent les paramètres par défaut d'Exchange Server 2010 pour une installation correcte de Windows SBS 2011.
Remarque Si vous avez configuré manuellement les paramètres dans Exchange, ceux-ci peuvent être modifiés et le flux de courrier risque de s'arrêter jusqu'à ce que vous terminiez les Assistants Windows SBS appropriés ou jusqu'à la reconfiguration d'Exchange Server. En outre, vous devez disposer d'une topologie de réseau prise en charge d'une seule carte réseau et d'un sous-réseau de classe C.
Cette procédure apporte les modifications suivantes :
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Définit le nom Base de données de boîtes aux lettres dans le Registre
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Corrige la version de rôle des outils d'administration dans le Registre
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Ajoute une valeur par défaut de l'attribut Active Directory msSBSEmailQuota pour les trois rôles Windows SBS par défaut
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Configure les rôles de sécurité appropriés pour gérer le serveur qui exécute Exchange Server
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Ajoute les autorisations au niveau de l'organisation pour donner accès au compte système
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Crée les groupes suivants si les groupes n'ont pas été créés :
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SBSAdmins
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Allusers
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Postmaster
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FSRMReports
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Définit la même appartenance et les mêmes paramètres pour chacun de ces groupes
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Configure les paramètres de transport pour les serveurs internes et une adresse d'administrateur
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Relie le connecteur de réception par défaut au réseau interne, IP interne du routeur non compris
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Supprime le connecteur de réception du client par défaut
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Active le certificat auto-émis Windows SBS avec CN=Sites
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Supprime le certificat auto-signé Exchange Server
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Configure les paramètres de message électronique sortant dans Microsoft SharePoint
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Ajoute un enregistrement d'hôte DNS pour le serveur SharePoint SMTP (Simple Mail Transfer Protocol)
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Ajoute diverses clés de Registre pour supprimer les problèmes d'installation
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Active le serveur Exchange en utilisant l'outil fourni
Pour résoudre ces problèmes si Exchange Server 2010 a été installé manuellement après l'installation de Windows SBS 2011 ou si Exchange Server 2010 a été réinstallé sur le serveur Windows SBS 2011, procédez comme suit :
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Sélectionnez la commande Exécuter en tant qu'administrateur pour exécuter Exchange Management Shell en mode élevé.
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Dans l'environnement Exchange Management Shell, exécutez les commandes suivantes dans cet ordre :
#SBS 2011 Std
#Lancer à partir d'Exchange Management Shell en tant qu'administrateur.
#Ce script effectue les tâches manquantes après l'échec d'une installation Exchange lors d'une migration.
# Exécuter chacune des sections, séparées par les commentaires individuellement.
##Le programme d'installation Exchange doit être réalisé en utilisant les paramètres appropriés avant d'exécuter ce script.
##Configurer le nom de boîte aux lettres dans le Registre
$mbx = Get-MailboxDatabase -server $env:COMPUTERNAME
Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Messaging" -name "MailboxDatabaseName" -value $mbx.Name
##Ajouter une clé de Registre pour les outils d'administration ; cela est nécessaire en raison de la manière dont SBSSetup est empaqueté.
$Version = get-itemproperty "HKLM:\Software\Microsoft\ExchangeServer\V14\AdminTools"
Set-ItemProperty "HKLM:\Software\Microsoft\ExchangeServer\V14\AdminTools" -name "ConfiguredVersion" -value $Version.UnpackedVersion
##Configurer l'attribut Exchange dans les rôles d'utilisateur. Cette opération peut échouer en cas d'absence de rôles d'utilisateur.
Module d'importation ActiveDirectory
set-aduser "Standard User" -Add @{msSBSEmailQuota=2097152}
set-aduser "WebWorkplaceTools" -Add @{msSBSEmailQuota=2097152}
set-aduser "Network Admin" -Add @{msSBSEmailQuota=2097152}
##ExchangeAdminPrep
Add-RoleGroupMember -Identity "Organization Management" -Member "$env:USERDOMAIN\Domain Admins" -BypassSecurityGroupManagerCheck
Add-RoleGroupMember -Identity "View-Only Organization Management" -Member "$env:USERDOMAIN\$env:COMPUTERNAME$" -BypassSecurityGroupManagerCheck
$org = Get-OrganizationConfig
add-adpermission -Identity $org.DistinguishedName -User "SYSTEM" -AccessRights "GenericAll" -InheritanceType "All"
##CreateMailDisributionGroupsTask
# Si les groupes existent déjà, il est possible qu'une erreur s'affiche. Ce n'est pas grave, c'est uniquement pour signaler que l'installation de SBS a été effectuée plusieurs fois et que la source n'a jamais été restaurée à partir d'une sauvegarde.
New-DistributionGroup -SamAccountName "sbsadmins" -Alias "sbsadmins" -Name "Windows SBS Administrators" -OrganizationalUnit $env:USERDNSDOMAIN"/MyBusiness/Distribution Groups" -Type "Distribution" -ErrorAction SilentlyContinue
New-DistributionGroup -SamAccountName "allusers" -Alias "allusers" -Name "All Users" -OrganizationalUnit $env:USERDNSDOMAIN"/MyBusiness/Distribution Groups" -Type "Distribution" -ErrorAction SilentlyContinue
Enable-DistributionGroup -Identity "All Users" -Alias "allusers" -WarningAction SilentlyContinue -ErrorAction SilentlyContinue
Enable-DistributionGroup -Identity "Windows SBS Administrators" -Alias "sbsadmins" -WarningAction SilentlyContinue -ErrorAction SilentlyContinue
Set-DistributionGroup -RequireSenderAuthenticationEnabled $false -Identity "Windows SBS Administrators" -ForceUpgrade
New-DistributionGroup -SamAccountName "postmaster" -Alias "postmaster" -Name "Postmaster and Abuse Reporting" -OrganizationalUnit $env:USERDNSDOMAIN"/MyBusiness/Distribution Groups" -Type "Distribution" -WarningAction SilentlyContinue -ErrorAction SilentlyContinue
Set-DistributionGroup -Identity "Postmaster and Abuse Reporting" -RequireSenderAuthenticationEnabled $false -HiddenFromAddressListsEnabled $true -EmailAddresses "SMTP:postmaster@$env:USERDNSDOMAIN","SMTP:abuse@$env:USERDNSDOMAIN" -EmailAddressPolicyEnabled $false -ForceUpgrade -WarningAction SilentlyContinue -ErrorAction SilentlyContinue
Add-DistributionGroupMember -Identity "Postmaster and Abuse Reporting" -Member "Windows SBS Administrators"
New-DistributionGroup -SamAccountName "fsrmreports" -Alias "fsrmreports" -Name "File Server Resource Manager Reports" -OrganizationalUnit $env:USERDNSDOMAIN"/MyBusiness/Distribution Groups" -Type "Distribution" -WarningAction SilentlyContinue -ErrorAction SilentlyContinue
Set-DistributionGroup -Identity "File Server Resource Manager Reports" -HiddenFromAddressListsEnabled $true -ForceUpgrade
Add-DistributionGroupMember -Identity "File Server Resource Manager Reports" -Member "Windows SBS Administrators"
##ConfigureIntranetSMTPTask
Set-TransportConfig -InternalSMTPServers 127.0.0.1
set-transportconfig -ExternalPostmasterAddress "postmaster@$env:USERDNSDOMAIN"
##Relier le connecteur de réception par défaut
# Cette section modifie le connecteur de réception par défaut de manière à ce qu'il n'écoute que sur le sous-réseau interne (moins le routeur), le flux de courrier risque de s'arrêter à cette étape.
$ip=(gwmi Win32_NetworkAdapterConfiguration | ? { $_.IPAddress -ne $null }).ipaddress.get(0)
$gateway=(gwmi Win32_NetworkAdapterConfiguration | ? { $_.IPAddress -ne $null }).DefaultIPGateway
$gw="$gateway"
$gwIp=$gw.split('.')
$subnet=$gw.Remove($gw.LastIndexOf('.'))+".0"
$range=$subnet+"-"+$gw.Remove($gw.LastIndexOf('.'))+"."+($gwIp.get(3)-1)+","+$gw.Remove($gw.LastIndexOf('.'))+"."+([int]$gwIp.get(3)+1)+"-"+$gw.Remove($gw.LastIndexOf('.'))+".255"
$con = get-receiveconnector -Identity "Default $env:computername"
$ip+=":25"
$con.Bindings=$ip
set-receiveconnector -Identity "Default $env:computername" -Bindings $con.Bindings
$ipAdd= $range.Split(',')
$con.remoteipranges = $ipAdd[0]
$con.remoteipranges += $ipAdd[1]
set-receiveconnector -Identity "Default $env:computername" -RemoteIpRanges $con.remoteipranges
##Supprimer le connecteur de réception du client par défaut
# S'il est en cours d'utilisation, cette étape doit être ignorée ou le connecteur recréé.
remove-receiveconnector -Identity "Client $env:computername" -Confirm:$false
##Supprimer le certificat Exchange par défaut et activer le nôtre
Get-ExchangeCertificate | ? {$_.Subject -eq "CN=Sites"} | Enable-ExchangeCertificate -services SMTP -force:$true
#remove
Get-ExchangeCertificate | ? {$_.FriendlyName -eq "Microsoft Exchange"} | Remove-ExchangeCertificate
##Nouveau connecteur de réception
#Créer le connecteur de réception interne pour SharePoint, télécopie et connecteur POP3
new-receiveconnector -Name "Windows SBS Fax Sharepoint Receive $env:computername" -RemoteIPRanges 127.0.0.1-127.0.0.1 -Bindings "127.0.0.1:25" -AuthMechanism "BasicAuth" -PermissionGroups "AnonymousUsers, ExchangeUsers" -Usage "Custom" -Server "$env:COMPUTERNAME" -ConnectionTimeout "00.06:00:00"
##ConfigureWSSOutgoingEmailTask
# Configure le routage de courrier sortant de SharePoint pour utiliser Exchange.
# Cette opération peut ne pas fonctionner si SharePoint n'utilise pas les paramètres par défaut ou ne fonctionne pas.
Add-PsSnapin Microsoft.SharePoint.PowerShell
$spWebApp=Get-SPWebApplication
$mail="CompanyWebAdmin@"+$env:userdnsdomain
$spWebApp.UpdateMailSettings("SharepointSMTPServer",$mail,$mail,65001)
dnscmd $env:computername /recordadd $env:userdnsdomain SharepointSMTPServer A 127.0.0.1
##Ajouter les composants de messagerie de la clé de Registre
$val = get-itemproperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Components\"
Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Components" -name "Messaging" -value $val.administration
##Résoudre les problèmes d'affichage
Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Setup" -name "DisplayIssues" -value False
##Filigrane de script de balise
$date=Get-Date
Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Setup" -name "RepairScript" -value "ExchangeFailureCompleteSetup $date" -
Ajoutez des utilisateurs à l'aide de la console Windows SBS.
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Terminez l'Assistant de gestion des adresses Internet.
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Installez le package de correctifs logiciels correspondant pour activer le serveur Exchange.
Accédez à la section suivante pour installer le package de correctifs logiciels pour activer le serveur Exchange.
Informations sur le correctif logiciel
Un correctif logiciel pris en charge est disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. Ne l'appliquez qu'aux systèmes sur lesquels vous constatez ce problème spécifique.
Si le correctif logiciel est disponible au téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, soumettez une demande aux services de Support technique Microsoft afin d'obtenir le correctif logiciel.
Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support s'appliqueront aux autres questions et problèmes non directement liés au correctif logiciel en question. Pour obtenir la liste complète des numéros de téléphone des services de Support technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ln=fr&ws=support#tab0Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif logiciel est disponible. Si votre langue n'est pas répertoriée, cela signifie qu'aucun correctif logiciel n'est disponible pour cette langue.
Conditions requises
Pour appliquer ce correctif, vous devez exécuter Windows Small Business Server 2011.
Informations sur le Registre
Pour utiliser le correctif logiciel de ce package, vous ne devez apporter aucun changement au Registre.
Nécessité d'un redémarrage
Vous ne devez pas redémarrer votre ordinateur après avoir appliqué ce correctif logiciel.
Informations sur le remplacement de correctif logiciel
Ce correctif logiciel ne remplace aucun correctif logiciel publié précédemment.