FIX: Assistant de mise à niveau apparaît à nouveau lorsque vous rouvrez la solution SSIS 2014 avec des paquets SSIS mis à niveau

Symptômes

Prenons l’exemple du scénario suivant :

  • Vous disposez d'une solution Microsoft SQL Server 2014 Integration Services (SSIS 2014) qui contient certains paquets SSIS qui sont utilisés dans les versions antérieures de SSIS, et le nom de certains paquets (exclure ".dtsx") contient des points (".").

  • Vous mettez à niveau ces paquets pour les utiliser dans SSIS 2014.

  • Vous ouvrez le fichier de solution (.sln file) dans Microsoft SQL Server Data Tools - Business Intelligence (SSDT-BI), et complétez les étapes de l'assistant de mise à niveau. Le rapport de mise à niveau affiche une mise à niveau réussie sans aucune erreur.

  • Vous essayez d'ouvrir à nouveau le fichier de solution dans SSDT-BI.

Dans ce scénario, l'assistant de mise à niveau apparaît à nouveau, et demande la mise à niveau.

Cause

Ce problème se produit parce qu'il y a un défaut dans l'outil de mise à niveau SSDT. Lorsque le nom du paquet (exclut .dtsx) contient plusieurs points, l'outil de mise à niveau enregistre le nom du fichier du paquet sur la chaîne avant le dernier point, puis annexe ".dstx". Par exemple, si le nom de fichier de paquet est A.B.C.dtsx, l'outil de mise à niveau l'enregistre en tant que A.B.dtsx. Par conséquent, la mise à niveau ne se produit pas sur le fichier de paquet d'origine, et lorsque vous rouvrez la solution, l'assistant de mise à niveau apparaît également à nouveau.

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs et toutes les corrections de sécurité qui ont été inclus avec la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×