Symptômes
Ce problème se produit lorsque le traitement des normes FIPS (Federal Information) pour Service Response Group (RGS) est activé dans un Skype Microsoft pour Business Server 2015 environnement.
En outre, lorsque vous établissez des extrémités de l’application, vous pouvez voir l’exception suivante :
sip:RtcApplication-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX@domain.com
sip:RtcApplication- XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX@domain.com
sip:RtcApplication- XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX@domain.com
Exceptions : System.Reflection.TargetInvocationException - System.Reflection.TargetInvocationException : une Exception a été levée par la cible d’un appel. ---> System.InvalidOperationException : cette implémentation ne fait pas partie des algorithmes de chiffrement validés Windows Platform FIPS.
à System.Security.Cryptography.SHA512Managed... ctor()
---Fin de la trace de pile d’exception interne---
à System.RuntimeMethodHandle.InvokeMethod (cible de l’objet arguments de [] objet, Signature sig, constructeur Boolean)
à System.Reflection.RuntimeConstructorInfo.Invoke (BindingFlags invokeAttr, binder de Binder, Object [] parameters, CultureInfo culture)
à System.Security.Cryptography.CryptoConfig.CreateFromName (String nom, objet [] args)
à System.Security.Cryptography.SHA512.Create()
à Microsoft.Rtc.Acd.Common.ConsistentHash'2..ctor (Func'2 nodeToHashKeyConverter, Func'2 requestToHashKeyConverter, virtualNodesMultiplier de Int32)
à Microsoft.Rtc.Acd.MatchMaking.PresenceProvider.PresenceComponent.Initialize (IReadOnlyCollection'1 presenceEndpoints, maxRgsAgentsPerPresenceWatcher de Int32)
à Microsoft.Rtc.Acd.MatchMaking.MatchMakingService.Start (IReadOnlyCollection'1 presenceEndpoints)
à Microsoft.Rtc.Acd.AepManager.StartMMAndItsDependencies (IReadOnlyCollection'1 presenceEndpoints)
Cause : Impossible de se connecter au serveur frontal ou le Front-End server est mal configuré.
Solution : Vérifiez le serveur frontal pour les erreurs.
Cause
Ce problème se produit car les classes MD5 et SHA512Managed n’ont FIPS activé.
Résolution
Pour résoudre ce problème, installez les mises à jour cumulatives suivantes :
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2017 de mai cumulative mise à jour 6.0.9319.281 pour Skype pour Business Server 2015, Service Response Group
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2017 de mai cumulative mise à jour 6.0.9319.281 pour Skype pour Business Server 2015, composants