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Symptômes

Lorsque vous essayez d’affecter un échéancier de paiement nouvellement créé dans le portail BP (Human Resource Self Service Suite) pour les entreprises de Microsoft Dynamics GP ou modifiez un échéancier de paiement existant, l’un des messages d’erreur suivants s’offre à vous :

 

L’échéancier de paiement a des dates qui chevauchent l’échéancier de paiement actif de l’année dernière. Vous ne pouvez pas enregistrer deux échéanciers de paiement actifs qui partagent des dates.

ou

Les périodes de paiement affectées à cette fréquence de paiement ne correspondent pas à la fréquence de paiement. Recalculer les périodes de paiement de l’échéancier de paiement.

Cause

Le problème avec le premier message ci-dessus se produit, car la date de début de la période 1 dans le nouvel échéancier de paiement chevauche la date de la dernière période de l’échéancier de paiement précédent. Toutefois, le module HRMSSS nécessite une période de paiement de 365 jours, et ne permet pas d’ignorer ou de chevaucher des dates entre deux plannings.


Le problème avec le deuxième message ci-dessus est que le planning de paiement est de 364 jours et que le système exige qu’il y soit de 365 jours avant que les modifications qui lui soient apportées soient autorisées, ou qu’un nouvel échéancier de paiement adjacent à celui-ci puisse être créé.
 

Résolution


Exemple :

Supposons que votre échéancier de paiement 2021 s’exécute du 23 décembre 2021 au 22 décembre 2022. Dans cet exemple, vous voulez créer un échéancier de paiement nommé « 2022 » qui commence le 22 décembre 2022, mais vous ne pouvez pas, car il a déjà été utilisé par l’échéancier de paiement précédent. 

Échéancier de paiement : Date de début -Date de fin

2021 : est actuellement prêt pour les dates 23/12/2021 - 22/12/2022

2022 : vous souhaitez les dates 22/12/2022 - 21/12/2023 ; Vous souhaitez commencer cette nouvelle planification le 22/12/2022, mais vous ne pouvez pas, car cette date a déjà été utilisée par l’échéancier de paiement de l’année précédente. 

Remarque : le système nécessite le « nom » de la période pour coïncider avec l’empreinte « année » sur la « date de début » de cet échéancier de paiement.

Pour contourner ce problème, utilisez l’une des méthodes suivantes :

  • Si vous utilisez BP 4.0 avec Microsoft Dynamics GP 10.0, utilisez la méthode 1 ou la méthode 2 ci-dessous.

  • Si vous utilisez BP 5.0 ou BP 5.1 avec Microsoft Dynamics GP 2010 ou BP 6.0/6.1 avec Microsoft Dynamics GP 2013 et que vous avez 27 périodes (toutes les semaines) ou 53 périodes (hebdomadaires), utilisez la méthode 1 ou la méthode 2 ci-dessous.

  • Si vous utilisez BP 5.0 ou BP 5.1 avec Microsoft Dynamics GP 2010 ou BP 6.0/6.1 avec Microsoft Dynamics GP 2013 et que vous avez 26 périodes (toutes les semaines) ou 52 périodes (toutes les semaines) car vous avez cliqué sur l’option « Utiliser uniquement les périodes de paiement complets », utilisez la méthode 1 ou la méthode 3 ci-dessous. Votre échéancier de paiement 2021 (en utilisant uniquement les périodes complètes) semble se terminer le 21/12/2022, mais vous ne pouvez pas créer d’échéancier pour 2022 qui commence le 22/12/2022, même si cette date n’a PAS été utilisée dans l’échéancier de paiement précédent.

Méthode 1 : dés affecter l’ancien échéancier de paiement afin que le système ne le regarde pas.


Si vous avez terminé d’utiliser l’ancien échéancier de paiement et que tous ces fiches de temps sont approuvées jusqu’à la fin, vous pouvez simplement dés affecter cet échéancier de paiement à tous les employés et le système ne l’envisagera plus. Vous pourrez ensuite créer l’échéancier de paiement à partir de la date de votre souhaitez. Il s’agit de la méthode la plus rapide et la plus simple pour contourner ce problème, si vous êtes en mesure d’attendre que le planning précédent ne soit plus utilisé et que toutes les cartes de paiement utilisant cet échéancier de paiement ont été approuvées/complétées.

1. Connectez-vous à BP en tant qu’administrateur.

2. Cliquez sur l’onglet Administration.

3. Cliquez sur Configuration de la carte de temps.

4. Sélectionnez l’échéancier de paiement approprié, puis cliquez sur le bouton Attribuer.

5. Utilisez la liste bas Restreindre par pour sélectionner Service, puis cliquez sur Tout désélecrer. Ensuite, restreignez l’action Employé, puis sélectionnez Tout désélecrer. (Vérifiez également par emplacement et position, bien que celles-ci soient moins utilisées.) Enregistrer.

6. Vous pouvez maintenant cliquer sur Ajouter et créer un échéancier de paiement à partir de la date de votre souhaitez.



Remarque Ne pas « supprimer » l’échéancier de paiement précédent à partir du Portail d’entreprise. L’échéancier de paiement doit exister pour que les données historiques soient consultées. Toutefois, si l’échéancier de paiement passé est supprimé de la fenêtre Échéancier de paiement, vous pouvez simplement le créer à nouveau, mais ne l’affecter à aucun employé. Il doit simplement exister pour afficher l’historique des cartes de temps passées.

Méthode 2 : modifier les dates dans l’échéancier de paiement si vous avez 27 ou 53 périodes à l’aide de scripts SQL Microsoft

Remarque Avant de suivre les instructions de cet article, assurez-vous d’avoir une copie de sauvegarde complète de la base de données que vous pouvez restaurer en cas de problème.


Remarques supplémentaires :

  • Nous vous recommandons d’effectuer une sauvegarde. Notez les dates de début et de fin pour tous les échéanciers de paiement afin de pouvoir modifier SQL scripts en conséquence.

  • Nous vous recommandons d’approuver toutes les cartes de temps dans l’échéancier de paiement à modifier. Par conséquent, ne suivez ces étapes qu’à la fin de l’échéancier de paiement.


L’objectif des étapes ci-dessous est de renommer la dernière période (période 27 ou période 53) de sorte que le système déplace cette période au début de l’échéancier. Nous allons ensuite modifier l’horodament annuel pour cette période, de sorte que le jour supplémentaire soit ajouté au début de l’année précédente et supprimé de la fin de l’échéancier afin de libérer cette date. Il s’agit donc essentiellement de faire glisser le planning d’une journée avant (ou 22/12/2020- 21/12/2021). Nous devons le faire, car le système nécessite toujours un échéancier de 365 jours. 

Étape 1
Exécutez le script approprié pour modifier la valeur De période de la valeur par semaine ou hebdomadaire à 0 comme suit. Cette période déplace la dernière période au début de l’échéancier de paiement :

BIWEEKLY:
update HRM_PayPeriod set PayPeriodID ='0' where PayPeriodID ='27' and yearid='2021' and frequencyid ='2'
WEEKLY:
update HRM_PayPeriod set PayPeriodID ='0' where PayPeriodID ='53' and yearid='2021' and frequencyid ='1'



Remarque Mettez à jour l’YEARID dans le script ci-dessus pour qu’il soit le nom de l’ancien échéancier de paiement. Ces exemples de scripts ne couvrent que chaque semaine et toutes les semaines, mais peuvent également être modifiés de manière appropriée si votre planning est différent, par exemple mensuel ou semi-mensuel. Ouvrez un cas de support pour insérer ces valeurs dans le script.
 

Étape 2

Exécutez le script approprié ci-dessous pour modifier la valeur du nom de période de façon à ce qu’elle corresponde :

BIWEEKLY:
update HRM_PayPeriod set Name = 'Period 0' where Name = 'Period 27' and Yearid = '2021' and frequencyid = '2'

WEEKLY:
update HRM_PayPeriod set Name = 'Period 0' where Name = 'Period 53' and Yearid = '2021' and frequencyid = '1'





Étape 3
Vous devrez à présent modifier les dates de début et de fin de la période 0 de façon à ce qu’elles soient l’année précédente, ce qui ajoute le jour supplémentaire au début de l’échéancier de paiement. Exécutez les deux scripts pour modifier la date de début d’abord pour la période 0, puis la date de fin pour la période 0 :

BIWEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='2'

update HRM_PayPeriod set EndDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='2'


WEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='1'

update HRM_PayPeriod set EndDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='1'

Notez que la date de la dernière période était le 22/12/2022-12/2022 et que vous l’avez à présent modifiée en 22/12/2021-12/2022/2021, ce qui ajoute le jour supplémentaire au début de l’échéancier en modifiant uniquement l’horodat de l’année. La période 26 ou 52 se termine le 21/12/2022.



Étape 4
Exécutez le script suivant pour mettre à jour HRM_PaySchedule table de début afin qu’elle corresponde à la nouvelle date de début de la période 0 dans HRM_PayPeriod table :

BIWEEKLY:
update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='2'

WEEKLY:

update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='1'

Remarque Pour vérifier que la valeur CommenceDate du tableau HRM_PaySchedule correspond à la valeur BeginDate de la période 0 dans la table HRM_PayPeriod, exécutez le script suivant :

BIWEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 2 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 2

WEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 1 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 1
 


Étape 5
Vous pouvez désormais créer un échéancier de paiement pour 2022 avec la date de début du « 22/12/2022 ». Dans BP, cliquez sur l’onglet Administration, puis sur Configuration de la carte de temps. Cliquez sur le bouton Ajouter dans la section Échéanciers de paiement. Tapez la fréquence et la date de début le 22/12/2022, puis cliquez sur Calculer les périodes de paiement. Enregistrer.


Notez que le nouvel échéancier de paiement crée également une période 27 ou une période 53 supplémentaire pour le jour supplémentaire (étant donné que 365 n’est pas également diviseur par 7). Toutefois, il est déconseillé de modifier la période supplémentaire à ce stade. Sinon, l’échéancier de paiement se chevauchera avec l’échéancier de paiement précédent, vous devez donc attendre la fin de l’année pour le modifier.


Étape 6
Sélectionnez l’échéancier de paiement, puis cliquez sur le bouton Affecter pour affecter la nouvelle planification à des services, des lieux, des employés ou des postes spécifiques.



 

Méthode 3 : modifier les dates dans l’échéancier de paiement si vous avez 26 ou 52 périodes à l’aide de scripts SQL Microsoft



Remarque Avant de suivre les instructions de cet article, assurez-vous d’avoir une copie de sauvegarde complète de la base de données que vous pouvez restaurer en cas de problème.


Remarques supplémentaires :

  • Nous vous recommandons d’effectuer une sauvegarde. Notez les dates de début et de fin pour tous les échéanciers de paiement afin de pouvoir modifier SQL scripts en conséquence.

  • Nous vous recommandons d’approuver toutes les cartes de temps dans l’échéancier de paiement à modifier. Par conséquent, ne suivez ces étapes qu’à la fin de l’échéancier de paiement.



Dans cet exemple, l’échéancier de paiement 2021 existant va du 23/12/2021 au 21/12/2022 (et présente 26 ou 52 périodes de paiement). Vous voulez modifier l’échéancier de paiement existant ou créer un échéancier qui commence le 22/12/2022, mais un message d’erreur continue de s’obtenir, même si cette date n’est pas utilisée par l’échéancier de paiement existant. Le système ne vous permet pas de créer le nouvel échéancier de paiement, car l’échéancier n’est pas long de 365 jours.  


L’objectif des étapes ci-dessous est d’ajouter un jour supplémentaire à l’échéancier existant afin de l’ajouter à 365 jours, afin que vous soyez alors en mesure de créer le nouvel échéancier de paiement. 

Étape 1
Examinez les dates actuelles de la période 1 et de la dernière période (période 26 ou période 52) de l’échéancier de paiement existant :

BIWEEKLY: Select * from HRM_PayPeriod where yearid='2021' and frequencyid ='2'
WEEKLY: Select * from HRM_PayPeriod where yearid='2021' and frequencyid ='1'



Remarque Mettez à jour l’YEARID dans le script ci-dessus pour qu’il soit le nom de l’échéancier de paiement existant. Ces exemples de scripts ne couvrent que chaque semaine et toutes les semaines, mais peuvent également être modifiés de manière appropriée si votre planning est différent, par exemple mensuel ou semi-mensuel. Ouvrez un cas de support pour insérer ces valeurs dans le script.

Étape 2

Remontez à la date de début de la période 1 par un jour pour ajouter un jour supplémentaire au début de l’échéancier de paiement afin de l’ajouter à 365 jours.

BIWEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='1' and yearid='2021' and frequencyid ='2'


WEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='1' and yearid='2021' and frequencyid ='1'

Remarque Si l’ajout de la date de début chevauche la planification des salaires de l’année précédente, il se peut que vous devrez tout d’abord dés affecter cette ancienne planification à tous les employés, afin que le système s’en charge et ne rencontre pas d’autre problème de chevauchement.



Remarque : l’échéancier de paiement s’effectuera du 22/12/2021 au 21/12/2022, ce qui ajoute le jour supplémentaire au début de l’échéancier pour lui donner une durée de 365 jours. 


Étape 3
Exécutez le script suivant pour mettre à jour HRM_PaySchedule table de début afin qu’elle corresponde à la nouvelle date de début de la période 1 dans HRM_PayPeriod table :

BIWEEKLY:
update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='2'

WEEKLY:
update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='1'

Remarque Pour vérifier que la valeur CommenceDate du tableau HRM_PaySchedule correspond à la valeur BeginDate de la période 0 dans la table HRM_PayPeriod, exécutez le script suivant :

BIWEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 2 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 2

WEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 1 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 1


Étape 4
Vous pouvez désormais créer un échéancier de paiement pour 2022, avec la date de début du « 22/12/2022 ». Dans BP, cliquez sur l’onglet Administration, puis sur Configuration de la carte de temps. Cliquez sur le bouton Ajouter dans la section Échéanciers de paiement. Tapez la fréquence et la date de début le 22/12/2022, puis cliquez sur Calculer les périodes de paiement. Enregistrer.


Notez que le nouvel échéancier de paiement crée également une période 27 ou une période 53 supplémentaire pour le jour supplémentaire (puisque 365 n’est pas égale à diviseur de 7) ou si vous utilisez « Utiliser uniquement les périodes de salaire complètes », cela créera de nouveau 26 ou 52 périodes de paiement. Toutefois, il est déconseillé de modifier la période supplémentaire à ce stade. Sinon, l’échéancier de paiement se chevauchera avec l’échéancier de paiement précédent, vous devez donc attendre la fin de l’année pour le modifier.


Étape 5
Sélectionnez l’échéancier de paiement, puis cliquez sur le bouton Affecter pour affecter la nouvelle planification à des services, des lieux, des employés ou des postes spécifiques.

 

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