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Symptômes

Supposez que vous utilisez SQL Server 2016 ou 2017. Lorsque vous interrogez les données dans la zone de chiffrement à l’aide de Hadoop, tout fonctionne correctement. Néanmoins, après 10 heures environ, la requête échoue et génère le message d’erreur suivant dans Dms_polybase. log. Mêmesi vous pouvez résoudre le problème en démarrant la base de connaissances services, la requête risque d’échoueraprès 10 heures.

org. Apache. Hadoop. Security. Authentication. client. AuthenticationException : GSSException : aucun identifiant valide fourni (niveau du mécanisme : échec de recherche du TGT Kerberos).

Cause

Ce problème se produit car la Polybase ne renouveler automatiquement le ticket d’attribution de ticket Kerberos (TGT). Le ticket expire 10 heures après sa création.

Statut

Microsoft a confirmé l’existence de ce problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème a été résolu dans les mises à jour cumulatives de SQL Server suivantes :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs et les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.

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