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Symptômes

Lorsque vous avez terminé ou annulé un expéditeur, la valeur de la zone statut n’est pas mise à jour sur fermé dans gestion des commandes dans Microsoft Dynamics SL.

Remarque La boîte de statut s’affiche sous l’onglet autres informations de l’écran expéditeurs (40.110.00) .  Par ailleurs, l’écran visionneuse du journal des mises à jour de l’expéditeur (40.460.00) n’inclut pas d’entrée pour l’ID de l’expéditeur. 

Cause

Cause 1

Le paramètre différer la mise à jour de l’expéditeur est incorrect. Voir résolution 1.

Cause 2

Le paramètre Time Sleep pour le gestionnaire de processus est trop petit. Voir résolution 2

Cause 3 

L’étape mettre à jour l’expéditeur sous l’onglet étapes de l’écran types d’ordre (40.200.00) est configurée de manière incorrecte. Voir résolution 3.

Cause 4 

Le type de commande a été modifié sous l’onglet étapes de l’écran types de commande (40.200.00) avant la fermeture des expéditeurs existants. Voir résolution 4.

Cause 5 

Des personnalisations ont été ajoutées à l’écran expéditeurs (40.110.00) qui a interrompu le traitement des enregistrements de l’expéditeur. Voir résolution 5.

Cause 6 

Toute cause autre qu’une cause 1 à cause 5.  Dans ce cas, ce problème se produit indépendamment du type de commande. Voir résolution 6 ou 7.

Résolution

Résolution 1

Vérifiez que le paramètre différer la mise à jour de l’expéditeur n’est pas trop volumineux. Pour cela, procédez comme suit :

  1. Dans le menu module , cliquez sur gestion des commandes.

  2. Dans le volet gestion des commandes , cliquez sur Configuration de la gestion des commandes sous configuration.

  3. Dans l’onglet autre , vérifiez que la valeur du champ différer la mise à jour de l’expéditeur (minutes) n’est pas trop grande. Remarques Si la valeur délai de mise à jour de l’expéditeur (minutes) est définie sur 30, le message d’expédition ne peut pas être fermé avant 30 minutes après la fin de l’enregistrement du message d’expédition.

Résolution 2

Augmenter la durée de veille du processus du gestionnaire de processus. Pour cela, procédez comme suit :

  1. Dans le menu module , cliquez sur gestion des commandes.

  2. Dans le volet gestion des commandes , cliquez sur Configuration de la gestion des commandes sous configuration.

  3. Dans l’onglet autre , tapez 15 dans la zone durée de veille du gestionnaire de processus (secondes) si la valeur figurant dans la zone est inférieure à 15.

Résolution 3

Corrigez l’état de l’étape dans le type de commande. Pour cela, procédez comme suit :

  1. Dans la liste des modules , cliquez sur gestion des commandes.

  2. Dans le volet gestion des commandes , cliquez sur types de commandes sous maintenance.

  3. Dans la zone type d’ordre , entrez l’ID du type de commande que vous voulez modifier.

  4. Dans l’onglet étapes , cliquez sur obligatoire dans le champ statut de la mise à jour de l’expéditeur.

  5. Cliquez sur Enregistrer. Fermez ensuite l’écran types de commandes (40.200.00) .

Résolution 4

Annulation des expéditeurs et des commandes client associées Pour cela, procédez comme suit :

  1. Dans la liste des modules , cliquez sur gestion des commandes.

  2. Dans le volet gestion des commandes , cliquez sur confirmation de l' expédition en entrée.

  3. Dans la zone Réf expéditeur , entrez l’ID de l’expéditeur que vous voulez annuler.

  4. Activez les cases à cocher suivantes :

    • Annuler l’expéditeur 

    • Annuler la commande 

  5. Cliquez sur Terminer. Fermez ensuite le Écran de confirmation d’expédition (40.117.00) .

Résolution 5

Supprimez les personnalisations de l’écran expéditeurs (40.110.00) . Pour cela, procédez comme suit :

  1. Fermez tous les écrans, à l’exception de l’écran expéditeurs (40.110.00) .

  2. Dans le menu personnaliser , cliquez sur mode personnalisation.

  3. Dans le menu personnaliser , cliquez sur Supprimer les modifications pour l’écran.

  4. Cliquez sur Oui, puis sur OK.

  5. Fermez l’écran expéditeurs (40.110.00) . Ouvrez ensuite l’écran.

Résolution 6

Changez l’ordre des expéditeurs de manière à ce qu’ils soient reconnus par le gestionnaire de processus. Pour la modifier, utilisez la clé de Registre AutoRecoverDelay. Remarques Avant de suivre les instructions de cette procédure, vérifiez que vous disposez d’une copie de sauvegarde complète de la base de données que vous pouvez restaurer en cas de problème.

  1. Dans l’écran Gestionnaire de processus (40.400.00) , cliquez sur arrêter.

  2. À l’aide de l’analyseur de requête SQL Microsoft ou Microsoft SQL Server Management Studio, exécutez l’instruction appropriée sur la base de données d’application.

    • Microsoft SQL Server 7,0

      Sélectionnez "execADG_Release_For_Update" "+ RTrim (CpnyID) +" "," "," "+ RTrim (ShipperID) +" ' "de SOSHIPHEADER où NextFunctionID =" 4043000 "and NextFunctionClass =" 0200 "

    • Microsoft SQL Server 2000 ou Microsoft SQL Server 2005 ou Microsoft SQL Server 2008

      Définissez QUOTED_IDENTIFIEROFF sélectionnez "exec ADG_Release_For_Update'" + RTrim (CpnyID) + "'," ', ' "+ RTrim (ShipperID) +" ' "dans SOSHIPHEADER whereNextFunctionID =" 4043000 "and NextFunctionClass =" 0200 "

  3. Copiez les résultats de l’instruction dans une nouvelle fenêtre. Excluez les en-têtes de colonnes ou de lignes. Exécutez ensuite la nouvelle instruction pour redisposer les expéditeurs répertoriés.Remarques L’instruction suivante est un exemple du résultat que vous souhaitez copier.

    exec ADG_Release_For_Update' 0060 ', ' ' 0009868 '

  4. Dans l’écran Gestionnaire de processus (40.400.00) , cliquez sur Démarrer.

Résolution 7

Annulez l’expéditeur. Pour cela, procédez comme suit :

  1. Dans la liste des modules , cliquez sur gestion des commandes.

  2. Dans le volet gestion des commandes , cliquez sur expéditeurs en entrée.

  3. Sous l’onglet autres informations , activez la case à cocher annulé , puis cliquez sur Terminer.

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