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Symptômes

Agents de logiciel anti-programme malveillant de sécurité client s’exécutant sur Windows Vista, Windows Server 2008, Windows 7 ou Windows Server 2008 R2, peuvent être supprimés lors de l’installation de Windows à l’aide de mises à jour et arrêter la fonction appliquer de Forefront Client Security mise à jour contre les logiciels malveillants de mars 2011 décrite dans l’article suivant :

Mise à jour du client 2508823 forefront Client Security anti-malware : mars 2011
Le fichier journal d’installation de la mise à jour, généralement situé à l’emplacement %ProgramFiles%\Microsoft Forefront\Client, Security\Client\Logs\mp_ambits.log, contient des informations semblables à le ci-dessous.

MSI (s) (90:84) [14:44:28:764] : produit : Service anti-programme malveillant de Microsoft Forefront Client Security--erreur 1923. Le service « Microsoft Forefront Client Security contre les logiciels malveillants Service » (FCSAM) n’a pas pu être installé. Vérifiez que vous disposez des privilèges suffisants pour installer des services système. MSI (s) (90:84) [14:44:28:951] : les opérations en cours d’exécution : ActionStart(Name=ExecSecureObjects,,)

MSI (s) (90:84) [14:44:29:013] : les opérations en cours d’exécution : CustomActionSchedule(Action=ExecServiceConfig,ActionType=3073,Source=BinaryData,Target=ExecServiceConfig,CustomActionData=FCSAM restart restart none 1 15) MSI (s) (90:50) [14:44:29:013] : l’appel d’une action personnalisée à distance. DLL : C:\Windows\Installer\MSI255E.tmp, point d’entrée : ExecServiceConfig ExecServiceConfig : erreur 0x80070430 : Impossible de modifier la configuration du service. Erreur : Le service spécifié a été marqué pour suppression
Dans ce cas, les composants de sécurité état Assessment(SSA) et Microsoft Operation Manager restent installés.

Cause

Microsoft a identifié un problème dans l’agent Forefront Client Security lors de l’exécution sur Windows Vista, Windows Server 2008, Windows 7 ou Windows Server 2008 R2, ce qui empêche leur mise à niveau vers la mise à jour de mars 2011 correctement lorsque les fenêtres de fonctionnalités « Installer les mises à jour et éteindre » est utilisé pour installer la mise à jour.

Remarque: le symptôme "erreur : le service spécifié a été marqué pour suppression » peut également se produire en raison des différentes causes.

Solution de contournement

Comment éviter le problème.

  • Administrateurs WSUS peuvent refuser ou pas approuver l’installation KB2508823

  • Éviter d’installer KB2508823 avec « mises à jour de l’installation et à l’arrêt ». Ces opérations peuvent être effectuées par

    • une recommandation par les administrateurs pour les utilisateurs

    • stratégie de groupe de l’application des mises à jour automatiques via : ordinateur Configuration/Administrative modèles/Windows composants/Windows mise à jour - ne pas afficher « Installer les mises à jour, puis arrêter » option dans la boîte de dialogue Arrêt de Windows.

    • l’installation de la mise à jour KB2508823 par le biais de délais WSUS ; Cela déclenche l’installation immédiatement. Pour plus d’informations sur les délais WSUS, consultez l’article de TechNet Comportement Client et les délais de mise à jour


Correction du problème

Pour la correction automatisée par le biais de Microsoft Update et WSUS, reportez-vous à la section Plus d’informations ci-dessous.



Pour une correction manuelle, il existe un certain nombre d’options

  • Téléchargez et installez KB2508823 manuellement. Il existe des étapes à suivre pour effectuer cette opération dans la section informations de correctif de l’article : http://support.microsoft.com/kb/2508823

  • Approuver dans WSUS « Mise à jour Client pour Microsoft Forefront Client Security (1.0.1728.0) » et refuser le update(KB2508823) de mars et de la mise à jour Client de Microsoft Forefront Client Security (1.0.1736.0) (2508824). Après que l’installation et la détection de mises à jour automatiques suivante le cycle, cela sera redéployer l’agent préalable contre les logiciels malveillants

  • Permet d’approuver la mise à jour de la copie de fichiers « Mise à jour Client pour Microsoft Forefront Client Security (1.0.1736.0) ».
    N OTE: dans certains cas cela échoue avec 0x666 ERROR_PRODUCT_VERSION
    Si vous constatez des échecs ERROR_PRODUCT_VERSION l’installation de la copie de fichiers, vous pouvez désinstaller SSA et qui doit permettre à ce qu’il fonctionne.


État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Un correctif est désormais disponible auprès de Microsoft pour mettre à jour des ordinateurs a rencontré des problèmes d’installation de Forefront Client Security mars 2011. Le correctif est un nouveau package de mise à jour de logiciel conçu pour corriger ces ordinateurs par le déploiement de nouveau la mise à jour de mars 2011 décrite dans l’article suivant :

Mise à jour du client 2508823 forefront Client Security anti-malware : mars 2011
Ce correctif est disponible à partir de Microsoft Update et de Windows Server Update Services (WSUS). La mise à jour utilise les conditions suivantes pour déterminer si elle doit s’appliquer à la mise à jour de mars 2011. Si toutes les conditions sont remplies, la mise à jour vont être installé :

  1. Installation de l’agent d’évaluation d’état Forefront Client Security (SSA)

  2. L’agent logiciel anti-programme malveillant de Forefront Client Security n’est pas installé.

  3. Clés de Registre de l’agent spécifiques contre les logiciels malveillants sont présents.

  4. Le système d’exploitation est Vista, Windows Server 2008, Windows 7 ou Windows Server 2008 R2.

Ce correctif est conçu pour corriger des cas très spécifique d’un échec de mise à niveau. Il existe de nombreuses raisons techniques qui une mise à niveau peut échouer à installer qui ne sont pas traités. Un Registre endommagé, problèmes liés à Windows installer référentiel ou exemples binaires détenus par des processus externes au-delà de notre contrôle. Si vous avez besoin de plus obtenir de l’aide contactez votre support technique professionnel ou visitez le site http://support.microsoft.com/ph/12632.




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