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Symptômes

Prenons l’exemple du scénario suivant :

  • Dans l’environnement de développement Microsoft Visual Studio 2010, vous travaillez sur une application.

  • Vous installez une extension Visual Studio tiers, tels que les outils de productivité Visual Studio DevExpress, dans l’environnement de développement.

  • Vous fermez l’environnement de développement Visual Studio 2010.

Dans ce scénario, l’application peut se bloquer lorsque vous essayez de fermer l’application en fermant l’environnement de développement. Puis, vous recevez une erreur Dr. Watson qui contient les informations suivantes :

Nom de l’événement : CLR20r3Application nom : devenv.exeApplication Version : < 10.0.30319.1 - 10.0.65535.9999 > Code d’Exception : rxoejih3rskjez4xxwpxudkcppwjodng

Remarque Pour vérifier les informations d’erreur Dr. Watson, procédez comme suit :

  1. Cliquez sur Démarrer, puis tapez les rapports de problème dans la zone de recherche .

  2. Si l’ordinateur exécute Windows Vista, cliquez sur Afficher l’historique du problème. Si l’ordinateur exécute Windows 7, cliquez sur Afficher tous les rapports de problème.

  3. Dans la fenêtre rapports de problèmes et de Solutions , double-cliquez sur le problème spécifique que vous rencontrez.

  4. Permet d’afficher les informations dans la section de la signature du problème .

Remarque Les méthodes qui sont décrites dans cet article s’appliquent à Windows Vista et Windows 7. Rechercher en ligne des méthodes qui s’appliquent à d’autres systèmes d’exploitation.

Cause

Ce problème peut se produire lorsque vous installez une extension de tiers mal essaie d’accéder à l’interface utilisateur de l’environnement de développement après que les services de Visual Studio ont été publiés. Les versions antérieures des outils de productivité Visual Studio DevExpress peuvent provoquer ce problème.

Résolution

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif. RemarqueSi des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web Microsoft suivant :

http://support.microsoft.com/contactus/?ws=support

Informations sur le téléchargement

Pour télécharger ce correctif depuis MSDN Code Gallery, visitez le site Web Microsoft suivant :

http://code.msdn.microsoft.com/KB2275326Remarque MSDN Code Gallery affiche les langues pour lesquelles ce correctif est disponible. Si vous ne voyez pas votre langue, c'est certainement dû au fait que la page de ressource Code Gallery n'existe pas dans cette langue. En outre, vous pouvez télécharger ce correctif cumulatif à partir du site Web Microsoft Connect suivant :

Le.NET Framework et Visual Studio : KB2275326Après avoir installé le correctif, vous devez installer la dernière version de l’extension de Visual Studio de tiers. Pour installer la dernière version de l’extension DevExpress, visitez le site Web suivant :

Outils de productivité de Visual StudioMicrosoft fournit des informations de contact de sociétés tierces afin de vous aider à obtenir un support technique&period; Ces informations de contact peuvent être modifiées sans préavis&period; Microsoft ne garantit pas l'exactitude des informations concernant les sociétés tierces&period;

Conditions préalables

Il n’y a aucune condition préalable à l’installation de ce package de correctifs.

Nécessité de redémarrer

Vous n’êtes pas obligé de redémarrer l’ordinateur après avoir appliqué ce correctif logiciel.

Informations sur le remplacement de correctif logiciel

Ce correctif logiciel ne remplace pas un package correctif publié précédemment.

Informations sur les fichiers

La version anglaise (États-Unis) de ce package de correctifs utilise un package Microsoft Windows Installer pour installer le package de correctifs. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC) dans le tableau suivant. Lorsque vous affichez les informations de fichier, la date est convertie en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et d’heure dans le panneau de configuration.

Nom du fichier

Version du fichier

Taille du fichier

Date

Heure

Plateforme

Microsoft.visualstudio.shell.10.0.dll

10.0.30319.341

995,712

30-Jul-2010

06:17

x86

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.Les produits tiers mentionnés dans le présent article sont édités par des sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

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