Symptômes
Le processus d’installation du client Microsoft Dynamics SL se bloque lors de l’installation des composants d’accès aux données.
Cause
Cause 1 :La version de MDAC sur la station de travail est antérieure à la version 2,5 et le programme d’installation de Microsoft Dynamics SL tente de mettre à jour les composants MDAC.
Voir résolution 1.
Cause 2 :
Lorsque le programme d’installation de Microsoft Dynamics SL exécute Sqlredis. exe pour installer les composants de connectivité du client SQL Server, le processus se bloque sur l’un des composants installés.
Voir résolution 2.
Résolution
Résolution 1 :
Pour résoudre ce problème, exécutez les étapes suivantes : 1. Tout d’abord, vérifiez la version de MDAC installée. Pour cela, procédez comme suit : a. Cliquez sur Démarrer | Exécutez b. Tapez "regedit" c. Dans le registre, accédez à HKEY_LOCAL_MACHINE \Software\Microsoft\DataAccess d. Recherchez la clé « version ». e. Vérifiez si cette clé est inférieure à 2.50.4403.12. touche. Si tel est le cas, vous pouvez essayer d’installer manuellement les composants MDAC à partir du site Web suivant : http://www.microsoft.com/downloads/en/details.aspx ?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&displaylang =enRemarque :
Si la clé n’est pas disponible, cela peut signifier un problème avec le système d’exploitation et peut-être réinstaller. Si la clé est présente et est supérieure à 2.50.4403.12, il n’est probablement pas la cause du problème.
Résolution 2 :
Si Sqlredis. exe ou un des fichiers exécutables qu’il utilise est en suspens, vous pouvez les mettre fin dans le gestionnaire des tâches : 1. Appuyez sur CTRL + ALT + SUPPR et lancez le gestionnaire des tâches.
2. sous l’onglet processus, recherchez l’un des processus suivants : setupre. exe Sqlredis. exe Dasetup. exe3. Si l’un des fichiers exécutables ci-dessus figure dans l’onglet « processus », mettez fin au processus. En cas de succès, le programme d’installation doit passer à l’étape suivante de l’installation du client.