Se connecter avec Microsoft
S'identifier ou créer un compte.
Bonjour,
Sélectionnez un autre compte.
Vous avez plusieurs comptes
Choisissez le compte avec lequel vous voulez vous connecter.

Symptômes

Lorsque vous utilisez le portail d’entreprise pour Microsoft Dynamics GP, pour les solutions Microsoft Business - Bonne fin ou pour Microsoft Dynamics SL, l’visionneuse de rapports est vide lorsque vous cliquez sur le nom d’un rapport qui s’affiche dans la page centrale.

Cause

Cause 1

Le dossier de rapport qui stocke les rapports publiés à partir de Microsoft Dynamics GP ou de Microsoft Dynamics SL n’est pas partagé.

Les utilisateurs et groupes suivants doivent avoir un accès total au partage de rapports :

  • Groupe Tout le monde

  • L’utilisateur du service réseau

  • Utilisateur d’identité pour l’objet Microsoft.BusinessPortal.Reports.FileService COM+.

  • Utilisateur d’identité pour le pool d’applications utilisé par le Portail d’entreprise

Consultez la résolution 1 de la section « Résolution ».

Cause 2

L’utilisateur d’identité pour l’objet Microsoft.BusinessPortal.Reports.FileService COM+ n’a pas un accès total Microsoft.BusinessPortal.Reports.FileService.dll fichier. Voir la résolution 2 dans la section « Résolution ».

Cause 3

L’emplacement du partage de rapport n’est pas correctement répertorié dans la table ReportCatalog. Voir la résolution 3 dans la section « Résolution ».

Cause 4

La taille du fichier Microsoft.BusinessPortal.Reports.FileService.tlb est de 0 kilo-octets (Ko). Voir la résolution 4 dans la section « Résolution ».

Solution

Résolution 1

Pour partager le dossier de rapports et ajouter l’accès au partage de rapports pour des utilisateurs et groupes spécifiques, suivez ces étapes :

  1. Dans Windows Explorer, cliquez avec le bouton droit sur le dossier contenant les rapports publiés à partir de Microsoft Dynamics GP ou de Microsoft Dynamics SL. Cliquez ensuite sur Propriétés.

  2. Cliquez sur l’onglet Partage, sur Partager cedossier, puis sur Autorisations.

  3. Cliquez sur Ajouter,tapez Tout le monde, cliquez sur Vérifier lesnoms, puis sur OK.

  4. Cliquez sur l’entrée Tout le monde.

  5. Dans la zone Autorisations pour tout le monde, cochez la case Contrôle total, puis cliquez sur OK.

Remarque Répétez les étapes 3 à 5 pour les autres utilisateurs et groupes mentionnés dans la section « Cause ». L’utilisateur du service réseau est un utilisateur local. Pour déterminer le nom des autres utilisateurs et groupes que vous devez ajouter, voir la section « Plus d’informations ».

Résolution 2

Pour ajouter l’accès correct à l’objet COM+, suivez ces étapes :

  1. Dans Windows’Explorateur, cliquez avec le bouton droit sur Microsoft.BusinessPortal.Reports.FileService.dll fichier, puis cliquez sur Propriétés.

    Remarque Par défaut, ce fichier se trouve dans le chemin d’accès suivant :

    C:\Inetpub\wwwroot\bin

  2. Cliquez sur l’onglet Sécurité, surAjouter, sur Emplacements,sélectionnez le nom du serveur Portail d’entreprise, puis cliquez sur OK.

  3. Entrez le nom de l’utilisateur, cliquez sur Vérifier lesnoms, puis sur OK.

    Remarque Pour déterminer le nom de l’utilisateur d’identité pour l’objet Microsoft.BusinessPortal.Reports.FileService COM+, voir la section « Informations supplémentaires ».

  4. Cliquez sur le nom d’utilisateur.

  5. Dans la zone Autorisations, cochez la case Contrôle total, puis cliquez sur OK.

Résolution 3

Pour corriger l’emplacement du partage d’état dans la table ReportCatalog, exécutez le script suivant sur la base de données de l’entreprise.

SELECT  * FROM ReportCatalog

La Report_URL colonne doit pointer sur le partage du rapport. Par exemple, si le rapport Report.txt se trouve dans le dossier C:\Reports sur le serveur de rapports BusinessPortalServer, la valeur dans la colonne Report_URL doit être la valeur suivante :

BusinessPortalServer/Reports/Report.txt

Résolution 4

  1. Dans Windows Explorer, recherchez le fichier Microsoft.BusinessPortal.Reports.FileService.tlb.

    Remarque Par défaut, ce fichier se trouve dans le dossier suivant :

    c:\inetpub\wwwroot\bin

  2. Si la taille du fichier est de 0 Ko, renommez-le en utilisant le nom de fichier suivant :

    Microsoft.BusinessPortal.Reports.FileService.tlbold

  3. Cliquez sur le lien suivant pour télécharger un nouveau fichier Microsoft.BusinessPortal.Reports.FileService.tlb :

    https://mbs.microsoft.com/fileexchange/?fileID=aab68342-5ba5-4084-adf0-44271a6f3141

  4. Collez le fichier dans le même dossier que celui où était situé le service Microsoft.BusinessPortal.Reports.FileService.tlb d’origine.

Informations supplémentaires

Pour déterminer l’utilisateur d’identité pour l’objet Microsoft.BusinessPortal.Reports.FileService COM+, suivez ces étapes :

  1. Cliquez sur Démarrer,sur Outils d’administration,puis sur Services de composants.

  2. Développez Component Services,Ordinateurs,My Computer,puis COM+ Applications.

  3. Cliquez avec le bouton droit sur Microsoft.BusinessPortal.Reports.FileService,cliquez sur Propriétés, puis sur l’onglet Identité.

Pour déterminer l’utilisateur d’identité du pool d’applications utilisé par le Portail d’entreprise, suivez ces étapes :

  1. Cliquez surDémarrer, sur Outilsd’administration, puis sur Internet Information Services (IIS).

  2. Développez le nom de l’ordinateur, puis développez les pools d’applications.

  3. Recherchez le pool d’applications que vous utilisez pour le portail d’entreprise.

  4. Cliquez avec le bouton droit sur le pool d’applications, cliquez surPropriétés, puis sur Identité.

Références

Pour plus d’informations sur les étapes de dépannage à suivre lorsque les rapports FRx ne s’affichent pas dans le Portail d’entreprise, cliquez sur le numéro d’article suivant pour le consulter dans la Base de connaissances Microsoft :

861754 Vous ne pouvez pas afficher les rapports FRx dans le portail d’entreprise à Reporting et Great

(861754)

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.

Les communautés vous permettent de poser des questions et d'y répondre, de donner vos commentaires et de bénéficier de l'avis d'experts aux connaissances approfondies.

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?
En cliquant sur Envoyer, vos commentaires seront utilisés pour améliorer les produits et services de Microsoft. Votre administrateur informatique sera en mesure de collecter ces données. Déclaration de confidentialité.

Nous vous remercions de vos commentaires.

×