Symptômes
Après avoir installé une mise à jour ASP.NET sur un ordinateur qui exécute une application de bureau Microsoft Visual Studio LightSwitch 2011 à deux niveaux, ou si Internet Information Services (IIS) héberge le serveur Microsoft Visual Studio LightSwitch 2011, le serveur peut se bloquer. Lorsque ce problème se produit, les utilisateurs de l’application peuvent rencontrer des échecs de chargement de données dans le programme client.
Cause
Ce problème se produit en raison des données d’assembly manquantes requises pour que la fonctionnalité d’unification d’assembly du .NET Framework fonctionne correctement. Par conséquent, les domaines d’application chargent deux versions du même assembly. Remarque Ce problème peut se produire uniquement entre l’installation d’une mise à jour ASP.NET et le prochain redémarrage de l’application ou du serveur.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes appropriées à l’application. Méthode 1 Pour une application de bureau à deux niveaux, fermez et redémarrez l’application. Méthode 2 Pour un site web ou une application de bureau à trois niveaux, utilisez le compte administrateur pour redémarrer le serveur qui exécute IIS. Méthode 3 Si l’application est démarrée à l’aide de Microsoft Visual Studio, redémarrez Visual Studio.
Références
Pour plus d’informations sur Visual Studio LightSwitch 2011, accédez au site web Microsoft suivant :
Informations générales sur Visual Studio LightSwitch 2011 Pour plus d’informations sur la fonctionnalité d’unification d’assembly, accédez au site web MSDN suivant :
Informations générales sur la fonctionnalité d’unification de l’assembly