Symptômes
Lorsque vous utilisez une application personnalisée pour effectuer le suivi de l’état de disponibilité des utilisateurs d’Office Communicator, Service Response Group (RGS), s’exécute sur Office Communications Server 2008 R2 cesse de répondre. Cela se produit lorsque l’application interagit avec le serveur. Pour effacer l’erreur, vous devez redémarrer le serveur.
Cause
Ce problème se produit que si l’application personnalisée envoie les informations d’état de disponibilité pour le Service Response Group dans XML et le fichier XML n’utilise pas la balise de schéma < disponibilité > présence. Lorsque cela se produit, le Service Response Group cesse de répondre.
Résolution
Comment faire pour obtenir le correctif
Ce problème est résolu dans le package de mise à jour de package correctif Office Communications Server 2007 R2, Service Response Group. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
Description de 975612 de la mise à jour cumulative pour Office Communications Server 2007 R2, Service Response Group : octobre 2009
Solution de contournement
Pour contourner ce problème, assurez-vous que le code XML qui passe par votre application personnalisée pour le Service Response Group utilise la balise de schéma < disponibilité > présence. Pour plus d’informations sur le schéma de présence d’Office Communications Server 2008, reportez-vous au site Web de MSDN suivant :
Text/xml+msrtc.pidf de l’annexe B: complet 7 Format de Document de présence
http://msdn.microsoft.com/en-us/library/cc246201(PROT.10).aspx
État
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».