Se connecter avec Microsoft
S'identifier ou créer un compte.
Bonjour,
Sélectionnez un autre compte.
Vous avez plusieurs comptes
Choisissez le compte avec lequel vous voulez vous connecter.

Symptômes

Considérez le scénario suivant :

  • Le service TN3270 Server recherche un certificat SSL auprès d’un fournisseur d’Infrastructure de clé publique (PKI).

  • Le certificat SSL a un nom commun demandé.

Dans ce scénario, le service TN3270 Server ne trouve pas le certificat SSL. Par conséquent, vous ne pouvez pas implémenter le certificat SSL.

Lorsque vous examinez un suivi du service serveur TN3270 capturée à l’aide de l’utilitaire de traçage de SNA, vous pouvez voir les lignes de suivi ci-dessous :

Look for server auth cert with subject containing CN 'Sernername.Company.Com' Find a certificate with required subject CN Find Certificate in Store failed, error 0x80092004 Search 0 exhausted Find a certificate with required subject CN Find Certificate in Store failed, error 0x80092004 Search 1 exhausted Failed to get certificate from the store

Cause

Ce problème se produit car le nom commun du certificat émis utilise le codage de CERT_RDN_UTF8_STRING. Si le codage de CERT_RDN_PRINTABLE_STRING est utilisé à la place, tout fonctionne bien.

Résolution

Informations sur le correctif



Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.
Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, accédez au site Web de Microsoft suivant :

http://support.Microsoft.com/default.aspx?scid=fh; [LN] ; CNTACTMS

Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Vous devez avoir la mise à jour cumulative package 10 pour Microsoft Host Integration Server 2010 installé pour appliquer ce correctif. Pour plus d’informations sur la façon d’obtenir le package de mise à jour cumulative, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2917398 mise à jour cumulative 10 pour Host Integration Server 2010

Plus d'informations

Après avoir appliqué le correctif, le service serveur TN3270 essaie les deux encodages lors de la recherche pour le certificat.

Informations de mise à jour cumulative

Le correctif de ce problème est inclus dans le package de mise à jour cumulative 3 pour Host Integration Server 2013. Pour plus d’informations sur la façon d’obtenir le cumulative mise à jour de package, voir Cumulative mise à jour 3 pour Host Integration Server 2013.

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.

Les communautés vous permettent de poser des questions et d'y répondre, de donner vos commentaires et de bénéficier de l'avis d'experts aux connaissances approfondies.

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?
En cliquant sur Envoyer, vos commentaires seront utilisés pour améliorer les produits et services de Microsoft. Votre administrateur informatique sera en mesure de collecter ces données. Déclaration de confidentialité.

Nous vous remercions de vos commentaires.

×