Symptômes

Lorsque vous modifiez une colonne indexée dans une liste à partir d’une réponse unique pour autoriser plusieurs réponses, une erreur se produit :

"Le type de cette colonne ne peut pas être modifié, car il est actuellement indexé"

Ce comportement est attendu.  Toutefois, une fois que vous avez effectué une telle opération, revenir à la liste montre que les métadonnées de cette colonne ne sont plus visibles.

Cause

S’il est choix de plusieurs sélections pour une colonne/un champ, la possibilité d’indexer cette colonne ne sera pas disponible (par conception).

Résolution

Solution de contournement

  1. Après avoir reproduire le problème, les métadonnées de la colonne « assignée à » semblent être manquantes.

  2. Accédez à «paramètres | Paramètres de la liste et cliquez sur colonnes indexées.

  3. La valeur « assignée à » est toujours définie pour être indexée, alors décochez-la, puis cliquez sur « OK ».

  4. Revenez à la liste (Notez que la colonne « assignée à » ne contient toujours pas de métadonnées).

  5. Revenez à la section’paramètres | Paramètres de liste' | Choisissez la colonne « assignée à » et basculez « Oui » pour « autoriser les sélections multiples ».

  6. Revenez à la liste et notez que les métadonnées sont redirigées vers la colonne « assignée à ».

  7. Les utilisateurs peuvent désormais choisir : Conservez cette valeur sous la forme d’un champ à plusieurs valeurs ou une valeur unique, puis ajoutez-les à nouveau en tant que colonne indexée.

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.