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Symptômes

Une fois la synchronisation d’un point de mise à jour logicielle (SUP) avec Windows Software Update Services (WSUS) terminée, les mises à jour logicielles qui ont été déployées avec succès sont affichées comme non valides dans la console Administrateur dans Microsoft System Center Configuration Manager 2007. Plus précisément, l’icône de mise à jour logicielle non valide (flèche rouge) apparaît à côté des mises à jour lorsque vous affichez les mises à jour dans le nœud Gestion du déploiement de la console Administrateur. En outre, ces mises à jour ne sont plus répertoriées sous le nœud Packages de déploiement.

Cause

Ce problème peut se produire en raison des modifications apportées au service Microsoft Update en octobre 2012. Ces améliorations contiennent des mises à jour de métadonnées qui affectent tous les serveurs WSUS. Ces modifications ont provoqué la marque de certaines mises à jour comme ayant un changement de contenu, même si les fichiers binaires de mise à jour n’ont pas été modifiés. Pour certains administrateurs, les modifications de métadonnées peuvent avoir été appliquées automatiquement lors de la synchronisation de WSUS avec les serveurs Microsoft Update en octobre. D’autres administrateurs ont reçu les modifications en appliquant la mise à jour 2734608 à leurs serveurs WSUS.

Résolution

Pour résoudre ce problème, installez ce package de correctifs logiciels sur les serveurs de site principal et secondaire System Center Configuration Manager 2007 SP2.

Une fois ce correctif logiciel appliqué, une mise à jour qui contient uniquement une modification des métadonnées et non du contenu du fichier n’entraîne pas l’affichage de la mise à jour comme non valide.

Ce correctif logiciel ne met pas à jour l’état des mises à jour précédemment marquées comme non valides. Toutefois, vous pouvez télécharger à nouveau ces mises à jour à l’aide de l’Assistant Téléchargement de logiciels à partir du nœud Mises à jour logicielles de la console Administrateur.

Pour identifier les mises à jour qui affichent l’icône de mise à jour logicielle non valide, vous pouvez créer un dossier de recherche. Pour ce faire, utilisez les propriétés d’objet suivantes lorsque vous créez le dossier de recherche :

  • Deployed=Yes

  • Downloaded=No

En outre, la case à cocher Rechercher dans tous les dossiers sous cette fonctionnalité doit être activée.

Après avoir exécuté la requête, vérifiez que seules les mises à jour logicielles non valides sont retournées. Vous pouvez sélectionner les mises à jour, puis les télécharger à nouveau directement à partir de la fenêtre de résultats. Vous pouvez placer les mises à jour dans les packages de déploiement d’origine, si elles sont connues. Vous pouvez également placer les mises à jour dans un nouveau package de déploiement. Les déploiements actifs sont automatiquement mis à jour pour reconnaître l’état de téléchargement révisé des mises à jour.

Pour plus d’informations sur la configuration des dossiers de recherche pour les mises à jour logicielles, accédez au site web Microsoft TechNet suivant :

Comment configurer des dossiers de recherche pour les mises à jour logicielles

Informations sur le correctif logiciel

Un correctif logiciel pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est destiné à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif logiciel uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif peut recevoir des tests supplémentaires. Par conséquent, si vous n’êtes pas gravement affecté par ce problème, nous vous recommandons d’attendre la prochaine mise à jour logicielle qui contient ce correctif logiciel.

Si le correctif logiciel est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » est disponible en haut de cet article de la Base de connaissances. Si cette section n’apparaît pas, contactez le service clientèle microsoft et le support technique pour obtenir le correctif logiciel.

Remarque Si des problèmes supplémentaires se produisent ou si un dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts de support habituels s’appliqueront aux questions et problèmes de support supplémentaires qui ne sont pas éligibles à ce correctif logiciel spécifique. Pour obtenir la liste complète des numéros de téléphone du service clientèle et du support technique Microsoft ou pour créer une demande de service distincte, visitez le site web Microsoft suivant :

http://support.microsoft.com/contactus/?ws=supportNotez que le formulaire « Téléchargement du correctif logiciel disponible » affiche les langues pour lesquelles le correctif logiciel est disponible. Si vous ne voyez pas votre langue, c’est qu’un correctif logiciel n’est pas disponible pour cette langue.

Conditions préalables

Pour installer ce correctif logiciel, vous devez exécuter System Center Configuration Manager Service Pack 2 2007 (SP2).

Informations sur le Registre

Pour installer ce correctif logiciel, vous n’avez pas à apporter de modifications au Registre.

Nécessité de redémarrer

Vous n’avez pas besoin de redémarrer l’ordinateur après avoir installé ce correctif logiciel.

Informations sur le remplacement de correctif logiciel

Ce correctif logiciel ne remplace pas un correctif logiciel précédemment publié.

Informations sur les fichiers

La version globale de ce correctif logiciel installe les fichiers qui ont les attributs répertoriés dans les tableaux suivants. Les date et heure de création de ces fichiers sont exprimées en temps universel coordonné (UTC). Les date et heure de ces fichiers s'affichent sur votre ordinateur local conformément à l'heure locale et en tenant compte de l'heure d'été. En outre, ces date et heure peuvent changer lorsque vous effectuez certaines opérations sur les fichiers.

Nom du fichier

Version du fichier

Taille du fichier

Date

Time

Platform

Updmgr.dll

4.0.6487.2220

156,232

01-Feb-2010

1,855

x86

Informations supplémentaires

Pour plus d’informations sur ce problème, accédez à la section « Problème 2 - Améliorations supplémentaires » du billet de blog suivant sur le site web Microsoft TechNet :

Conseil de support : Configuration Manager les packages de déploiement du client peuvent ne pas être déployés en raison de mises à jour devant être retentéesPour plus d’informations sur la mise à jour 2734608, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft :

2734608 Une mise à jour pour Windows Server Update Services Service Pack 2 3.0 est disponible (KB2734608)Pour plus d’informations sur la synchronisation des mises à jour logicielles, consultez le site web Microsoft TechNet suivant :

Informations générales sur la synchronisation des mises à jour logiciellesPour plus d’informations sur les métadonnées des mises à jour logicielles, accédez au site web Microsoft TechNet suivant :

Informations générales sur les métadonnées des mises à jour logiciellesPour plus d’informations sur le glossaire d’icône pour les mises à jour logicielles, accédez au site web Microsoft TechNet suivant :

Informations générales sur le glossaire d’icône pour les mises à jour logicielles

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