Se connecter avec Microsoft
S'identifier ou créer un compte.
Bonjour,
Sélectionnez un autre compte.
Vous avez plusieurs comptes
Choisissez le compte avec lequel vous voulez vous connecter.

Symptômes

Lorsque vous utilisez des rapports dans le portail d’entreprise, vous recevez l’un des messages d’erreur suivants, selon que vous utilisez Microsoft Dynamics GP 9.0 ou Microsoft Dynamics SL 6.5.

Microsoft Dynamics GP

Lorsque vous cliquez sur Gérer le catalogue derapports, vous recevez le message d’erreur suivant :

Erreur serveur dans l’application « / ».
-------------------------------------------------------------------------------- valeur était trop grande ou



trop petite pour un int16.


Description : Une exception non exécutée s’est produite lors de l’exécution de la demande web actuelle. Consultez le suivi de pile pour plus d’informations sur l’erreur et son origine dans le code.



Détails de l’exception : System.OverflowException : la valeur était trop grande ou trop petite pour un int16.



Erreur source : une exception non exécutée a été générée lors de



l’exécution de la demande web actuelle. Les informations relatives à l’origine et à l’emplacement de l’exception peuvent être identifiées à l’aide du suivi de pile d’exceptions ci-dessous.



Stack Trace :




[OverflowException: Value was too large or too small for an Int16.] System.Int16.Parse(String s, Style NumberStyles, fournisseur IFormatProvider) +129 Microsoft.BusinessPortal.ReportsPages.VS.ReportProesAssignments.FillVges() +186 Microsoft.BusinessPortal.ReportsPages.VS.ReportRolesAssignments.RoleRptID_TextChanged(Object sender, EventArgs e) +32 System.Web.UI.WebControls.TextBox.OnTextChanged(EventArgs e) +108 System.Web.UI.WebControls.TextBox.System. Web.UI.IPostBackDataHandler.RaisePostDataChangedEvent() +26 System.Web.UI.Page.RaiseChangedEvents() +115 System.Web.UI.Page.ProcessRequestMain() +1099






--------------------------------------------------------------------------------

Version : Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Version :1.1.4322.2032

Microsoft Dynamics SL

Lorsque vous envoyez un état, vous recevez le message d’erreur suivant :

SubmitReportRequest a échoué. La valeur était trop grande ou trop petite pour un int16.

Cause

Ce problème se produit pour l’une des raisons suivantes, selon que vous utilisez Microsoft Dynamics GP 9.0 ou Microsoft Dynamics SL 6.5.

Microsoft Dynamics GP

Le DEX_ROW_ID de la table ReportCatalog a une valeur supérieure à la valeur maximale autorisée de 32 767.

Microsoft Dynamics SL

La table ReportRequest utilisée par Report Scheduler inclut le champ ID AppSrvRequest. Le champ ID AppSrvRequest a une valeur supérieure à la valeur maximale autorisée de 32 767.

Résolution

Pour résoudre ce problème, suivez la procédure appropriée, selon que vous utilisez Microsoft Dynamics GP 9.0 ou Microsoft Dynamics SL 6.5.

Microsoft Dynamics GP

Réinitialiser DEX_ROW_ID champ de recherche. Pour cela, procédez comme suit :

  1. Suivez l’étape appropriée, selon que vous utilisez Microsoft SQL Server ou SQL Server Desktop Engine (également appelé MSDE 2000) :

    • Si vous utilisez Microsoft SQL Server 2000, démarrez l’SQL analyseur de requête. Pour ce faire, cliquez sur Démarrer,pointez sur Programmes,pointez sur Microsoft SQL Server,puis cliquez sur Analyseur de requête.

    • Si vous utilisez Microsoft SQL Server 2005, démarrez le SQL Server Management Studio. Pour ce faire, cliquez surDémarrer, pointez sur Programmes,pointez sur Microsoft SQL Server 2005,puis cliquez SQL ServerManagement Studio.

    • Si vous utilisez MSDE 2000, démarrez la Console d’administrateur de support. Pour ce faire, cliquez sur Démarrer,pointez sur Programmes,pointez sur Console d’administrateur Microsoft,puis cliquez sur Console d’administrateur du support.

  2. Exécutez l’instruction suivante sur la base de données de l’entreprise.

    DBCC CHECKIDENT ('ReportCatalog', RESEED, 1)
  3. Effacer la table ReportCatalog à l’aide SQL Analyseur de requête ou SQL Server Management Studio. Le service d’intégration FRx resupupque la table avec la valeur correcte dans le DEX_ROW_ID complet. Pour ce faire, exécutez l’instruction suivante sur la base de données de l’entreprise.

    DELETE AppSrvRequest

Microsoft Dynamics SL

Réinitialisez le champ ID AppSrvRequest. Pour cela, procédez comme suit :

  1. Suivez l’étape appropriée, selon que vous utilisez Microsoft SQL Server ou SQL Server Desktop Engine (également appelé MSDE 2000) :

    • Si vous utilisez Microsoft SQL Server 2000, démarrez l’SQL analyseur de requête. Pour ce faire, cliquez sur Démarrer,pointez sur Programmes,pointez sur Microsoft SQL Server,puis cliquez sur Analyseur de requête.

    • Si vous utilisez Microsoft SQL Server 2005, démarrez le SQL Server Management Studio. Pour ce faire, cliquez surDémarrer, pointez sur Programmes,pointez sur Microsoft SQL Server 2005,puis cliquez sur SQL Server Management Studio.

    • Si vous utilisez MSDE 2000, démarrez la Console d’administrateur de support. Pour ce faire, cliquez sur Démarrer,pointez sur Programmes,pointez sur Console d’administrateur Microsoft,puis cliquez sur Console d’administrateur du support.

  2. Exécutez l’instruction suivante sur la base de données système.

    Delete from AppsrvRequest
    Delete from Scheduler
    DBCC CHECKIDENT('AppSrvRequest',RESEED, 0)

    Remarque : cette procédure permet de supprimer toutes les demandes programmées. Vous devez à nouveaux créer les demandes prévues.

  3. Effacer la table ReportCatalog à l’aide SQL Analyseur de requête ou SQL Server Management Studio. Le service d’intégration FRx reresupque la table avec la valeur correcte dans le champ ID AppSrvRequest. Pour ce faire, exécutez l’instruction suivante sur la base de données de l’entreprise.

    DELETE ReportCatalog

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.

Les communautés vous permettent de poser des questions et d'y répondre, de donner vos commentaires et de bénéficier de l'avis d'experts aux connaissances approfondies.

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?
En cliquant sur Envoyer, vos commentaires seront utilisés pour améliorer les produits et services de Microsoft. Votre administrateur informatique sera en mesure de collecter ces données. Déclaration de confidentialité.

Nous vous remercions de vos commentaires.

×