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Symptômes

Vous recevez un message d’erreur lorsque vous effectuez l’une des actions suivantes dans Microsoft Business Solutions - Portail d’entreprise :

  • Vous essayez de restaurer une base de données.

  • Vous essayez de mettre une base de données hors connexion.

  • Vous essayez de configurer une base de données pour un accès utilisateur unique ou un accès en lecture seule.

Vous recevez le message d’erreur suivant :

Erreur 5070 : L’état de la base de données ne peut pas être modifié tandis que les autres utilisateurs utilisent l’instruction «database_name' ALTER DATABASE ». sp_dboption commande a échoué.

Ce problème se produit même si tous les utilisateurs ont quitté Microsoft Dynamics GP ou Microsoft Dynamics SL.

Cause

Le portail d’entreprise utilise le regroupement de connexions pour tirer parti des avantages des performances. Ce comportement est dû à la façon dont les fonctions de regroupement de connexions et à la conception du portail d’entreprise. Les utilisateurs du Portail d’entreprise conservent leur connexion aux bases de données une fois qu’ils ont fermé leurs sessions de navigateur.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Afficher les connexions actives aux bases de données, l’ID Microsoft SQL Server de processus serveur 2000 (SPID), l’état et le nom de connexion. Pour cela, procédez comme suit :

    1. Démarrez SQL Analyseur de requête.

    2. Exécutez le script suivant.

      sp_who
  2. Réinitialisez les connexions actives. Pour cela, appliquez l’une des méthodes suivantes :



    Méthode 1
    Déconnecter manuellement les S SPID des utilisateurs du portail d’entreprise. Cette méthode est recommandée, car elle affecte le moins de processus et d’utilisateurs.

    Remarque Avant de suivre ces étapes, faites en sorte que tous les utilisateurs quittent le Portail d’entreprise.

    1. Démarrez SQL Analyseur de requête.

    2. Exécutez le script suivant sur la base de données.

      KILL <SPID number>

      Remarque Remplacez le <SPID> espace réservé par le numéro 1.

    Méthode 2 Redémarrer SQL Services à l’aide SQL Server Management Studio
    ou Microsoft SQL Server Manager :

    1. Faire en sorte que tous les utilisateurs quittent le Portail d’entreprise et tous les autres programmes qui se connectent à Microsoft SQL Server.

    2. Redémarrez SQL Services à l’aide Microsoft SQL Server Management Studio ou du Gestionnaire d SQL Server Entreprise émarrage.

      Lorsque vous redémarrez SQL Services, tous les SPID et toutes les connexions SPID sont réinitialisés. La méthode 2 affecte plus d’utilisateurs et plus de processus que la méthode 1.

Informations supplémentaires

Pour plus d’informations sur la commande KILL, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft :

171224 Fonctionnement de la commande KILL SQL Transact-SQL

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