Symptômes

Vous recevez le message d’erreur suivant dans Microsoft CRM 1,2, dans Microsoft Business Solutions-CRM 1,0 ou dans Microsoft Dynamics CRM 3,0 :

Autorisation utilisateur non valide. L’authentification de l’utilisateur transmise à la plateforme n’est pas valide.

Vous recevez ce message d’erreur lorsque vous effectuez l’une des opérations suivantes :

  • Vous ouvrez une session sur Microsoft CRM.

  • Vous modifiez la Division d’un utilisateur Microsoft CRM.

  • Vous êtes en ligne dans Microsoft CRM Sales pour Outlook (le client Outlook).

  • Vous cliquez sur un dossier Microsoft CRM dans le client Microsoft CRM 3,0 pour Outlook.

  • Vous essayez de fusionner un enregistrement Microsoft CRM 3,0.

Cause

Cause 1

Ce problème peut se produire lorsqu’une ou plusieurs des conditions suivantes sont remplies :

  • Aucun rôle n’est affecté à l’utilisateur du programme.

  • La Division de l’enregistrement utilisateur a récemment été modifiée dans le programme. Lorsque l’unité commerciale est modifiée dans Microsoft CRM 1,2, dans Microsoft Business Solutions-CRM 1,0 et dans Microsoft Dynamics CRM 3,0, tous les rôles qui ont été précédemment attribués à un utilisateur sont supprimés. Dans Microsoft Dynamics CRM 3,0, lorsque l’unité commerciale est modifiée, la modification n’est pas disponible dans le client Microsoft Dynamics CRM pour Outlook tant que vous n’avez pas redémarré l’ordinateur.

Cause 2

Ce problème peut se produire si le compte d’ordinateur Microsoft CRM Server n’est pas membre du groupe PrivUserGroup Active Directory et du groupe SQLAccessGroup.

Cause 3

Ce problème peut se produire si l’utilisateur propriétaire de l’enregistrement subordonné qui sera fusionné a été supprimé d’Active Directory.

Solution

Résolution 1

Microsoft CRM 1,2, Microsoft Business Solutions-CRM 1,0 et Microsoft Dynamics CRM 3,0

Pour résoudre ce problème, attribuez le rôle approprié à l’utilisateur. Pour cela, procédez comme suit :

  1. Connectez-vous à Microsoft CRM en tant qu’utilisateur disposant du rôle administrateur système.

  2. Cliquez sur Accueil, surparamètres, puis sur paramètres de l' unité commerciale, et enfin sur utilisateurs.

  3. Double-cliquez sur l’enregistrement utilisateur dans lequel vous observez le problème.

  4. Cliquez sur rôles, sur gérer les rôles, puis sélectionnez le rôle approprié pour cet utilisateur.

  5. Cliquez sur OK, puis sur enregistrer et fermer.

Suivez ces étapes si vous recevez le message d’erreur mentionné dans la section « Symptômes » lorsque vous vous connectez dans le client Outlook et que vous avez modifié la division qui a été affectée à l’utilisateur :

  1. Vérifiez que l’utilisateur est hors connexion dans le client Outlook.

  2. Dans Microsoft CRM, remplacez la Division pour l’utilisateur par la Division d’origine. Pour cela, procédez comme suit :

    1. Ouvrez Microsoft CRM, cliquez sur Accueil, sur paramètres, puis sur paramètres de l' unité commerciale, puis sur utilisateurs.

    2. Double-cliquez sur l’enregistrement utilisateur.

    3. Cliquez sur actions, puis sur changer de division.

    4. Cliquez sur la Division d’origine qui a été affectée à l’utilisateur, cliquez sur OK, puis sur enregistrer et fermer.

  3. Dans le client Outlook, cliquez sur se connecter.

  4. Lorsque vous êtes en ligne, modifiez la Division pour l’utilisateur dans Microsoft CRM.

  5. Fermez, puis rouvrez Microsoft Office Outlook.

Résolution 2

Pour résoudre ce problème, ajoutez le compte d’ordinateur au groupe PrivUserGroup et au groupe SQLAccessGroup dans Active Directory :

  1. Sur le contrôleur de domaine, démarrez utilisateurs et ordinateurs Active Directory.

  2. Cliquez avec le bouton droit sur PrivUserGroup, puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet membres , cliquez sur Ajouter, puis ajoutez le compte d’ordinateur serveur CRM.

  4. Dans utilisateurs et ordinateurs Active Directory, cliquez avec le bouton droit sur SQLAccessGroup, puis cliquez sur Propriétés.

  5. Cliquez sur l’onglet membres , cliquez sur Ajouter, puis ajoutez le compte d’ordinateur serveur CRM.

  6. Sur le serveur Microsoft CRM, cliquez sur Démarrer, sur exécuter, puis tapez cmd.

  7. À l’invite de commandes, tapez IISReset.

Résolution 3

Pour résoudre ce problème, affectez l’enregistrement subordonné à un utilisateur Microsoft CRM valide :

  1. Démarrez Microsoft CRM.

  2. Double-cliquez sur l’enregistrement subordonné que vous souhaitez fusionner.

  3. Cliquez sur actions, sur affecter, puis sur affecter à un autre utilisateur.

  4. Dans la liste des utilisateurs, sélectionnez le nouveau propriétaire, puis cliquez sur OK à deux reprises.

Références

Cet article a été le document TechKnowledge 31789.

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