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Symptômes

Après avoir effectué une mise à niveau vers Windows Installer version 2.0, le service Windows Installer peut ne pas démarrer et le message d'erreur suivant peut s'afficher :

Impossible d'accéder au service Windows Installer. Ce problème peut se produire lorsque vous exécutez Windows en mode sans échec ou si Windows Installer n'est pas correctement installé. Contactez votre support technique pour assistance.

Remarque Ce problème ne se produit pas avec les produits suivants :

  • Microsoft Windows XP

  • Microsoft Windows Millennium Edition

  • Microsoft Windows 98

Cause

Ce problème peut se produire si l'une des conditions suivantes est remplie :

  • Dans les autorisations DCOM, le niveau d'authentification par défaut a pour valeur Aucun et le niveau d'emprunt d'identité par défaut a pour valeur Anonyme.

  • Le compte système ne dispose pas des autorisations Totales sur une clé de Registre ou un dossier auquel Windows Installer essaie d'accéder. Ceci est spécifique à NTFS.

Résolution

Selon le problème rencontré, appliquez l'une ou l'ensemble des méthodes suivantes :

  • Méthode 1 : Désinscription et réinscription de Windows Installer.

  • Méthode 2 : Vérification des autorisations DCOM.

  • Méthode 3 : Attribution de l'autorisation Contrôle total au compte SYSTEM.

  • Méthode 4 : Vérification des autorisations de Registre.

  • Méthode 5 : Correction de la clé de sécurité cassée pour le service MsiServer.

Avant de commencer : Vérifiez que le Service Pack est installé

Si vous utilisez Windows 2000, assurez-vous que le SP 2 est installé.
Si vous utilisez Windows NT 4.0, assurez-vous que le SP 6 est installé.

Si vous n'installez pas les Service Packs appropriés, les étapes de la section "Plus d'informations" de cet article peuvent ne pas fonctionner comme prévu.

Plus d'informations

Méthode 1 : Désinscription et réinscription de Windows Installer

  1. Cliquez sur Démarrer, sur Exécuter, tapez MSIEXEC /UNREGISTER, puis cliquez sur OK. Même si vous effectuez cette procédure correctement, il peut vous sembler que rien ne se produit.

  2. Cliquez sur Démarrer, sur Exécuter, tapez MSIEXEC /REGSERVER, puis cliquez sur OK. Même si vous effectuez cette procédure correctement, il peut vous sembler que rien ne se produit, ou un sablier peut s'afficher brièvement. Une fois cette commande exécutée, l'opération est terminée.

  3. Réessayez votre application Windows Installer.

Méthode 2 : Vérification des autorisations DCOM

Cette méthode implique de modifier le niveau d'emprunt d'identité par défaut DCOM sur Identify, de supprimer le fichier Msisip.dll et de réinstaller Windows 2000 SP3.

Pour cela, procédez comme suit :

  1. Cliquez sur Démarrer, sur Exécuter, tapez dcomcnfg, puis cliquez sur OK.

  2. Sous l'onglet Propriétés par défaut :

    1. Dans la liste Niveau d'authentification par défaut, cliquez sur Se connecter.

    2. Dans la liste Niveau d'emprunt d'identité par défaut, cliquez sur Identifier, puis sur OK.

  3. Cliquez sur Démarrer, sur Exécuter, tapez explorer /select, %windir%\system32\msisip.dll, puis cliquez sur OK.

  4. Renommez le fichier Msisip.dll en Msisip.old.

  5. Réinstallez le Service Pack 3 Windows 2000.

Méthode 3 : Attribution de l'autorisation Contrôle total au compte SYSTEM

  1. Démarrez l'Explorateur Windows, cliquez avec le bouton droit sur le disque dur racine de votre ordinateur, puis cliquez sur Propriétés.

  2. Cliquez sur l'onglet Sécurité, puis sur Ajouter.

  3. Dans la boîte de dialogue Sélectionner Utilisateurs ou Groupes, cliquez sur le compte SYSTEM, cliquez sur Ajouter, puis sur OK.

  4. Sous Autorisations, activez la case à cocher Contrôle total, puis cliquez sur OK.

  5. Cliquez sur le dossier TEMP, puis vérifiez que le compte SYSTEM dispose du contrôle total.

Méthode 4 : Vérification des autorisations de Registre

  1. Cliquez sur Démarrer, sur Exécuter, puis tapez Regedt32.

  2. Pour chaque ruche du Registre, procédez comme suit :

    1. Sélectionnez la ruche.

    2. Pour Windows XP, dans le menu Edition, cliquez sur Autorisations.

      Pour Windows 2000 et Windows NT 4.0, dans le menu Sécurité, cliquez sur Autorisations.

  3. Vérifiez que le compte SYSTEM a été ajouté et qu'il dispose du contrôle total. Si tel n'est pas le cas, ajoutez le compte SYSTEM avec le contrôle total.

Méthode 5 : Correction de la clé de sécurité cassée pour le service MsiServer

  1. Démarrez l'ordinateur en utilisant Windows 2000.

  2. Cliquez sur Démarrer, sur Exécuter, tapez regedit.exe, puis renommez la clé suivante Old_Security :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer\Security

  3. Redémarrez l'ordinateur (vous devez le faire).

  4. Réexécutez Instmsiw.exe pour Installer 2.0 ; cela corrige la clé de sécurité cassée pour le service MSI.

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