S’applique à
Microsoft Dynamics AX 4.0 Microsoft Dynamics AX 3.0 Microsoft Dynamics NAV 5.0

Symptômes

Lorsque vous démarrez Microsoft FRx Report Server, le message d’erreur suivant s’affiche :

Erreur 3709 - Impossible d’utiliser la connexion pour effectuer cette opération

Cause

Ce problème se produit pour l’une des raisons suivantes.

Cause 1

Les stations de travail n’ont pas la même version de Microsoft FRx Designer ou de Microsoft FRx Report Server. Consultez Résolution 1 dans la section « Résolution ».

Cause 2

Les dossiers Microsoft FRx nécessaires ont des autorisations utilisateur incorrectes. Consultez Résolution 2 dans la section « Résolution ».

Cause 3

Le bloc de construction est endommagé, le jeu de spécifications est endommagé ou les fichiers .f32 sont endommagés. Consultez Résolution 3 dans la section « Résolution ».

Cause 4

Le fichier FRxQue32.mdb est endommagé. Consultez Résolution 4 dans la section « Résolution ».

Solution

Résolution 1

Pour résoudre ce problème, case activée la version de Microsoft FRx sur chaque ordinateur disposant du code Microsoft FRx. Pour la modifier, utilisez la clé de Registre AutoRecoverDelay.

Microsoft FRx Designer

  1. Cliquez sur Démarrer, sur Rechercher, puis tapez FRx32.exe.

  2. Cliquez avec le bouton droit sur FRx32.exe, puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Version , puis notez la version du fichier.

Serveur de rapports Microsoft FRx

  1. Cliquez sur Démarrer, sur Rechercher, puis tapez RptSvr32.exe.

  2. Cliquez avec le bouton droit sur RptSvr32.exe, puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Version , puis notez la version du fichier.

Ces versions de fichiers doivent être identiques sur chaque station de travail du réseau. Si les versions de fichier ne sont pas identiques, vous devez appliquer le Service Pack approprié à l’application qui n’a pas la même version de fichier.Vous pouvez également effectuer une mise à jour vers le dernier Service Pack. Pour plus d’informations, visitez l’un des sites Web Microsoft suivants, selon que vous êtes un partenaire ou un client.Partenaires

https://mbs.microsoft.com/partnersource/products/GreatPlains/downloads/servicepackClients

https://mbs.microsoft.com/customersource/support/downloads/servicepacks

Résolution 2

Définir les autorisations appropriées

Définissez les autorisations appropriées sur tous les dossiers auxquels Microsoft FRx doit accéder. Pour la modifier, utilisez la clé de Registre AutoRecoverDelay.

  1. Connectez-vous à l’ordinateur en tant qu’administrateur local ou administrateur de domaine.

  2. Cliquez sur Démarrer, sur Rechercher, puis sur Tous les fichiers et dossiers.

  3. Recherchez les dossiers suivants :

    • Dossier de code FRx. Par défaut, le chemin est C :\Program Files\FRx Software

    • Dossier IO_Data .

    • Dossier SysData .

    • Dossier Temp .

    • Dossier MSInfo .

    • Dossier System32 .

  4. Pour chaque dossier répertorié à l’étape 3, procédez comme suit :

    1. Cliquez avec le bouton droit sur le dossier, puis cliquez sur Propriétés.

    2. Dans la boîte de dialogue Propriétés , cliquez sur l’onglet Sécurité .

    3. Assurez-vous que l’utilisateur Administrateur et tous les utilisateurs Microsoft FRx disposent des autorisations suivantes :

      • Pour le dossier de code FRx : Contrôle total

      • Pour le dossier IO_Data : Contrôle total

      • Pour le dossier SysData : Contrôle total

      • Pour le dossier Temp : Contrôle total

      • Pour le dossier MSInfo : Contrôle total

      • Pour le dossier System32 : Un minimum de « Lecture & Exécuter »

    4. Si des utilisateurs sont configurés dans des groupes de sécurité différents, assurez-vous que ces utilisateurs disposent des mêmes autorisations que les groupes à l’étape 4c.

Résolution 3

Pour résoudre ce problème, corrigez le bloc de construction, corrigez le jeu de spécifications ou corrigez les fichiers .f32. Pour ce faire, procédez comme suit :

  1. Si l’erreur est limitée à un catalogue, une ligne, une colonne ou une arborescence, recréez ce bloc de construction particulier.

  2. Si l’erreur se produit pour plusieurs blocs de construction, créez un jeu de spécifications qui contient un nouveau fichier .f32. Pour ce faire, procédez comme suit :

    1. Démarrez Microsoft FRx, cliquez sur Société, puis sur Ensembles de spécifications.

    2. Sélectionnez l’ensemble de spécifications que l’entreprise utilise.

    3. Cliquez sur Exporter, puis sélectionnez tous les éléments de chaque onglet.

    4. Cliquez à nouveau sur Exporter . Un fichier .tdb est créé.

    5. Pour créer un ensemble de spécifications, cliquez sur Nouveau, puis tapez un nouveau nom de fichier pour le fichier .f32 dans la zone Emplacement.

    6. Enregistrez le nouvel ensemble de spécifications.

    7. Cliquez sur Importer, puis sélectionnez le fichier .tdb créé à l’étape 2d plus haut dans cette section.

    8. Enregistrez l’ensemble de spécifications.

    9. Cliquez sur Société, sur Informations, puis sélectionnez le nouvel ensemble de spécifications dans la liste Ensemble de spécifications . Enregistrez l’enregistrement de l’entreprise.

    10. Définissez l’entreprise comme société par défaut.

Résolution 4

Pour résoudre ce problème, remplacez le fichier FRxQue32.mdb. Pour cela, procédez comme suit :

  1. Arrêtez le moniteur de file d’attente Microsoft FRx. Pour ce faire, cliquez sur le bouton Arrêter/Arrêter .

  2. Renommez le fichier FRxQue32.mdb dans le répertoire de file d’attente Microsoft FRx. Par exemple, renommez le fichier FRxQue32.old.

  3. Effectuez une copie du fichier FRxQue32.tpl, puis renommez la copie en FRxQue32.mdb. Le fichier FRxQue32.tpl se trouve dans le répertoire SysData.

  4. Double-cliquez sur le fichier RptSvr32.exe pour redémarrer le moniteur de file d’attente Microsoft FRx. Pour rechercher le fichier RptSvr32.exe, procédez comme suit :

    1. Cliquez avec le bouton droit sur Démarrer, puis cliquez sur Explorer tous les utilisateurs.

    2. Recherchez le dossier de code microsoft FRx Report Server. Par défaut, le chemin d’accès est le suivant :

      C :\Program Files\FRx Software\FRx 6.7 Report ServerLe fichier RptSvr32.exe se trouve dans ce dossier.

    RemarqueVous pouvez rencontrer le problème suivant :

    • Files qui ont une extension de nom de fichier .ldb ou une extension de nom de fichier .lck restent dans le dossier Microsoft FRx SysData même si aucun utilisateur n’est connecté à Microsoft FRx.

    Si vous rencontrez ce problème, le verrouillage opportuniste peut endommager la base de données Microsoft Jet. Ce problème peut se produire si le serveur qui héberge le dossier Microsoft FRx SysData exécute l’un des programmes suivants :

    • Microsoft Windows Server 2003 ou Windows Server 2003 Terminal Server

    • Microsoft Windows 2000 Server ou Windows 2000 Server Terminal Services

    • Windows Server 2003 Terminal Server avec Citrix

    Pour empêcher le verrouillage opportuniste d’endommager la base de données Microsoft Jet, installez la dernière Windows Server Service Pack. Toutefois, si ce problème persiste après l’installation de la dernière Windows Server Service Pack, désactivez le verrouillage opportuniste. Pour plus d’informations sur la désactivation du verrouillage opportuniste, cliquez sur les numéros d’article suivants pour afficher les articles de la Base de connaissances Microsoft :

    296264 Configuration du verrouillage opportuniste dans Windows

    129202 PC Ext : Explication du verrouillage opportuniste sur Windows NTLes produits tiers décrits dans cet article sont fabriqués par des entreprises indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

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