Symptômes
Lorsque vous utilisez le Portail d’entreprise avec Microsoft Dynamics GP ou Microsoft Dynamics SL, vous recevez le message d’erreur suivant dans un ou plusieurs composants Web Parts :
Une des propriétés du site Web Part présente un format incorrect. Windows SharePoint Services désorganisez pas le site Web Part. Vérifiez le format des propriétés et essayez à nouveau.
Cause
Ce problème peut être dû à la définir incorrectement des autorisations. En règle générale, ce problème se produit parce que le groupe d’utilisateurs STS_WPG/WSS_WPG n’a pas les autorisations suffisantes.
Résolution
Vérifiez que les groupes d’utilisateurs suivants ont les autorisations minimales requises pour le dossier Windows, pour le dossier Windows\Temp et pour le dossier Windows\system32\logfiles. Le tableau suivant répertorie les autorisations minimales requises :
Groupe d’utilisateurs |
Autorisations |
Administrateurs |
Contrôle total |
SYSTEM |
Contrôle total |
STS_WPG (SharePoint 2.0) |
Lire |
WSS_WPG (SharePoint 3.0) |
Lire |
Écrire |
|
Service réseau |
Lecture |
Écrire |
Remarque Vous devez seulement définir des autorisations pour le groupe d’utilisateurs du service réseau sur un contrôleur de domaine.
Pour afficher ou modifier les autorisations d’un dossier, suivez ces étapes :
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Démarrez l’Explorateur Windows.
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Cliquez avec le bouton droit sur le dossier pour lequel vous souhaitez afficher les autorisations, puis cliquez sur Propriétés.
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Cliquez sur l’onglet Partage, sur Partager cedossier, puis sur Autorisations.
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Si le groupe ou le nom d’utilisateur dont vous voulez afficher ou mettre à jour les autorisations existe, passer à l’étape 5. Si le groupe ou le nom d’utilisateur n’existe pas, suivez ces étapes :
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Cliquez sur Ajouter.
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Tapez STS_WPG ou WSS_WPG, selon votre version de SharePoint, ou tapez le groupe ou l’utilisateur dont vous voulez afficher ou mettre à jour les autorisations.
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Cliquez sur Vérifier les noms,puis sur OK.
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Sélectionnez le groupe ou le nom d’utilisateur dont vous voulez afficher ou mettre à jour les autorisations.
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Dans la zone Autorisations, cochez les cases des autorisations minimales requises.
Après avoir réinitialisé les autorisations, fermez le navigateur web, puis redémarrez le Portail d’entreprise.