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Symptômes

Lorsque vous visitez n’importe quelle page de projet, comme la saisie de l’heure, l’entrée de notes, le composant WebPart Communicator, le projet Analyst et le projet Executive Analyst dans Business Portal, vous recevez un message d’erreur rouge qui ressemble à l’un des éléments suivants :

Message d’erreur 1 :

Erreur : pièce jointe : une nouvelle tentative de connexion a été dépassée. HRESULT = 0x80004005 : erreur non spécifiée-client : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0x80004005 : erreur non spécifiée-client : échec de l’envoi du message SOAP ou aucune réponse identifiable ne provient de HRESULT = 0x80004005 : erreur non spécifiée-client : erreur cliente non spécifiée. HRESULT = 0x80004005 : erreur non spécifiée FaultCode = client FaultString = pièce jointe : une nouvelle tentative de connexion a été dépassée.

Voir les résolutions 6, 7, 8 et 9

Message d’erreur 2 :

Connecteur : délai de connexion expiré. HRESULT = 0x800A1527-client : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0x800A1527-client : échec de l’envoi du message SOAP ou de la réception d’une réponse de la valeur HRESULT = 0x800A1527-client : erreur client non spécifiée.

Voir les résolutions 6, 7, 8 et 9

Message d’erreur 3 :

Lien : certificat incorrect. HRESULT = 0x800A1529-client : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0x800A1529-client : échec de l’envoi du message SOAP ou de la réception d’une réponse de la valeur HRESULT = 0x800A1529-client : erreur client non spécifiée. HRESULT=0x800A1529

Voir les résolutions 6 et 9

Message d’erreur 4 :

Connecteur : erreur HTTP non spécifiée. HRESULT = 0x800A1518-client : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0x800A1518-client : échec de l’envoi du message SOAP ou de la réception d’une réponse de la valeur HRESULT = 0x800A1518-client : erreur client non spécifiée. HRESULT=0x800A1518

Voir les résolutions 6, 7, 8 et 9

Message d’erreur 5 :

Échec de connexion : aucun schéma d’autorisation correspondant n’est activé sur le connecteur. HRESULT = 0x80004005 : erreur non spécifiée-client : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0x80004005 : erreur non spécifiée-client : échec de l’envoi du message SOAP ou aucune réponse identifiable ne provient de HRESULT = 0x80004005 : erreur non spécifiée-client : erreur cliente non spécifiée. HRESULT = 0x80004005 : erreur non spécifiée

Voir les résolutions 7 et 9

Message d’erreur 6 :

Client : le chargement de la requête dans SoapReader a échoué. HRESULT = 0x80070057 : le paramètre est incorrect. -Client : erreur cliente non spécifiée. HRESULT = 0x80070057 : le paramètre est incorrect. FaultCode = client.

Voir les résolutions 6, 7, 8 et 9

Message d’erreur 7 :

L’application ne peut pas ouvrir la base de données système. DBNETLIB [ConnectionOpen (connexion ()).] SQL Server n’existe pas ou n’est pas autorisé à accéder.Votre administrateur système doit exécuter pcConfiguration sur le serveur du portail d’entreprise pour résoudre ce problème.

Voir les résolutions 5 et 9

Message d’erreur 8 :

Une erreur est survenue. Erreur : il y a eu une erreur lors de l’ouverture de la base de données système. (pcconnect)

Voir les résolutions 1, 2, 3, 4 et 9

Message d’erreur 9 :

L’application ne peut pas lire les informations de connexion Solomon. Votre administrateur système doit exécuter pcConfiguration sur le serveur du portail d’entreprise pour résoudre ce problème.

Voir les résolutions 1, 2, 3, 4 et 9

Message d’erreur 10 :

Vous ne pouvez pas vous connecter à la base de données système exécuter PCConfiguration. Nom d’utilisateur et mot de passe non valides.

Voir les résolutions 4 et 9

Message d’erreur 11 :

Erreur : client SOAP : une erreur s’est produite lors du traitement de la requête SOAP. Path non valide pour PCService. asmx spécifié dans ProjectService. wsdlYour l’administrateur système doit exécuter pcConfiguration-Update Web service sur le serveur du portail d’entreprise pour résoudre ce problème.

Voir les résolutions 6 et 9

Cause

Pour que les pages du projet puissent fonctionner, Internet Information Services (IIS) doit pouvoir préparer et envoyer une demande SOAP (Simple Object Access Protocol) au fichier PCService. asmx.  Plusieurs éléments doivent être configurés pour que cette opération fonctionne.  Si une ou plusieurs des conditions suivantes ne sont pas correctement configurées, les erreurs indiquées dans la section « symptômes » peuvent être à l’origine :

  1. Les informations de connexion de la base de données Microsoft Dynamics SL sont manquantes ou sont stockées incorrectement dans le registre.

  2. Microsoft. Solomon. PMA. Security. ImpersonateDLL. dll est manquant, n’est pas enregistré ou les utilisateurs ne disposent pas des autorisations nécessaires sur le fichier.

  3. L’identité du pool d’applications n’est pas disposant des autorisations d’accès à la clé de Registre HKEY_LOCAL_MACHINE \SOFTWARE\Microsoft\Business Portal\PMA\Solomon

  4. Le fichier CAPICOM. dll est manquant, n’est pas enregistré dans une version incorrecte ou les utilisateurs ne disposent pas des autorisations nécessaires sur le fichier

  5. Le serveur exécutant IIS et SQL Server doit pouvoir communiquer à l’aide du protocole TCP/IP

  6. Le chemin d’accès au fichier PCService. asx dans le ProjectService. WSDL est incorrect

    1. Le chemin d’accès doit être pointé sur le nom du serveur IIS.

    2. Le chemin d’accès doit inclure le numéro de port

    3. Le chemin d’accès doit être une URL non-SSL.

    4. Si vous utilisez des en-têtes d’hôte IIS, le chemin d’accès doit résoudre vers le site Web approprié

  7. Le site IIS n’utilise pas l’authentification Windows (NTLM)

  8. La variable SessionState dans le fichier Web. config est définie de manière incorrecte

En règle générale, le message d’erreur ne fournit pas beaucoup d’informations sur les éléments précédents qui ne sont pas valides.  C’est pourquoi nous vous conseillons d’essayer toutes les solutions possibles.

Résolution

Résolution 1- Exécutez l’utilitaire PCConfiguration

  1. Naviguez jusqu’au fichier PCConfiguration. exe sur le serveur du portail d’entreprise, puis double-cliquez dessus pour l’exécuter.  Il se trouve généralement dans le dossier c:\Inetpub\wwwroot\bin ou dans le dossier C:\Inetpub\wwwroot\wss\VirtualDirectories\80\bin.

  2. Remplissez les zones suivantes :

    1. Nom SQL Server-entrez le nom du serveur SQL qui héberge les bases de données Microsoft Dynamics SL.

    2. Système BDD-entrez le nom de la base de données système Microsoft Dynamics SL.

    3. Utilisateur SQL : entrez le nom d’un utilisateur SQL qui a accès à la base de données système.  « SA » ou « BusinessPortalUser » sont des options courantes.

    4. Mot de passe : entrez le mot de passe de l’utilisateur entré dans la zone utilisateur SQL.

  3. Cliquez sur tester la connexion.  Si un message d’erreur s’affiche, passez en revue les valeurs de l’étape 2. Remarque : Il est possible que ce bouton ne puisse pas effectuer cette action en raison de l’erreur 55474.

  4. Cliquez sur mettre à jour le registre.  Le message suivant doit apparaître : « les données ont été correctement écrites dans le registre »

  5. Fermez l’utilitaire et essayez de nouveau les pages du portail d’entreprise.

Résolution 2 -Vérifiez le fichier Microsoft. Solomon. PMA. Security. ImpersonateDLL. dll

  1. Sur le serveur du portail d’entreprise, ouvrez le gestionnaire des services Internet (IIS).

  2. Cliquez avec le bouton droit sur le site Web de Business Portal et sélectionnez Propriétés.

  3. Dans l’onglet Répertoire de base, prenez note de la valeur de la zone « chemin local ».

  4. Dans l’onglet Répertoire de base, prenez note de la valeur dans la zone de liste déroulante « Pool d’applications ».

  5. Cliquez sur OK pour fermer la fenêtre Propriétés.

  6. Dans le gestionnaire des services Internet (IIS), développez « pools d’applications ».  Cliquez avec le bouton droit sur le pool d’applications trouvé à l’étape 4, puis sélectionnez Propriétés.

  7. Sous l’onglet identité, notez l’utilisateur spécifié comme identité du pool d’applications.

  8. Cliquez sur OK pour fermer la fenêtre Propriétés.

  9. En savoir plus sur le gestionnaire des services Internet

  10. Dans l’Explorateur Windows, accédez au répertoire indiqué à l’étape 3.

  11. Dans le dossier bin, faites défiler vers le bas et recherchez le fichier Microsoft. Solomon. PMA. Security. ImpersonateDLL. dll.

    1. Si ce fichier est manquant, il est possible que vous deviez réinstaller le portail d’entreprise.

  12. Cliquez avec le bouton droit sur le fichier, puis sélectionnez Propriétés.

  13. Dans l’onglet sécurité, assurez-vous que l’utilisateur de l’étape 7 dispose des droits lecture et lecture & « exécuter ».

  14. Cliquez sur OK pour fermer la fenêtre Propriétés.

  15. Cliquez de nouveau avec le bouton droit sur le fichier, puis sélectionnez Ouvrir avec...

  16. Sélectionnez « sélectionner le programme dans une liste ».

  17. Cliquez sur « Parcourir ».

  18. Naviguez jusqu’au dossier C:\Windows\System32 et recherchez le fichier Regsvr32. exe, puis cliquez sur Ouvrir.

  19. Cliquez sur OK.  Le message suivant doit apparaître : « DllRegisterServer dans C:\Inetpub\wwwroot\bin\Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll succeeded ».

  20. Réessayer de charger les pages du portail d’entreprise

Résolution 3 : vérifier la clé de Registre

  1. Sur le serveur du portail d’entreprise, ouvrez le gestionnaire des services Internet (IIS).

  2. Cliquez avec le bouton droit sur le site Web de Business Portal et sélectionnez Propriétés

  3. Dans l’onglet Répertoire de base, notez la valeur de la zone de liste modifiable « pool d’applications ».

  4. Cliquez sur OK pour fermer la boîte de dialogue Propriétés et quitter le gestionnaire des services Internet

  5. Cliquez sur Démarrer-> exécuter et tapez RegEdt32.  Cela devrait ouvrir l’éditeur du Registre.

  6. Accédez à HKEY_LOCAL_MACHINE \SOFTWARE\Microsoft\Business Portal\PMA\Solomon

    1. Si cette clé de Registre est manquante, voir solution 1 pour exécuter l’utilitaire PCConfiguration

  7. Cliquez avec le bouton droit sur « Solomon » et sélectionnez « autorisations ».

  8. Assurez-vous que l’utilisateur de l’étape 3 dispose des autorisations de lecture

  9. Réessayer de charger les pages du portail d’entreprise

Pour plus d’informations, voir l’Article 912363 de la base de connaissances.

Résolution 4 : vérifier le fichier CAPICOM. dll

  1. Sur le serveur du portail d’entreprise, accédez au dossier C:\Windows\System32

  2. Cliquez avec le bouton droit sur la classe CAPICOM. Fichier DLL et sélectionnez Propriétés.

    1. Si ce fichier est manquant, vous devrez peut-être copier le fichier à partir d’une autre station de travail ou réinstaller le portail d’entreprise.

  3. Dans l’onglet version, assurez-vous que la version du fichier affiche 2.1.0.1

    1. Si la version du fichier est incorrecte, vous devrez peut-être copier le fichier à partir d’une autre station de travail ou réinstaller le portail d’entreprise.

  4. Dans l’onglet sécurité, assurez-vous que le groupe DOMAIN\Users dispose des droits d’exécution en lecture et en lecture & pour ce fichier.  Voirl’article de la base de connaissances 927618

  5. Cliquez sur OK pour fermer la boîte de dialogue Propriétés.

  6. Cliquez de nouveau avec le bouton droit sur le fichier, puis sélectionnez Ouvrir avec...

  7. Sélectionnez « sélectionner le programme dans une liste ».

  8. Cliquez sur « Parcourir ».

  9. Naviguez jusqu’au dossier C:\Windows\System32 et recherchez le fichier Regsvr32. exe, puis cliquez sur Ouvrir.

  10. Cliquez sur OK.  Le message suivant doit apparaître : « DllRegisterServer dans C:\WINDOWS\system32\capicom.dll succeeded ».

  11. Réessayer de charger les pages du portail d’entreprise

  12. Si le message d’erreur persiste :

    1. Voir résolution 1 pour réexécuter l’utilitaire PCConfiguration.

    2. Redémarrez IIS en cliquant sur Démarrer > exécuter et tapez « IISReset ».

    3. Réessayer de charger les pages du portail d’entreprise

Pour plus d’informations, voir l’Article 909144 de la base de connaissances.

Résolution 5- Vérifier que le serveur IIS et SQL Server peuvent communiquer à l’aide du protocole TCP/IP

  1. Le protocole TCP/IP doit être activé sur le serveur SQL Server et sur le serveur exécutant IIS hébergeant les sites portail d’entreprise.

  2. Pour plus d’informations sur la façon de vérifier cela, voir l’article de la base de connaissances 954024

Résolution 6 : Vérifiez le chemin du fichier PCService. asx dans le fichier ProjectService. wsdl.

  1. Sur le serveur du portail d’entreprise, naviguez jusqu’au fichier ProjectService. wsdl.  Il se trouve généralement dans le répertoire C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA

  2. Ouvrez le fichier dans le bloc-notes.

  3. Faites défiler vers le bas du fichier et recherchez la balise commençant par « <SOAP : adresse emplacement = ».

  4. Il doit exister une URL vers le fichier PCService. asmx dans cette balise.  Il doit ressembler à ce qui suit : "HTTP://nomordinateur: 80/BusinessPortal/applications/PMA/PCService. asmx" cette URL comporte plusieurs exigences spécifiques.  Vérifiez et corrigez les éléments suivants selon vos besoins :

    1. L’URL doit spécifier le nom de l’ordinateur (par exemple, BPSERVER).  Les adresses IP (par exemple, 192.168.0.10), localhost ou un nom de domaine (par exemple, BP.contoso.com) ne fonctionnent pas pour les demandes SOAP.

      1. Pour trouver le nom de l’ordinateur, cliquez sur Démarrer > exécuter et tapez CMD.

      2. Tapez HOSTNAME, puis appuyez sur entrée.

      3. Le nom de l’ordinateur doit être retourné.  La valeur nomordinateur de l’URL doit être définie pour correspondre.

    2. L’URL ne doit pas utiliser SSL.  L’URL doit commencer par « http:// », mais pas « https:// »

      1. Si votre site Web est configuré pour exiger SSL, voir l’Article 924723 de la base de connaissances pour connaître les étapes de configuration d’une exception pour autoriser une connexion non SSL au fichier PCService. asmx.

    3. L’URL doit résoudre vers le site Web BusinessPortal dans IIS

      1. Il peut s’agir d’un problème si vous utilisez des en-têtes d’hébergement pour différencier les différents sites Web qui s’exécutent sur le même serveur.

      2. Pour plus d’informations, voir l’Article 2005711 de la base de connaissances.

  5. Testez l’URL pour vérifier qu’elle est valide.  Pour cela, copiez et collez l’URL dans Internet Explorer sur le serveur du portail d’entreprise.  Le message doit s’afficher « PCServices ».  Si, à la place, vous recevez une erreur SharePoint ou une erreur « la page ne peut pas être affichée », revérifiez les éléments de l’étape 4.

  6. Le fichier ProjectService. wsdl ayant désormais une URL valide, essayez à nouveau d’utiliser les pages du portail d’entreprise.

Pour plus d’informations, reportez-vous à l’article 892356 ou à la base de connaissances 897024 .

Résolution 7 : vérification de la méthode d’authentification dans les services Internet (IIS)

  1. Sur le serveur du portail d’entreprise, ouvrez le gestionnaire des services Internet (IIS).

  2. Cliquez avec le bouton droit sur le site Web de Business Portal et sélectionnez Propriétés

  3. Sous l’onglet sécurité du répertoire, dans la section « authentification et contrôle d’accès », cliquez sur modifier...

  4. Vérifier que la case à cocher authentification Windows intégrée est activée

  5. Assurez-vous que l’option « autoriser l’accès anonyme » est désactivée pour les serveurs de domaine Windows et « authentification .NET Passport ».

  6. Il n’est pas nécessaire de vérifier l’authentification de base. Toutefois, cela ne devrait pas poser de problème s’il est activé.

  7. Cliquez sur OK, puis de nouveau sur OK pour fermer la boîte de dialogue Propriétés.

  8. En savoir plus sur le gestionnaire des services Internet

  9. Redémarrez IIS en cliquant sur Démarrer > exécuter et tapez « IISReset ».

  10. Réessayer les pages du portail d’entreprise

Résolution 8 : Vérifiez la variable SessionState dans le fichier Web. config.

  1. Sur le serveur du portail d’entreprise, ouvrez le gestionnaire des services Internet (IIS).

  2. Cliquez avec le bouton droit sur le site Web de Business Portal et sélectionnez Propriétés

  3. Dans l’onglet Répertoire de base, notez la valeur de la zone « chemin local ».

  4. Cliquez sur OK pour fermer la boîte de dialogue Propriétés et quitter le gestionnaire des services Internet

  5. Naviguez jusqu’au répertoire trouvé à l’étape 3 et recherchez le fichier Web. config.

  6. Créer une copie de sauvegarde du fichier Web. config

  7. Ouvrez le fichier web.config dans le Bloc-notes

  8. Recherchez la balise qui commence par « <sessionState ».

  9. Modifiez la balise entière pour lire « <le mode sessionState = «InProc »/>».

  10. Enregistrez le fichier et fermez le bloc-notes.

  11. Redémarrez IIS en cliquant sur Démarrer > exécuter et tapez « IISReset ».

  12. Réessayer de charger les pages du portail d’entreprise

 Résolution 9 -exécutez le script PCConnectDebug et envoyez les résultats à la prise en charge. 

  1. Télécharger B2004933_pcConnectDebug. zip

  2. Décompresser le fichier sur le serveur du portail d’entreprise

  3. Copiez le fichier « pcConnectDebug. asp » dans le répertoire C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.

  4. Sur le serveur du portail d’entreprise, ouvrez Internet Explorer et connectez-vous à Business Portal

  5. Cliquez sur la page Web du centre de projets

  6. Collez l’URL suivante pour ouvrir la page PCConnectDebug : http://ServerName:port/BusinessPortal/applications/PMA/pcconnectdebug.asp remplacez le « ServerName » par le nom du serveur BP.  Remplacez le « port » par le numéro de port sur lequel s’exécute le site Web de BP.

  7. Vous êtes invité à « cliquer OK » pour continuer.  Cliquez sur OK.

  8. Une page Web s’affiche et commence par « démarrer le débogage... ».   Dans Internet Explorer, cliquez sur fichier-> enregistrer sous... Enregistrez la page dans un fichier.

    1. Avertissement: en fonction de la date à laquelle le débogage a pu atteindre, les résultats peuvent contenir un mot de passe en texte clair.  N’hésitez pas à modifier le fichier dans le bloc-notes et à remplacer le mot de passe réel par le mot « thePassword » avant de soumettre le fichier à la prise en charge.

  9. Envoyez ce fichier aux services d’assistance technique Microsoft pour analyse approfondie.

  10. Dès que le problème est résolu, supprimez le fichier pcConnectDebug. asp dans le répertoire C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA

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