Symptômes
Lorsque vous exécutez Sysprep.exe sur Microsoft Surface Pro 3, vous pouvez recevoir les messages d’erreur suivants :
Sysprep was not able to validate your Windows installation. Review the log file at %windir%\system32\Sysprep\panther\setupact.log for details. After resolving the issue use Sysprep to validate your installation again. Reviewing the setupact.log may show the following errors:2014-11-03 20:57:55, Error SYSPRP BitLocker-Sysprep: BitLocker is on for the OS volume. Turn BitLocker off to run Sysprep. (0x80310039)[gle=0x00000001]2014-11-03 20:57:55, Error [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Failure occurred while executing 'ValidateBitLockerState' from C:\Windows\System32\BdeSysprep.dll; dwRet = 0x80310039[gle=0x00000001]2014-11-03 20:57:55, Error SYSPRP SysprepSession::Validate: Error in validating actions from C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x803100392014-11-03 20:57:55, Error SYSPRP RunPlatformActions:Failed while validating SysprepSession actions; dwRet = 0x803100392014-11-03 20:57:55, Error [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = 0x803100392014-11-03 20:57:55, Error [0x0f00d8] SYSPRP WinMain:Hit failure while pre-validate sysprep generalize internal providers; hr = 0x80310039If you run manage-bde -status command it will show the following:Disk volumes that can be protected withBitLocker Drive Encryption:Volume C: [OSDisk][OS Volume] Size: 118.34 GB BitLocker Version: 2.0 Conversion Status: Encryption in Progress Percentage Encrypted: 97.8% Encryption Method: AES 128 Protection Status: Protection Off Lock Status: Unlocked Identification Field: Unknown Key Protectors: None Found
Remarque Ce problème peut se produire sur n’importe quel système qui prend en charge la secours connectée.
Cause
Ce problème se produit car Windows démarre automatiquement le chiffrement des lecteurs à l’aide de BitLocker sur Windows 8.1 ordinateurs qui prennent en charge InstantGo (secours connecté).
Résolution
Pour résoudre ce problème, dans l’invite de commandes en tant qu’administrateur, exécutez la commande suivante :manage-bde -off c :Notes
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La commande peut prendre un certain temps pour déchiffrer entièrement le lecteur. Vous pouvez exécuter la commande manage-bde -status pour surveiller la progression.
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Une fois le déchiffrement complet terminé, vous pouvez réexécuter Sysprep.exe.
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Pour éviter ce problème lors de l’installation initiale de Windows, définissez la valeur PreventDeviceEncryption sur True dans le fichier unattend.xml pendant la phase OOBE (Out-of-Body Experience) pour générer l’image de référence. Pour plus d’informations, consultez PreventDeviceEncryption.
Informations supplémentaires
Une fois que vous avez défini la valeur dans le fichier unattend.xml, la sous-clé de Registre et l’entrée de Registre suivantes sont créées :
Sous-clé : nom HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BitLocker: PreventDeviceEncryptionType : REG_DWORDDonnées : 0x00000001