Symptômes
Après avoir installé le service de rôle serveur d’impression sur un ordinateur qui exécute Windows Server 2008, vous pouvez utiliser uniquement un compte d’administrateur pour exécuter certaines tâches liées à l’impression. Ces tâches comprennent l’installation des pilotes d’imprimante locale des files d’impression locales et des ports d’imprimante locales.
Cause
Une vérification codée de manière irréversible empêche les utilisateurs du domaine à partir de la plupart des tâches liées à l’impression.
Résolution
Après avoir installé ce correctif, vous avez un nouveau
Onglet sécurité dans les propriétés du serveur d’impression. Sur ce
L’onglet sécurité , vous pouvez utiliser le compte administrateur pour attribuer l’autorisation d’utilisateur de domaine pour effectuer les tâches qui sont liées à l’impression. Il existe plusieurs limitations après avoir installé ce correctif. Ces limitations sont les suivantes :
-
Un utilisateur délégué peut installer uniquement les pilotes d’impression qui se trouvent déjà dans le magasin de pilotes.
-
Un utilisateur délégué ne peut pas installer un pilote d’impression à distance à partir du magasin de pilotes.
-
Un utilisateur délégué ne peut pas installer un pilote d’impression à partir du magasin de pilotes dans un spouleur en cluster.
-
Un utilisateur délégué ne peut pas installer une file d’attente à l’impression à distance et ne peut pas ajouter une imprimante à distance à partir d’un ordinateur qui exécute Windows XP.
Remarque Si l’utilisateur délégué utilise un ordinateur qui exécute Windows 7 ou Windows Vista, l’utilisateur délégué peut installer une file d’attente à l’impression à distance et peut ajouter une imprimante à distance.
Remarque Par défaut, un utilisateur délégué ne dispose pas de l’autorisation Gérer les imprimantes qui sont installées sur le serveur d’impression. Toutefois, après avoir attribué une autorisation de l’utilisateur délégué au serveur d’impression, cet utilisateur ne nécessite pas d’autorisations supplémentaires pour gérer toutes les imprimantes qui sont ajoutées ultérieurement.
Informations sur le correctif
Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.
Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.
Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et support technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/? ws=supportRemarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.
D'importants correctifs de Windows Vista et Windows Server 2008 sont inclus dans les mêmes packages. Toutefois, un seul de ces produits peut être répertorié dans la page demande de correctif « ». Pour demander le package de correctif qui s’applique à Windows Vista et Windows Server 2008, sélectionnez simplement le produit figurant sur la page.
Conditions préalables
Pour appliquer ce correctif logiciel, votre ordinateur doit exécuter l’un des systèmes d’exploitation suivants :
-
Windows Server 2008
-
Windows Server 2008 Service Pack 2 (SP2)
Nécessite un redémarrage
Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.
Informations concernant le Registre
Vous ne disposez pas d’apporter de modification au Registre.
Informations sur les fichiers
La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.
Pour toutes les versions x86 prises en charge de Windows Server 2008
Nom de fichier |
Version de fichier |
Taille du fichier |
Date |
Heure |
Plateforme |
SP requis |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6001.22467 |
637,440 |
10-Jul-2009 |
11:59 |
x86 |
SP1 |
Printui.dll |
6.0.6001.22467 |
873,472 |
10-Jul-2009 |
11:59 |
x86 |
SP1 |
Pour toutes les versions basées sur les x86 de Windows Server 2008 SP2
Nom de fichier |
Version de fichier |
Taille du fichier |
Date |
Heure |
Plateforme |
SP requis |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6002.22169 |
624,128 |
10-Jul-2009 |
11:48 |
x86 |
SP2 |
Printui.dll |
6.0.6002.22169 |
873,472 |
10-Jul-2009 |
11:49 |
x86 |
SP2 |
Pour toutes les versions Itanium de Windows Server 2008 prises en charge
Nom de fichier |
Version de fichier |
Taille du fichier |
Date |
Heure |
Plateforme |
SP requis |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6001.22467 |
1,624,576 |
10-Jul-2009 |
11:56 |
IA-64 |
SP1 |
Printui.dll |
6.0.6001.22467 |
1,648,640 |
10-Jul-2009 |
11:57 |
IA-64 |
SP1 |
Pour toutes les versions Itanium et Windows Server 2008 SP2
Nom de fichier |
Version de fichier |
Taille du fichier |
Date |
Heure |
Plateforme |
SP requis |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6002.22169 |
1,624,576 |
10-Jul-2009 |
11:40 |
IA-64 |
SP2 |
Printui.dll |
6.0.6002.22169 |
1,648,640 |
10-Jul-2009 |
11:42 |
IA-64 |
SP2 |
Pour toutes les versions x64 de Windows Server 2008 prises en charge
Nom de fichier |
Version de fichier |
Taille du fichier |
Date |
Heure |
Plateforme |
SP requis |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6001.22467 |
793,088 |
10-Jul-2009 |
12:26 |
x64 |
SP1 |
Printui.dll |
6.0.6001.22467 |
987,136 |
10-Jul-2009 |
12:26 |
x64 |
SP1 |
Pour toutes les versions basées sur les x64 de Windows Server 2008 SP2
Nom de fichier |
Version de fichier |
Taille du fichier |
Date |
Heure |
Plateforme |
SP requis |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6002.22169 |
774,144 |
10-Jul-2009 |
11:54 |
x64 |
SP2 |
Printui.dll |
6.0.6002.22169 |
987,136 |
10-Jul-2009 |
11:55 |
x64 |
SP2 |
Plus d'informations
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
940724 membres du groupe utilisateurs avec pouvoir et du groupe Opérateurs d’impression ne peut pas installer des imprimantes locales sur un serveur membre Windows Server 2003
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft
État
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».