Symptômes
Prenons l’exemple du scénario suivant :
-
Vous installez le serveur de site Microsoft System Center Configuration Manager 2007 Service Pack 2 (SP2) sur un ordinateur qui exécute Windows Server 2008.
-
Vous essayez d’importer un pilote dans une image de déploiement de système d’exploitation (OSD). Le pilote est signé uniquement pour le système d’exploitation Windows 7.
Dans ce scénario, l’Assistant Importation d’un nouveau pilote échoue. En même temps, vous recevez le message d’erreur suivant :
L’Assistant Importation d’un nouveau pilote s’est terminé avec des erreurs. Pour plus d’informations sur les tâches qui n’ont pas été effectuées, consultez les détails.
Détails : Erreur : certains pilotes ne peuvent pas être importés correctement. Consultez les détails suivants. Erreur : Échec de l’importation des pilotes suivants : <fichier pilote> Le pilote sélectionné n’est applicable à aucune plateforme prise en chargeNotez que ce problème ne se produit pas si le pilote est signé pour le système d’exploitation Windows Vista et le système d’exploitation Windows 7.
Cause
L’Assistant Importation d’un nouveau pilote ne peut pas reconnaître les pilotes qui sont signés uniquement pour le système d’exploitation Windows 7.
Résolution
Informations sur le correctif logiciel
Un correctif logiciel pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est destiné à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif logiciel uniquement aux systèmes qui rencontrent ce problème spécifique.
Si le correctif logiciel est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » est disponible en haut de cet article de la Base de connaissances. Si cette section n’apparaît pas, envoyez une demande au service clientèle et au support technique Microsoft pour obtenir le correctif logiciel. Remarque Si des problèmes supplémentaires se produisent ou si un dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts de support habituels s’appliqueront aux questions et problèmes de support supplémentaires qui ne sont pas éligibles à ce correctif logiciel spécifique. Pour obtenir la liste complète des numéros de téléphone du service clientèle et du support technique Microsoft ou pour créer une demande de service distincte, visitez le site Web Microsoft suivant :http://support.microsoft.com/contactus/?ws=supportNotez que le formulaire « Téléchargement du correctif logiciel disponible » affiche les langues pour lesquelles le correctif logiciel est disponible. Si vous ne voyez pas votre langue, c’est qu’un correctif logiciel n’est pas disponible pour cette langue.
Conditions préalables
Pour appliquer ce correctif logiciel, System Center Configuration Manager Service Pack 2 (SP2) 2007 doit être installé sur l’ordinateur.
Instructions d’installation
Notez que le package de correctif logiciel suivant peut être installé sur un serveur de site System Center Configuration Manager 2007 SP2 qui exécute une version x86 d’un système d’exploitation ou une version x64 d’un système d’exploitation :
SCCM2007-SP2-KB978754-X86-ENU.msi
Nécessité de redémarrer
Vous n’avez pas besoin de redémarrer l’ordinateur après avoir appliqué ce correctif logiciel.
Informations sur le remplacement de correctif logiciel
Ce correctif logiciel ne remplace pas un correctif logiciel précédemment publié.
Informations sur les fichiers
La version anglaise de ce correctif logiciel installe des fichiers dont les attributs sont répertoriés dans les tableaux ci-dessous. Les date et heure de création de ces fichiers sont exprimées en temps universel coordonné (UTC). Les date et heure de ces fichiers s'affichent sur votre ordinateur local conformément à l'heure locale et en tenant compte de l'heure d'été. En outre, ces date et heure peuvent changer lorsque vous effectuez certaines opérations sur les fichiers.
System Center Configuration Manager notes d’informations sur les fichiers
Nom du fichier |
Version du fichier |
Taille du fichier |
Date |
Time |
Platform |
---|---|---|---|---|---|
Mcs.msi |
Non applicable |
7,266,816 |
26-Jan-2010 |
02:00 |
Non applicable |
Osdcore.dll |
4.0.6487.2115 |
575,336 |
26-Jan-2010 |
02:00 |
x86 |
Sccm2007ac-sp2-kb978754-x86.msp |
Non applicable |
467,456 |
26-Jan-2010 |
02:00 |
Non applicable |
Osdcore.dll |
4.0.6487.2115 |
2,630,504 |
26-Jan-2010 |
02:00 |
IA-64 |
Osdcore.dll |
4.0.6487.2115 |
1,165,160 |
26-Jan-2010 |
02:01 |
x64 |
État
Microsoft a confirmé l’existence de ce problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Informations supplémentaires
Vous ne pouvez pas installer le correctif logiciel décrit dans cet article sur certaines configurations de système de site. Par exemple, vous ne pouvez pas installer ce correctif logiciel sur le serveur fournisseur SMS dans la configuration suivante :
Serveur |
Description |
---|---|
Un |
Serveur de site en cours d’exécution System Center Configuration Manager 2007 SP2 |
B |
Serveur de base de données pour le serveur A |
C |
SMS serveur fournisseur qui n’est pas un serveur de système de site |
Dans cette configuration, vous ne pouvez pas installer le correctif logiciel sur le serveur C, car les fichiers binaires System Center Configuration Manager 2007 SP2 ne sont pas installés sur le serveur. Pour contourner ce problème, procédez comme suit :
-
Copiez manuellement le Osdcore.dll du serveur A vers le serveur C.
-
Redémarrez le service WMI sur le serveur C.
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Redémarrez le service exécutif SMS sur le serveur A.
Notez que nous vous recommandons de déplacer le fournisseur SMS vers le serveur serveur de site avant le processus de mise à jour pour vous assurer que le serveur fournisseur SMS est automatiquement mis à jour.
Références
Pour plus d’informations sur la terminologie des mises à jour logicielles, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft