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Symptômes

Vous pouvez rencontrer un comportement inattendu lorsque Microsoft FRx tente d’accéder à un ou plusieurs des fichiers de base de données FRx suivants :

  • Frxsys32.mdb

  • Frxque32.mdb

  • Fichiers qui ont une extension de nom de fichier .f32

Par exemple, vous pouvez rencontrer les symptômes suivants :

  • Vous recevez l’un des messages d’erreur suivants.

    Message d’erreur 1

    Erreur d’exécution « -2147467259 (80004005) » : format de base de données non reconnu.

    Message d’erreur 2

    Erreur d’exécution « 3343 » : format de base de données non reconnu.

    Message d’erreur 3

    Erreur 3709. La connexion ne peut pas être utilisée pour effectuer cette opération. Il est fermé ou non valide dans ce contexte.

  • FRx Designer peut ne pas démarrer. Lorsque vous essayez de démarrer FRx Designer, l’écran de démarrage s’affiche brièvement. Puis, il disparaît.

  • Lorsque vous générez un rapport dans Microsoft FRx Concepteur de rapports, le message d’erreur suivant s’affiche :

    Le moteur de base de données Microsoft Jet ne peut pas trouver la table d’entrée ou la requête « Utilisateurs actifs ». Assurez-vous qu’il existe et qu’il est correctement orthographié.

Lorsque vous rencontrez ces symptômes, vous ne pouvez plus utiliser Microsoft FRx. Une fois que vous avez effectué une opération compacte et de réparation sur la base de données, Microsoft FRx fonctionne comme prévu. Toutefois, vous pouvez recevoir le même message d’erreur peu de temps après.

Cause

Ce problème peut se produire si les bases de données Microsoft Jet utilisées par Microsoft FRx sont endommagées. Les problèmes suivants peuvent entraîner une altération de la base de données :

  • Fichiers système obsolètes

  • Service Packs Microsoft FRx incompatibles

  • Problèmes de connectivité réseau

  • Problèmes liés aux paramètres d’environnement

Résolution

Pour éviter ce problème, utilisez une ou plusieurs des méthodes suivantes, le cas échéant.

Méthode 1 : effectuer régulièrement une opération de compactage et de réparation sur la base de données

  1. Démarrez Microsoft FRx. Vous pouvez démarrer Microsoft FRx sur une station de travail. Ou, si Microsoft FRx est installé sur un serveur, vous pouvez démarrer Microsoft FRx sur le serveur.

  2. Cliquez sur Fichier, pointez sur Base de données FRx compacte, puis cliquez sur Base de données de l’ensemble de spécifications actuelle.

  3. Cliquez sur Oui, puis sur OK une fois l’opération terminée.

  4. Cliquez sur Fichier, pointez sur Base de données FRx compacte, puis cliquez sur Base de données système FRx.

  5. Cliquez sur Oui, puis sur OK une fois l’opération terminée.

  6. Cliquez sur Fichier, pointez sur Base de données FRx compacte, puis cliquez sur Base de données file d’attente FRx.

    Remarque La base de données de file d’attente FRx n’est disponible que si FRx Report Server est installé.

  7. Cliquez sur Oui, puis sur OK une fois l’opération terminée.

Si vous continuez à recevoir l’un des messages d’erreur mentionnés dans la section « Symptômes », exécutez la méthode 2.

Méthode 2 : vérifiez que toutes les stations de travail sur laquelle FRx Designer est installé sont à jour

Procédez comme suit sur chaque station de travail sur laquelle FRx Designer est installé :

  1. Utilisez Microsoft Update pour installer le dernier Service Pack Microsoft Windows. Pour plus d’informations sur Microsoft Update, reportez-vous au site web de Microsoft à l’adresse suivante :

    http://update.microsoft.com

  2. Obtenez et installez le dernier Service Pack Microsoft Jet. Pour obtenir les Service Packs Microsoft Jet, visitez le site Web Microsoft suivant :

    http://www.microsoft.com/downloads Pour trouver le dernier Service Pack Microsoft Jet, cliquez sur Tous les téléchargements dans la liste Recherche , tapez Mises à jour Jet, puis cliquez sur Accéder.

  3. Configurez des exclusions dans les programmes antivirus et anti-espion pour empêcher ces programmes de lire le dossier FRx SysData.

    Pour plus d’informations sur la configuration des exclusions, consultez les instructions de configuration du programme antivirus et anti-espion.

    Remarque Lorsque vous installez Microsoft FRx, assurez-vous que les programmes antivirus et anti-espion sont désactivés. Cela empêche les fichiers d’installation d’être endommagés ou bloqués pendant l’installation.

Si vous continuez à recevoir l’un des messages d’erreur mentionnés dans la section « Symptômes », exécutez la méthode 3.

Méthode 3 : Désactiver le verrouillage opportuniste sur le serveur qui héberge le dossier FRx SysData

Si vous rencontrez le comportement suivant, le verrouillage opportuniste peut être à l’origine d’une altération dans la base de données Microsoft Jet :

  • Après avoir effectué les méthodes 1 et 2, vous continuez à recevoir l’un des messages d’erreur mentionnés dans la section « Symptômes ».

  • Les fichiers qui ont une extension de nom de fichier .ldb ou .lck restent dans le dossier FRx SysData même si aucun utilisateur n’est connecté à FRx.

Ce comportement peut se produire si le serveur qui héberge le dossier FRx SysData exécute l’un des programmes suivants :

  • Microsoft Windows Server 2003 ou Windows Server 2003 Terminal Server

  • Microsoft Windows 2000 Server ou Windows 2000 Server Terminal Services

  • Serveur Citrix

Pour empêcher le verrouillage opportuniste d’endommager la base de données Microsoft Jet, installez le dernier Service Pack Windows Server. Toutefois, si le comportement mentionné dans cette section continue de se produire après l’installation du dernier Service Pack Windows Server, désactivez le verrouillage opportuniste. Pour plus d’informations sur la désactivation du verrouillage opportuniste, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft :

296264 Configuration du verrouillage opportuniste dans Windows

Les produits tiers décrits dans cet article sont fabriqués par des sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

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