Symptômes

Lorsque vous essayez de modifier des données d’entreprise dans la fenêtre Gérer le programme d’installation de l’entreprise, vous recevez le message d’erreur suivant :

La société sélectionnée est en cours de modification par un autre utilisateur

Ce problème se produit lorsque vous utilisez la gestion des réquisitions dans le portail d’entreprise pour Microsoft Dynamics GP et pour les solutions Microsoft Business - Bonne fin.Lorsque ce problème se produit, aucun autre utilisateur n’accède à ces données d’entreprise dans le Portail d’entreprise.

Cause

Le message d’erreur est dû à un enregistrement utilisateur qui n’est pas effacé de la table MultiUserManager. La table MultiUserManager est située dans la base de données Dynamics.

Résolution

Pour résoudre ce problème, suivez les étapes suivantes :

  1. Exécutez le script suivant dans SQL Analyseur de requête pour voir quels enregistrements utilisateur ne sont pas effacés dans la table MultiUserManager.

    SELECT * FROM  DYNAMICS..MultiUserManager

    Notez que le tableau MultiUserManager doit être effacé toutes les 20 minutes. Toutefois, les enregistrements utilisateur restent parfois dans la table.

  2. Pour supprimer l’enregistrement utilisateur du tableau, exécutez le script suivant.Remarque : remontez à la base de données Dynamics avant d’exécuter le script.

    DELETE DYNAMICS..MultiUserManager WHERE UserID = XXX

    Remarque Remplacer XXX par l’ID utilisateur de l’enregistrement utilisateur renvoyé à l’étape 1.

Informations supplémentaires

Procédure pour reproduire le problème

  1. Démarrez le portail d’entreprise.

  2. Cliquez sur Sites Paramètres,pointez sur la Paramètres’application, pointez sur Réquisitions,puis cliquez sur Configuration de l’entreprise.

  3. Sélectionnez une société, puis cliquez sur Modifier.

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.