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Symptômes

Lorsque vous ouvrez la page Gérer les utilisateurs du portail d’entreprise dans le portail d’entreprise de Microsoft Dynamics GP ou dans Microsoft Dynamics SL, vous recevez le message d’erreur suivant :

displayError: --- soap:Server System.Web.Services.Protocols.SoapException:Server was unable to process request. ---> Microsoft.BusinessFramework.Data.EntityDataNotFoundException: Microsoft.Applications.BusinessDesk.Dynamics.User

Cause

Ce problème se produit lorsque les conditions suivantes sont vraies :

  • L’enregistrement d’un client, d’un vendeur, d’un commercial, d’un employé, d’un utilisateur ou d’un responsable a été supprimé des bases de données du bureau principal.

  • Un utilisateur du portail d’entreprise est mappé à cet enregistrement dans le cadre d’un rôle avancé.

Étant donné que l’enregistrement a été supprimé des bases de données du bureau principal, le partie Web Part Rôles avancés n’apparaît pas à l’ouverture de la page Gérer les utilisateurs du portail d’entreprise. Par conséquent, le rôle avancé assigné ne peut pas être non attribué. Étant donné que le rôle avancé ne peut pas être non insérez, vous recevez le message d’erreur mentionné dans la section « Symptômes ».

Résolution

Pour résoudre ce problème, recherchez des rôles avancés affectés qui ne sont plus valides. Pour ce faire, exécutez l’un des scripts suivants :

  • Pour Microsoft Dynamics GP ou Microsoft Business Solutions - Great Download, téléchargez le script AdvdRoleOrphaned_GP.sql. Ensuite, exécutez le script sur la base de données Dynamics. Le fichier suivant peut être téléchargé à partir du fichier de solutions Microsoft Business Exchange Server :


    AdvdRoleOrphaned_GP.sql Date de publication : 24 janvier 2006, Microsoft a analysé ce fichier à la recherche




    de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication de ce fichier. Le fichier est conservé sur des serveurs sécurisés, ce qui empêche toute modification non autorisée du fichier.

  • Pour Microsoft Dynamics SL ou microsoft business solutions - Download, téléchargez le script AdvRoleOrphaned_SL.sql. Exécutez ensuite le script sur la base de données système. Le fichier suivant peut être téléchargé à partir du fichier de solutions Microsoft Business Exchange Server :


    AdvRoleOrphaned_SL.sql Date de publication : 24 janvier 2006, Microsoft a analysé ce fichier à la recherche




    de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication de ce fichier. Le fichier est conservé sur des serveurs sécurisés, ce qui empêche toute modification non autorisée du fichier.

Notez qu’un rapport est généré lorsque vous exécutez le script. Si le script trouve des rôles avancés qui ne sont plus valides, un script de nettoyage est fourni dans le rapport. Par exemple, le rapport de la section « Plus d’informations » fournit un script de nettoyage qui décrit la suppression d’un enregistrement.

Informations supplémentaires

Le script génère un rapport similaire à ce qui suit : Recherche d’ID utilisateur : LESSONUSER1 du type : Microsoft.Applications.BusinessDesk.Dynamics.User The Back Office/Enterprise Role LESSONUSER1 n’a pas été trouvé dans la table maître utilisateur

(SY01400).
UserID : 110A1DC6-F1E8-4892-B517-4DE353D63DDE
RoleID: 97EFA56C-75A9-489D-9ACA-2BF0DCFCA1B0
Container ID: D98C1DD4-008F-04B2-E980-0998ECF8427E
Constituent Role: <entityKey><Microsoft.Applications.BusinessDesk.Dynamics.User ID="LESSONUSER1 » /></entityKey>Pour supprimer cet enregistrement, exécutez les opérations suivantes : supprimez de


MbfRoleUser où (UserID = '110A1DC6-F1E8-4892-B517-4DE353D63DDE' et
RoleID = '97EFA56C-75A9-489D-9ACA-2BF0DCFCA1B0' et ContainerID = 'D98C1DD4-008F-04B2-E980-0998ECF8427E')

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