Vous recevez un message d’erreur « Word Impossible de rétablir une liaison DDE » dans Word



Pour obtenir une version Microsoft Word 2000 de cet article, reportez-vous à la section 189259.


Pour obtenir une version Microsoft Word 97 de cet article, reportez-vous à la section 123698.


Pour un Microsoft Word 7.0 ou une version antérieure de cet article, reportez-vous à la section 188077.

Symptômes

Lorsque vous insérez une base de données dans un document Microsoft Word ou joignez un document principal de fusion et publipostage à une source de données, vous pouvez recevoir le message d’erreur suivant, où nom du programme est le programme qui est associé à la source de données :

Impossible de rétablir une connexion DDE au nom du programme pour terminer la tâche en cours.

Cause

Ce problème peut être provoqué par une des conditions suivantes :

  • Il existe un problème de communication par échange dynamique de données (DDE).

  • Le nom de la requête ou la table contient des guillemets. Lorsque vous essayez d’insérer une requête Microsoft Access ou une table dont le nom contient des guillemets, Word ajoute un deuxième jeu de guillemets autour du nom. Parce que cette action renvoie des informations incorrectes à Access, Access ne peut pas trouver la requête ou la table et puis génère le message d’erreur.

  • Vous sélectionnez un champ Mémo ou image. Si vous sélectionnez un champ Mémo ou image à partir d’une table Microsoft Access 1.0 comme champ dans un document Word, vous recevez le message d’erreur décrit dans la section « Symptômes » de cet article. Les champs Mémo et image sont automatiquement filtrés par le menu de tri lorsque vous utilisez une table Microsoft Access 1.1 comme source de données. Word ne peut pas supprimer les noms des champs Mémo ou image de la boîte de dialogue tri pour Access 1.0. Les types de champs, dans le cadre des informations sur les fichier table de données, ne sont pas fournis par Access 1.0.

  • La base de données Access est ouverte « exclusivement » par un autre utilisateur.

Résolution

Pour résoudre ce problème, utilisez la méthode qui est associée à la cause.

Problème de communication par l’intermédiaire de DDE

Sélectionnez une autre méthode pour ouvrir la source de données. Pour ce faire, assurez-vous que la confirmation des conversions à l’ouverture située sont activée et ouvrez la source de données :

  1. Dans le menu Outils, cliquez sur Options.

  2. Cliquez sur l’onglet Général.

  3. Activez la case à cocher Confirmer la conversion à la case à cocher Ouvrir, puis cliquez sur OK.

  4. Ouvrir la source de données. Pour ce faire, utilisez une des méthodes suivantes :

    • Insérer une base de données dans un document Word :

      1. Dans la barre d’outils de base de données, cliquez sur Insérer une base de données.

        Remarque Pour afficher la barre d’outils de base de données, pointez sur Barres d’outils dans le menu Affichage, puis cliquez sur base de données.

      2. Dans la boîte de dialogue base de données, cliquez sur obtenir les données.

      3. Dans les zone type de fichiers, cliquez sur le type de fichier de données que vous avez.

      4. Cliquez sur votre fichier de données, puis cliquez sur Ouvrir.

      5. Dans la boîte de dialogue Confirmer la Source de données, cliquez sur le via la méthode DDE corriger pour votre source de données, puis cliquez sur OK.

      6. Cliquez sur Insérer des données.

        Remarque Si Word ne peut pas rétablir une connexion DDE, essayez de démarrer le programme de base de données, puis répétez les étapes précédentes. Ou bien, cliquez sur méthode via ODBC à l’étape 5.

    • Attacher une source de données à un document principal de fusion et publipostage :

      1. Ouvrez votre document principal de fusion et publipostage.

      2. Dans le menu Outils, pointez sur lettres et publipostage, puis cliquez sur Fusion et publipostage.

      3. Dans le volet Office Fusion et publipostage, cliquez sur étape 3 : sélection des destinataires, cliquez sur utiliser une liste existante, puis cliquez sur Parcourir.

      4. Dans les zone type de fichiers, cliquez sur le type de fichier de données que vous avez.

      5. Cliquez sur votre fichier de données, puis cliquez sur Ouvrir.

      6. Dans la boîte de dialogue Confirmer la Source de données, cliquez sur le via la méthode DDE corriger pour votre source de données, puis cliquez sur OK.

      7. Dans la boîte de dialogue destinataires du publipostage, cliquez sur OK.

        Remarque Si Word ne peut pas rétablir une connexion DDE, essayez de démarrer le programme de base de données, puis répétez les étapes précédentes et cliquez sur méthode via ODBC à l’étape 6.

La requête ou le nom de la Table contient des guillemets

Pour contourner ce problème, renommez la table dans Access pour utiliser des caractères d’apostrophe (') comme marqueur ou utilisez le pilote ODBC Access plutôt que DDE.

Vous sélectionnez une note ou un champ image

Pour éviter ce message d’erreur, n’essayez pas de tri Access 1.0 des tables de données à l’aide du champ Mémo ou image.

La base de données Access est ouverte exclusivement

Pour rendre possible un accès partagé à la base de données Access :

  1. Dans la boîte de dialogue base de données ouverte, cliquez pour désactiver la case à cocher Exclusive.

  2. Modifier le mode par défaut ouvrir des bases de données partagées. Pour localiser cette option dans Access 2.0, cliquez sur Options dans le menu Affichage, puis cliquez sur multi-utilisateur/ODBC dans la zone catégorie. Pour rechercher cette option dans Access 7.0, Access 97, Access 2000 ou Access 2002, cliquez sur Options dans le menu Outils, cliquez sur l’onglet Avancé, puis cliquez sur l’option partagé.

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×